directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Karasulu <aok...@bellsouth.net>
Subject Re: add entry no longer works.
Date Fri, 10 Dec 2004 19:15:12 GMT
Mark Swanson wrote:

>Hello,
>
>Somehow over the past couple of days it has become impossible to add entries 
>to eve. I thought it was me, but I've spent a few hours going over everything 
>and I'm pretty sure it's not. Here is a simple test case that used to work 
>(and works fine against OpenLDAP).
>
>Using this simple LDIF:
>
>dn: dc=home2, dc=mark
>  
>
You got a partition hanging off of

dc=mark

??

If not add should fail.  If so add should work but you need to bind to dc=mark to see that
naming context rather than jxplorer.  Try to bind to dc=mark.

Usually LDAP clients will bind to a specific namingContext referred to in the Root DSE's 
namingContexts attribute.  This is a multivalued attribute that contains DN's of namingContext
suffixes.  Meaning where the roots to the tree served by the DSA reside.  So if you list the
namingContexts you'll get this on the eample with the Apache partition added to the server:

ldapsearch -h localhost -p 10389 -s base -b "" -D 'uid=admin,ou=system'  -x -w secret '(objectClass=*)'
namingContexts

# extended LDIF
#
# LDAPv3
# base <> with scope base
# filter: (objectClass=*)
# requesting: namingContexts
#

#
dn:
namingContexts: dc=apache,dc=org
namingContexts: ou=system

# search result
search: 2
result: 0 Success

# numResponses: 2
# numEntries: 1

Check to make sure you have dc=mark as a valid namingContexts value and make sure you bind
to it as the baseDn in your client.

Alex


Mime
View raw message