directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@d-haven.org>
Subject Re: compile error (Missing JavaSchema.java, others...)
Date Wed, 01 Dec 2004 19:58:01 GMT
Alex Karasulu wrote:

> Mark,
>
> I think maven 1.0 works with 1.4 and 1.5.  I know 1.4 for certain but 
> have not tried it on 1.5. If you were only referring to the VM issues 
> I can help out on that.  Just gimme like 20-30 minutes and I can lend 
> more of a hand.  If you have a chance see if you can log into IRC here 
> irc.freenode.net #directory-dev and we can work on the issue faster. 
> My handle is aok - the only one there at the moment.

Maven 1.0 works with 1.4 for sure.  The problem is with paths with spaces.

Maven 1.0.1 fixed issues with that.  I discovered and repaired that 
issue (and submitted the fix) when Java 1.5 was first introduced.

If you take the startup script from Maven 1.0.1 and use it for Maven 
1.0--your JAVA_HOME environment variable can be set to anything and it 
will work.

>>> So there are two options here:
>>>
>>> 1). revert back to 1.0
>>> 2). put the maven.remote.repo property into your build.properties
>>>
>>>   
>>
>>
>> Since #1 will not work with jdk1.4 or jdk1.5 I tried #2. #2 did not 
>> work either. I added this line to build.properties (tried 
>> project.properties too)
>>
>> maven.remote.repo=http://cvs.apache.org/repository
>>
>> but the ldap jar still wasn't found.
>

Hmm.  Don't you have to perform the maven jar:install-snapshot for the 
ldap project in Directory?

-- 

"Programming today is a race between software engineers striving to build bigger and better
idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far,
the Universe is winning."
                - Rich Cook


Mime
View raw message