directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Swanson <m...@ScheduleWorld.com>
Subject Re: No Schema published?
Date Fri, 03 Dec 2004 20:46:35 GMT
On December 3, 2004 3:09 pm, Alex Karasulu wrote:
> 0.8.0 for sure to make anything useful.  We may not enable schema
> checking at this point but we sure do need to have a subschemaSubentry.

Completely agree.

> Lots of clients need it to create forms for adding new entries.  That's
> how they figure out the attributes needed.  Ok Mark can you file this in
> JIRA too and I'll get to it.  I'll try to get to this one soon as well.

Done.

<snip>
> The idea for using Eve is this.  If you fire it up without password info
> in the env Hashtable then on the first start the password for this admin
> user becomes the empty string and you operate as the admin all the
> time.  Meaning you don't care about security and are just using an LDAP
> namespace store.  If you do provide credentials for the admin user as
> the principal (Context.SECURITY_PRINCIPAL) in the properties file then
> this is set as the admin password when creating the entry on the first
> start.

OK - that was enough info for me to fix everything. I can now successfully do 
this:
ldapadd -p 10389 -h lin -x -D "uid=admin,ou=system" -v -W -f $*

and my existing entries are imported perfectly.

> >(I tried uid=admin,ou=system password=secret but that didn't work)
> >
> >When I try to start eve by specifying the eve/eve.properties that fails
> > too (and I can no longer connect if I do this)
> >
> >eve.properties:
> >java.naming.factory.initial=org.apache.eve.jndi.EveContextFactory
> >java.naming.security.authentication=simple
> >java.naming.security.principal=uid=admin,ou=system
> >java.naming.security.credentials=secret

I commented out credentials, and it works now with uid=admin,ou=system and a 
blank password. Also, this fixes the "cludge" as the while(true) loop in 
EnvMain has a good env with no credentials to create an InitialContext with - 
so no more errors every 20 seconds.

Cheers.


-- 
Free SyncML-capable J2ME & J2SE replacement for Exchange and Outlook
http://www.ScheduleWorld.com/
WAP: http://www.ScheduleWorld.com/sw/WAPToday?id=4000&tz=EST
WebDAV: http://www.ScheduleWorld.com/sw/webDAVDir/4000.ics
VFREEBUSY: http://www.ScheduleWorld.com/sw/freebusy/4000.ifb

Mime
View raw message