directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <aok...@bellsouth.net>
Subject FW: Maven b10 hangs on some jars
Date Sun, 15 Feb 2004 21:36:14 GMT
FYI

> -----Original Message-----
> From: Alex Karasulu [mailto:aok123@bellsouth.net]
> Sent: Sunday, February 15, 2004 4:21 PM
> To: users@maven.apache.org
> Subject: Maven b10 hangs on some jars
> 
> Hello,
> 
> I have a situation where b10 stays hung until a connection times out
> trying to resolved dependencies.  The odd thing here is that these
> dependencies like others that are resolved just fine are located in
> the cache but not in the remote repository.  For example here is the
> output from maven for a jar it finds locally but not in the remote
> repo:
> 
> <maven>
> Error retrieving artifact from
> [http://www.ibiblio.org/maven/directory/jars/eve-
> frontend-common-api-SNAPSHOT.jar]: java.lang.Exception: Can't get eve-
> frontend-common-api-SNAPSHOT.jar to C:\Documents and
> Settings\akarasulu\.maven\repository\
> directory\jars\eve-frontend-common-api-SNAPSHOT.jar
> Artifact /directory/jars/eve-frontend-common-api-SNAPSHOT.jar doesn't
> exists
> 
> in remote repository, but it exists locally
> </maven>
> 
> eve-frontend-common-api-SNAPSHOT.jar resolves just fine within a second
> or so but eve-frontend-listener-spi-SNAPSHOT.jar does not and hangs for
> a long time here:
> 
> <maven>
> Error retrieving artifact from
> [http://www.ibiblio.org/maven/directory/jars/eve-frontend-listener
> -pojo-impl-SNAPSHOT.jar]: java.net.ConnectException: Connection timed out:
> connect Artifact /directory/jars/eve-frontend-listener-pojo-impl-
> SNAPSHOT.jar doesn't exists in remote repository, but it exists locally
> </maven>
> 
> Notice the hanging jars show a ConnectionException whereas the ones that
> succeed rapidly have the generic java.lang.Exception.
> 
> When I take these hanging jars off of the <dependencies> section
> everything goes through just fine.  When I add them back again then it
> just starts hanging again ultimately blowing the following stack trace:
> 
> java.lang.reflect.InvocationTargetException
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
> java:39)
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
> sorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:324)
>         at com.werken.forehead.Forehead.run(Forehead.java:543)
>         at com.werken.forehead.Forehead.main(Forehead.java:573)
> Caused by: java.lang.NoClassDefFoundError:
> org/apache/xerces/xni/parser/XMLParse
> Exception
>         at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown
> Source)
>         at javax.xml.parsers.SAXParser.parse(Unknown Source)
>         at
> org.apache.maven.plugin.PluginCacheManager.parse(PluginCacheManager.j
> ava:361)
>         at
> org.apache.maven.plugin.PluginManager.loadJellyScript(PluginManager.j
> ava:467)
>         at
> org.apache.maven.MavenSession.loadJellyScript(MavenSession.java:282)
>         at
> org.apache.maven.project.Project.loadJellyScript(Project.java:1530)
>         at
> org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:
> 375)
>         at
> org.apache.maven.MavenSession.attainGoals(MavenSession.java:348)
>         at org.apache.maven.cli.App.doMain(App.java:525)
>         at org.apache.maven.cli.App.main(App.java:1088)
>         ... 6 more
> 
> Question is why would maven pick out these jars and behave differently?
> What can I do to get back on track with my development?
> 
> Alex
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org




Mime
View raw message