directory-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From elecha...@apache.org
Subject svn commit: r1646306 - in /directory/studio/branches/studio-tycho/plugins: common.ui/ connection.ui/ ldapbrowser.common/ ldapbrowser.core/
Date Wed, 17 Dec 2014 18:36:01 GMT
Author: elecharny
Date: Wed Dec 17 18:36:00 2014
New Revision: 1646306

URL: http://svn.apache.org/r1646306
Log:
Added some new pom-first files

Added:
    directory/studio/branches/studio-tycho/plugins/common.ui/pom-first.xml
    directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/pom-first.xml
    directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/pom-first.xml
Modified:
    directory/studio/branches/studio-tycho/plugins/common.ui/pom.xml
    directory/studio/branches/studio-tycho/plugins/connection.ui/pom-first.xml
    directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/pom.xml
    directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/pom.xml

Added: directory/studio/branches/studio-tycho/plugins/common.ui/pom-first.xml
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/common.ui/pom-first.xml?rev=1646306&view=auto
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/common.ui/pom-first.xml (added)
+++ directory/studio/branches/studio-tycho/plugins/common.ui/pom-first.xml Wed Dec 17 18:36:00 2014
@@ -0,0 +1,73 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+  Licensed to the Apache Software Foundation (ASF) under one or more
+  contributor license agreements.  See the NOTICE file distributed with
+  this work for additional information regarding copyright ownership.
+  The ASF licenses this file to You under the Apache License, Version 2.0
+  (the "License"); you may not use this file except in compliance with
+  the License.  You may obtain a copy of the License at
+
+  http://www.apache.org/licenses/LICENSE-2.0
+
+  Unless required by applicable law or agreed to in writing, software
+  distributed under the License is distributed on an "AS IS" BASIS,
+  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+  See the License for the specific language governing permissions and
+  limitations under the License.
+-->
+<!--
+  @author <a href="mailto:dev@directory.apache.org">Apache Directory Project</a>
+-->
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
+  <modelVersion>4.0.0</modelVersion>
+  <parent>
+    <groupId>org.apache.directory.studio</groupId>
+    <artifactId>parent-plugins</artifactId>
+    <version>2.0.0-SNAPSHOT</version>
+    <relativePath>../pom-first.xml</relativePath>
+  </parent>
+
+  <artifactId>org.apache.directory.studio.common.ui</artifactId>
+  <name>Apache Directory Studio Common UI Manifest Generation</name>
+  <description/>
+  <packaging>bundle</packaging>
+
+  <build>
+     <!-- MANIFEST.MF Generation -->
+    <plugins>
+      <plugin>
+        <groupId>org.apache.felix</groupId>
+        <artifactId>maven-bundle-plugin</artifactId>
+        <extensions>true</extensions>
+        <configuration>
+          <manifestLocation>META-INF</manifestLocation>
+          <instructions>
+            <Bundle-SymbolicName>${project.artifactId};singleton:=true</Bundle-SymbolicName>
+            <Bundle-Localization>plugin</Bundle-Localization>
+            <Eclipse-LazyStart>true</Eclipse-LazyStart>
+            <Bundle-Activator>org.apache.directory.studio.common.ui.CommonUIPlugin</Bundle-Activator>
+            
+            <Export-Package>org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.common.ui.filesystem,
+ org.apache.directory.studio.common.ui.widgets</Export-Package>
+ 
+            <Require-Bundle>org.eclipse.core.runtime,
+ org.eclipse.ui,
+ org.eclipse.ui.editors</Require-Bundle>
+          </instructions>
+        </configuration>
+        <executions>
+          <execution>
+            <id>generate-manifest</id>
+            <phase>process-classes</phase>
+            <goals>
+              <goal>manifest</goal>
+            </goals>
+          </execution>
+        </executions>
+      </plugin>
+    </plugins>
+  </build>
+
+</project>
+

Modified: directory/studio/branches/studio-tycho/plugins/common.ui/pom.xml
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/common.ui/pom.xml?rev=1646306&r1=1646305&r2=1646306&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/common.ui/pom.xml (original)
+++ directory/studio/branches/studio-tycho/plugins/common.ui/pom.xml Wed Dec 17 18:36:00 2014
@@ -32,210 +32,4 @@
   <packaging>eclipse-plugin</packaging>
 
   <description />
-
-<!--   <build> -->
-<!--     <resources> -->
-<!--       <resource> -->
-<!--         <directory>.</directory> -->
-<!--         <includes> -->
-<!--           <include>plugin*.properties</include> -->
-<!--           <include>plugin.xml</include> -->
-<!--         </includes> -->
-<!--       </resource> -->
-<!--       <resource> -->
-<!--         <directory>resources</directory> -->
-<!--         <targetPath>resources</targetPath> -->
-<!--       </resource> -->
-<!--       <resource> -->
-<!--         <directory>src/main/resources</directory> -->
-<!--       </resource> -->
-<!--       <resource> -->
-<!--         <directory>src/main/java</directory> -->
-<!--         <includes> -->
-<!--           <include>**/*.properties</include> -->
-<!--         </includes> -->
-<!--       </resource> -->
-<!--     </resources> -->
-<!--     <plugins> -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.maven.plugins</groupId> -->
-<!--         <artifactId>maven-eclipse-plugin</artifactId> -->
-<!--         <configuration> -->
-<!--           <skip>false</skip> -->
-<!--           <pde>true</pde> -->
-<!--           <additionalProjectnatures> -->
-<!--             <projectnature>org.eclipse.pde.PluginNature</projectnature> -->
-<!--             <projectnature>org.eclipse.jdt.core.javanature</projectnature> -->
-<!--           </additionalProjectnatures> -->
-<!--           <classpathContainers> -->
-<!--             <classpathContainer>org.eclipse.jdt.launching.JRE_CONTAINER</classpathContainer> -->
-<!--             <classpathContainer>org.eclipse.pde.core.requiredPlugins</classpathContainer> -->
-<!--           </classpathContainers> -->
-<!--         </configuration> -->
-<!--       </plugin> -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.directory.studio</groupId> -->
-<!--         <artifactId>studio-maven-plugin</artifactId> -->
-<!--         <configuration> -->
-<!--           <skip>false</skip> -->
-<!--           <createManifest>true</createManifest> -->
-<!--         </configuration> -->
-<!--         <executions> -->
-<!--           <execution> -->
-<!--             <goals> -->
-<!--               <goal>prepare-jar-package</goal> -->
-<!--             </goals> -->
-<!--           </execution> -->
-<!--         </executions> -->
-<!--       </plugin> -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.maven.plugins</groupId> -->
-<!--         <artifactId>maven-jar-plugin</artifactId> -->
-<!--         <configuration> -->
-<!--           <archive> -->
-<!--             <manifestFile>META-INF/MANIFEST.MF</manifestFile> -->
-<!--             <addMavenDescriptor>false</addMavenDescriptor> -->
-<!--           </archive> -->
-<!--         </configuration> -->
-<!--       </plugin> -->
-     <!-- MANIFEST.MF Generation -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.felix</groupId> -->
-<!--         <artifactId>maven-bundle-plugin</artifactId> -->
-<!--         <extensions>true</extensions> -->
-<!--         <configuration> -->
-<!--           <manifestLocation>META-INF</manifestLocation> -->
-<!--           <instructions>             -->
-<!--             <Bundle-SymbolicName>${project.groupId}.${project.artifactId};singleton:=true</Bundle-SymbolicName> -->
-<!--             <Bundle-Localization>plugin</Bundle-Localization> -->
-<!--             <Eclipse-LazyStart>true</Eclipse-LazyStart> -->
-<!--             <Bundle-Activator>org.apache.directory.studio.common.ui.CommonUIPlugin</Bundle-Activator> -->
-<!--             <Require-Bundle>org.eclipse.core.runtime, -->
-<!--  org.eclipse.ui, -->
-<!--  org.eclipse.ui.editors</Require-Bundle> -->
-<!--             <Export-Package>org.apache.directory.studio.*</Export-Package> -->
-<!--             <Import-Package>!</Import-Package> -->
-<!--             <Private-Package>!</Private-Package> -->
-<!--           </instructions> -->
-<!--         </configuration> -->
-<!--         <executions> -->
-<!--           <execution> -->
-<!--             <id>generate-manifest</id> -->
-<!--             <phase>process-classes</phase> -->
-<!--             <goals> -->
-<!--               <goal>manifest</goal> -->
-<!--             </goals> -->
-<!--           </execution> -->
-<!--         </executions> -->
-<!--       </plugin> -->
-      <!-- No tests to run -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.maven.plugins</groupId> -->
-<!--         <artifactId>maven-surefire-plugin</artifactId> -->
-<!--         <configuration> -->
-<!--           <skip>true</skip> -->
-<!--         </configuration> -->
-<!--       </plugin> -->
-<!--     </plugins> -->
-<!--     <pluginManagement> -->
-<!--       <plugins> -->
-<!--         <plugin> -->
-<!--           <groupId>org.apache.rat</groupId> -->
-<!--           <artifactId>apache-rat-plugin</artifactId> -->
-<!--           <configuration> -->
-<!--             <excludeSubProjects>false</excludeSubProjects> -->
-<!--             <excludes> -->
-              <!-- MAVEN_DEFAULT_EXCLUDES -->
-<!--               <exclude>**/target/**/*</exclude> -->
-<!--               <exclude>**/cobertura.ser</exclude> -->
-              <!-- ECLIPSE_DEFAULT_EXCLUDES -->
-<!--               <exclude>**/.classpath</exclude> -->
-<!--               <exclude>**/.project</exclude> -->
-<!--               <exclude>**/.settings/**/*</exclude> -->
-              <!-- IDEA_DEFAULT_EXCLUDES -->
-<!--               <exclude>**/*.iml</exclude> -->
-<!--               <exclude>**/*.ipr</exclude> -->
-<!--               <exclude>**/*.iws</exclude> -->
-              <!-- MANIFEST_MF_EXCLUDES -->
-<!--               <exclude>**/MANIFEST.MF</exclude> -->
-              <!-- Missing license header in dependency reduced pom, see http://jira.codehaus.org/browse/MSHADE-48 -->
-<!--               <exclude>**/dependency-reduced-pom.xml</exclude> -->
-              <!-- GITIGNORE_EXCLUDES -->
-<!--               <exclude>**/.gitignore</exclude> -->
-              <!-- ABOUT_EXCLUDES -->
-<!--               <exclude>**/about.ini</exclude> -->
-<!--               <exclude>**/about_files/*</exclude> -->
-              <!-- LOG_FILES_EXCLUDES -->
-<!--               <exclude>**/*.log</exclude> -->
-<!--               <exclude>**/*.vm</exclude> -->
-              <!-- OTHER_EXCLUDES -->
-<!--               <exclude>src/main/java/org/apache/directory/studio/common/ui/filesystem/PathEditorInput.java</exclude> -->
-<!--               <exclude>**/*.launch</exclude> -->
-<!--               <exclude>**/maven-eclipse.xml</exclude> -->
-<!--             </excludes> -->
-<!--           </configuration> -->
-<!--          </plugin> -->
-<!--       </plugins> -->
-<!--     </pluginManagement> -->
-<!--   </build> -->
-
-<!--   <dependencies> -->
-	<!-- Eclipse plugins dependencies -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.swt.gtk.linux</groupId> -->
-<!--       <artifactId>x86</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.ui</groupId> -->
-<!--       <artifactId>workbench</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.core</groupId> -->
-<!--       <artifactId>commands</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.core</groupId> -->
-<!--       <artifactId>runtime</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.core</groupId> -->
-<!--       <artifactId>jobs</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.equinox</groupId> -->
-<!--       <artifactId>registry</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.equinox</groupId> -->
-<!--       <artifactId>common</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse</groupId> -->
-<!--       <artifactId>osgi</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse</groupId> -->
-<!--       <artifactId>jface</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse</groupId> -->
-<!--       <artifactId>ui</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.ui</groupId> -->
-<!--       <artifactId>editors</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--   </dependencies> -->
-
 </project>
\ No newline at end of file

Modified: directory/studio/branches/studio-tycho/plugins/connection.ui/pom-first.xml
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/connection.ui/pom-first.xml?rev=1646306&r1=1646305&r2=1646306&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/connection.ui/pom-first.xml (original)
+++ directory/studio/branches/studio-tycho/plugins/connection.ui/pom-first.xml Wed Dec 17 18:36:00 2014
@@ -28,7 +28,7 @@
   </parent>
 
   <artifactId>org.apache.directory.studio.connection.ui</artifactId>
-  <description>The studio connection UI Manifest Generation</description>
+  <name>Apache Directory Studio Connection UI Manifest Generation</name>
   <packaging>bundle</packaging>
 
   <build>

Added: directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/pom-first.xml
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/pom-first.xml?rev=1646306&view=auto
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/pom-first.xml (added)
+++ directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/pom-first.xml Wed Dec 17 18:36:00 2014
@@ -0,0 +1,97 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+  Licensed to the Apache Software Foundation (ASF) under one or more
+  contributor license agreements.  See the NOTICE file distributed with
+  this work for additional information regarding copyright ownership.
+  The ASF licenses this file to You under the Apache License, Version 2.0
+  (the "License"); you may not use this file except in compliance with
+  the License.  You may obtain a copy of the License at
+
+  http://www.apache.org/licenses/LICENSE-2.0
+
+  Unless required by applicable law or agreed to in writing, software
+  distributed under the License is distributed on an "AS IS" BASIS,
+  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+  See the License for the specific language governing permissions and
+  limitations under the License.
+-->
+<!--
+  @author <a href="mailto:dev@directory.apache.org">Apache Directory Project</a>
+-->
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
+  <modelVersion>4.0.0</modelVersion>
+  <parent>
+    <groupId>org.apache.directory.studio</groupId>
+    <artifactId>parent-plugins</artifactId>
+    <version>2.0.0-SNAPSHOT</version>
+    <relativePath>../pom-first.xml</relativePath>
+  </parent>
+
+  <artifactId>org.apache.directory.studio.ldapbrowser.common</artifactId>
+  <name>Apache Directory Studio LDAP Browser Common Manifest Generation</name>
+  <description/>
+  <packaging>bundle</packaging>
+
+  <build>
+     <!-- MANIFEST.MF Generation -->
+    <plugins>
+      <plugin>
+        <groupId>org.apache.felix</groupId>
+        <artifactId>maven-bundle-plugin</artifactId>
+        <extensions>true</extensions>
+        <configuration>
+          <manifestLocation>META-INF</manifestLocation>
+          <instructions>
+            <Bundle-SymbolicName>${project.artifactId};singleton:=true</Bundle-SymbolicName>
+            <Bundle-Localization>plugin</Bundle-Localization>
+            <Eclipse-LazyStart>true</Eclipse-LazyStart>
+            <Bundle-Activator>org.apache.directory.studio.ldapbrowser.common.BrowserCommonActivator</Bundle-Activator>
+            
+            <Export-Package>org.apache.directory.studio.ldapbrowser.common,
+ org.apache.directory.studio.ldapbrowser.common.actions,
+ org.apache.directory.studio.ldapbrowser.common.actions.proxy,
+ org.apache.directory.studio.ldapbrowser.common.dialogs,
+ org.apache.directory.studio.ldapbrowser.common.dialogs.preferences,
+ org.apache.directory.studio.ldapbrowser.common.dnd,
+ org.apache.directory.studio.ldapbrowser.common.filtereditor,
+ org.apache.directory.studio.ldapbrowser.common.widgets,
+ org.apache.directory.studio.ldapbrowser.common.widgets.browser,
+ org.apache.directory.studio.ldapbrowser.common.widgets.entryeditor,
+ org.apache.directory.studio.ldapbrowser.common.widgets.search,
+ org.apache.directory.studio.ldapbrowser.common.wizards,
+ org.apache.directory.studio.valueeditors</Export-Package>
+ 
+            <Import-Package>org.eclipse.core.runtime,
+ org.eclipse.core.expressions,
+ org.eclipse.jface.text,
+ org.eclipse.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.workbench.texteditor,
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.ldapbrowser.core,
+ org.apache.directory.studio.ldifparser,
+ org.apache.directory.api.ldap.model;bundle-version="${org.apache.directory.api.bundleversion}",
+ org.apache.directory.api.util;bundle-version="${org.apache.directory.api.bundleversion}"</Import-Package>
+            
+            <Require-Bundle>org.apache.commons.lang,
+ org.apache.commons.io</Require-Bundle>
+          </instructions>
+        </configuration>
+        <executions>
+          <execution>
+            <id>generate-manifest</id>
+            <phase>process-classes</phase>
+            <goals>
+              <goal>manifest</goal>
+            </goals>
+          </execution>
+        </executions>
+      </plugin>
+    </plugins>
+  </build>
+
+</project>
+

Modified: directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/pom.xml
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/pom.xml?rev=1646306&r1=1646305&r2=1646306&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/pom.xml (original)
+++ directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/pom.xml Wed Dec 17 18:36:00 2014
@@ -32,258 +32,4 @@
   <packaging>eclipse-plugin</packaging>
 
   <description />
-  
-<!--   <build> -->
-<!--     <resources> -->
-<!--       <resource> -->
-<!--         <directory>.</directory> -->
-<!--         <includes> -->
-<!--           <include>plugin*.properties</include> -->
-<!--           <include>plugin.xml</include> -->
-<!--         </includes> -->
-<!--       </resource> -->
-<!--       <resource> -->
-<!--         <directory>resources</directory> -->
-<!--         <targetPath>resources</targetPath> -->
-<!--       </resource> -->
-<!--       <resource> -->
-<!--         <directory>src/main/resources</directory> -->
-<!--       </resource> -->
-<!--       <resource> -->
-<!--         <directory>src/main/java</directory> -->
-<!--         <includes> -->
-<!--           <include>**/*.properties</include> -->
-<!--         </includes> -->
-<!--       </resource> -->
-<!--     </resources> -->
-<!--     <plugins> -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.maven.plugins</groupId> -->
-<!--         <artifactId>maven-eclipse-plugin</artifactId> -->
-<!--         <configuration> -->
-<!--           <skip>false</skip> -->
-<!--           <pde>true</pde> -->
-<!--           <additionalProjectnatures> -->
-<!--             <projectnature>org.eclipse.pde.PluginNature</projectnature> -->
-<!--             <projectnature>org.eclipse.jdt.core.javanature</projectnature> -->
-<!--           </additionalProjectnatures> -->
-<!--           <classpathContainers> -->
-<!--             <classpathContainer>org.eclipse.jdt.launching.JRE_CONTAINER</classpathContainer> -->
-<!--             <classpathContainer>org.eclipse.pde.core.requiredPlugins</classpathContainer> -->
-<!--           </classpathContainers> -->
-<!--         </configuration> -->
-<!--       </plugin> -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.directory.studio</groupId> -->
-<!--         <artifactId>studio-maven-plugin</artifactId> -->
-<!--         <configuration> -->
-<!--           <skip>false</skip> -->
-<!--           <createManifest>true</createManifest> -->
-<!--         </configuration> -->
-<!--         <executions> -->
-<!--           <execution> -->
-<!--             <goals> -->
-<!--               <goal>prepare-jar-package</goal> -->
-<!--             </goals> -->
-<!--           </execution> -->
-<!--         </executions> -->
-<!--       </plugin> -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.maven.plugins</groupId> -->
-<!--         <artifactId>maven-jar-plugin</artifactId> -->
-<!--         <configuration> -->
-<!--           <archive> -->
-<!--             <manifestFile>META-INF/MANIFEST.MF</manifestFile> -->
-<!--             <addMavenDescriptor>false</addMavenDescriptor> -->
-<!--           </archive> -->
-<!--         </configuration> -->
-<!--       </plugin> -->
-      <!-- MANIFEST.MF Generation -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.felix</groupId> -->
-<!--         <artifactId>maven-bundle-plugin</artifactId> -->
-<!--         <extensions>true</extensions> -->
-<!--         <configuration> -->
-<!--           <manifestLocation>META-INF</manifestLocation> -->
-<!--           <instructions>             -->
-<!--             <Bundle-SymbolicName>${project.groupId}.${project.artifactId};singleton:=true</Bundle-SymbolicName> -->
-<!--             <Bundle-Localization>plugin</Bundle-Localization> -->
-<!--             <Eclipse-LazyStart>true</Eclipse-LazyStart> -->
-<!--             <Bundle-Activator>org.apache.directory.studio.ldapbrowser.common.BrowserCommonActivator</Bundle-Activator> -->
-<!--             <Require-Bundle>org.apache.directory.studio.common.core, -->
-<!--  org.apache.directory.studio.common.ui, -->
-<!--  org.apache.directory.studio.connection.core, -->
-<!--  org.apache.directory.studio.connection.ui, -->
-<!--  org.apache.directory.studio.ldapbrowser.core, -->
-<!--  org.apache.directory.studio.ldifparser, -->
-<!--  org.apache.commons.io;bundle-version="${org.apache.commons.io.version}", -->
-<!--  org.apache.commons.lang;bundle-version="${org.apache.commons.lang.version}", -->
-<!--  org.apache.directory.api.ldap.model;bundle-version="${org.apache.directory.api.validversion}", -->
-<!--  org.apache.directory.api.util;bundle-version="${org.apache.directory.api.validversion}", -->
-<!--  org.eclipse.core.runtime, -->
-<!--  org.eclipse.core.expressions, -->
-<!--  org.eclipse.jface.text, -->
-<!--  org.eclipse.ui, -->
-<!--  org.eclipse.ui.editors, -->
-<!--  org.eclipse.ui.workbench.texteditor</Require-Bundle> -->
-<!--             <Export-Package>org.apache.directory.studio.ldapbrowser.common.*, org.apache.directory.studio.valueeditors.*</Export-Package> -->
-<!--             <Import-Package>!*</Import-Package> -->
-<!--           </instructions> -->
-<!--         </configuration> -->
-<!--         <executions> -->
-<!--           <execution> -->
-<!--             <id>generate-manifest</id> -->
-<!--             <phase>process-classes</phase> -->
-<!--             <goals> -->
-<!--               <goal>manifest</goal> -->
-<!--             </goals> -->
-<!--           </execution> -->
-<!--         </executions> -->
-<!--       </plugin> -->
-<!--     </plugins> -->
-<!--   </build> -->
-
-<!--   <dependencies> -->
-    <!-- Apache Directory Studio library plugins dependencies -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>org.apache.commons.io</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-    
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>org.apache.commons.lang</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-    
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.api</groupId> -->
-<!--       <artifactId>api-ldap-model</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-    
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.api</groupId> -->
-<!--       <artifactId>api-util</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-    
-    <!-- Apache Directory Studio plugins dependencies -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>common.core</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>common.ui</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>connection.core</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>connection.ui</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>ldapbrowser.core</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>ldifparser</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-    
-	<!-- Eclipse plugins dependencies -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse</groupId> -->
-<!--       <artifactId>jface</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.jface</groupId> -->
-<!--       <artifactId>text</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse</groupId> -->
-<!--       <artifactId>text</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.ui.workbench</groupId> -->
-<!--       <artifactId>texteditor</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.ui</groupId> -->
-<!--       <artifactId>workbench</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.ui</groupId> -->
-<!--       <artifactId>editors</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.core</groupId> -->
-<!--       <artifactId>commands</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.core</groupId> -->
-<!--       <artifactId>jobs</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.core</groupId> -->
-<!--       <artifactId>runtime</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.update</groupId> -->
-<!--       <artifactId>core</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse</groupId> -->
-<!--       <artifactId>osgi</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.equinox</groupId> -->
-<!--       <artifactId>common</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.equinox</groupId> -->
-<!--       <artifactId>registry</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.equinox</groupId> -->
-<!--       <artifactId>preferences</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.swt.gtk.linux</groupId> -->
-<!--       <artifactId>x86</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-    
-    <!-- JUnit for test only -->
-<!--     <dependency> -->
-<!--       <groupId>junit</groupId> -->
-<!--       <artifactId>junit</artifactId> -->
-<!--       <scope>test</scope> -->
-<!--     </dependency> -->
-<!--   </dependencies> -->
-
 </project>

Added: directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/pom-first.xml
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/pom-first.xml?rev=1646306&view=auto
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/pom-first.xml (added)
+++ directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/pom-first.xml Wed Dec 17 18:36:00 2014
@@ -0,0 +1,96 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+  Licensed to the Apache Software Foundation (ASF) under one or more
+  contributor license agreements.  See the NOTICE file distributed with
+  this work for additional information regarding copyright ownership.
+  The ASF licenses this file to You under the Apache License, Version 2.0
+  (the "License"); you may not use this file except in compliance with
+  the License.  You may obtain a copy of the License at
+
+  http://www.apache.org/licenses/LICENSE-2.0
+
+  Unless required by applicable law or agreed to in writing, software
+  distributed under the License is distributed on an "AS IS" BASIS,
+  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+  See the License for the specific language governing permissions and
+  limitations under the License.
+-->
+<!--
+  @author <a href="mailto:dev@directory.apache.org">Apache Directory Project</a>
+-->
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
+  <modelVersion>4.0.0</modelVersion>
+  <parent>
+    <groupId>org.apache.directory.studio</groupId>
+    <artifactId>parent-plugins</artifactId>
+    <version>2.0.0-SNAPSHOT</version>
+    <relativePath>../pom-first.xml</relativePath>
+  </parent>
+
+  <artifactId>org.apache.directory.studio.ldapbrowser.core</artifactId>
+  <name>Apache Directory Studio LDAP Browser Core</name>
+  <description/>
+  <packaging>bundle</packaging>
+
+  <build>
+     <!-- MANIFEST.MF Generation -->
+    <plugins>
+      <plugin>
+        <groupId>org.apache.felix</groupId>
+        <artifactId>maven-bundle-plugin</artifactId>
+        <extensions>true</extensions>
+        <configuration>
+          <manifestLocation>META-INF</manifestLocation>
+          <instructions>
+            <Bundle-SymbolicName>${project.artifactId};singleton:=true</Bundle-SymbolicName>
+            <Bundle-Localization>plugin</Bundle-Localization>
+            <Eclipse-LazyStart>true</Eclipse-LazyStart>
+            <Bundle-Activator>org.apache.directory.studio.ldapbrowser.core.BrowserCorePlugin</Bundle-Activator>
+            
+            <Export-Package>org.apache.directory.studio.ldapbrowser.core,
+ org.apache.directory.studio.ldapbrowser.core.events,
+ org.apache.directory.studio.ldapbrowser.core.internal.search,
+ org.apache.directory.studio.ldapbrowser.core.jobs,
+ org.apache.directory.studio.ldapbrowser.core.model,
+ org.apache.directory.studio.ldapbrowser.core.model.filter,
+ org.apache.directory.studio.ldapbrowser.core.model.filter.parser,
+ org.apache.directory.studio.ldapbrowser.core.model.impl,
+ org.apache.directory.studio.ldapbrowser.core.model.schema,
+ org.apache.directory.studio.ldapbrowser.core.propertypageproviders,
+ org.apache.directory.studio.ldapbrowser.core.utils</Export-Package>
+ 
+            <Import-Package>org.apache.commons.lang,
+ org.apache.commons.io,
+ org.apache.commons.collections,
+ org.apache.commons.codec.digest,
+ org.dom4j,
+ org.dom4j.io,
+ org.xmlpull.v1</Import-Package>
+            
+            <Require-Bundle>org.eclipse.core.runtime,
+ org.eclipse.search,
+ org.apache.directory.api.asn1.api;bundle-version="${org.apache.directory.api.bundleversion}",
+ org.apache.directory.api.ldap.model;bundle-version="${org.apache.directory.api.bundleversion}",
+ org.apache.directory.api.ldap.codec.core;bundle-version="${org.apache.directory.api.bundleversion}",
+ org.apache.directory.api.dsmlv2.parser;bundle-version="${org.apache.directory.api.bundleversion}",
+ org.apache.directory.api.util;bundle-version="${org.apache.directory.api.bundleversion}",
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.ldifparser</Require-Bundle>
+          </instructions>
+        </configuration>
+        <executions>
+          <execution>
+            <id>generate-manifest</id>
+            <phase>process-classes</phase>
+            <goals>
+              <goal>manifest</goal>
+            </goals>
+          </execution>
+        </executions>
+      </plugin>
+    </plugins>
+  </build>
+
+</project>
+

Modified: directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/pom.xml
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/pom.xml?rev=1646306&r1=1646305&r2=1646306&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/pom.xml (original)
+++ directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/pom.xml Wed Dec 17 18:36:00 2014
@@ -28,7 +28,7 @@
   </parent>
 
   <artifactId>org.apache.directory.studio.ldapbrowser.core</artifactId>
-  <name>Apache Directory Studio LDAP Browser Core</name>
+  <name>Apache Directory Studio LDAP Browser Core Manifest Generation</name>
   <packaging>eclipse-plugin</packaging>
 
   <description />
@@ -53,16 +53,19 @@
                   <artifactId>poi</artifactId>
                   <version>3.9</version>
                 </artifactItem>
+                
                 <artifactItem>
                   <groupId>org.openoffice</groupId>
                   <artifactId>odfdom</artifactId>
                   <version>0.6.16</version>
                 </artifactItem>
+                
                 <artifactItem>
                   <groupId>xerces</groupId>
                   <artifactId>xercesImpl</artifactId>
                   <version>2.11.0</version>
                 </artifactItem>
+                
                 <artifactItem>
                   <groupId>xml-apis</groupId>
                   <artifactId>xml-apis</artifactId>
@@ -74,6 +77,7 @@
         </executions>
       </plugin>
     </plugins>
+    
     <pluginManagement>
       <plugins>
         <!--This plugin's configuration is used to store Eclipse m2e settings only. It has no influence on the Maven build itself.-->
@@ -104,297 +108,4 @@
       </plugins>
     </pluginManagement>
   </build>
-  
-<!--   <build> -->
-<!--     <resources> -->
-<!--       <resource> -->
-<!--         <directory>.</directory> -->
-<!--         <includes> -->
-<!--           <include>plugin*.properties</include> -->
-<!--           <include>plugin.xml</include> -->
-<!--         </includes> -->
-<!--       </resource> -->
-<!--       <resource> -->
-<!--         <directory>src/main/resources</directory> -->
-<!--       </resource> -->
-<!--       <resource> -->
-<!--         <directory>src/main/java</directory> -->
-<!--         <includes> -->
-<!--           <include>**/*.properties</include> -->
-<!--         </includes> -->
-<!--       </resource> -->
-<!--     </resources> -->
-<!--     <plugins> -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.maven.plugins</groupId> -->
-<!--         <artifactId>maven-eclipse-plugin</artifactId> -->
-<!--         <configuration> -->
-<!--           <skip>false</skip> -->
-<!--           <pde>true</pde> -->
-<!--           <additionalProjectnatures> -->
-<!--             <projectnature>org.eclipse.pde.PluginNature</projectnature> -->
-<!--             <projectnature>org.eclipse.jdt.core.javanature</projectnature> -->
-<!--           </additionalProjectnatures> -->
-<!--           <classpathContainers> -->
-<!--             <classpathContainer>org.eclipse.jdt.launching.JRE_CONTAINER</classpathContainer> -->
-<!--             <classpathContainer>org.eclipse.jdt.junit.JUNIT_CONTAINER/3.8.1</classpathContainer> -->
-<!--             <classpathContainer>org.eclipse.pde.core.requiredPlugins</classpathContainer> -->
-<!--           </classpathContainers> -->
-<!--         </configuration> -->
-<!--       </plugin> -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.directory.studio</groupId> -->
-<!--         <artifactId>studio-maven-plugin</artifactId> -->
-<!--         <configuration> -->
-<!--           <skip>false</skip> -->
-<!--           <createManifest>true</createManifest> -->
-<!--         </configuration> -->
-<!--         <executions> -->
-<!--           <execution> -->
-<!--             <goals> -->
-<!--               <goal>prepare-jar-package</goal> -->
-<!--             </goals> -->
-<!--           </execution> -->
-<!--         </executions> -->
-<!--       </plugin> -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.maven.plugins</groupId> -->
-<!--         <artifactId>maven-jar-plugin</artifactId> -->
-<!--         <configuration> -->
-<!--           <archive> -->
-<!--             <manifestFile>META-INF/MANIFEST.MF</manifestFile> -->
-<!--             <addMavenDescriptor>false</addMavenDescriptor> -->
-<!--           </archive> -->
-<!--         </configuration> -->
-<!--       </plugin> -->
-      <!-- MANIFEST.MF Generation -->
-<!--       <plugin> -->
-<!--         <groupId>org.apache.felix</groupId> -->
-<!--         <artifactId>maven-bundle-plugin</artifactId> -->
-<!--         <extensions>true</extensions> -->
-<!--         <configuration> -->
-<!--           <manifestLocation>META-INF</manifestLocation> -->
-<!--           <instructions>             -->
-<!--             <Bundle-SymbolicName>${project.groupId}.${project.artifactId};singleton:=true</Bundle-SymbolicName> -->
-<!--             <Bundle-Localization>plugin</Bundle-Localization> -->
-<!--             <Eclipse-LazyStart>true</Eclipse-LazyStart> -->
-<!--             <Bundle-Activator>org.apache.directory.studio.ldapbrowser.core.BrowserCorePlugin</Bundle-Activator> -->
-<!--             <Require-Bundle>org.apache.commons.codec;bundle-version="${org.apache.commons.codec.version}", -->
-<!--  org.apache.commons.collections;bundle-version="${org.apache.commons.collections.version}", -->
-<!--  org.apache.commons.io;bundle-version="${org.apache.commons.io.version}", -->
-<!--  org.apache.commons.lang;bundle-version="${org.apache.commons.lang.version}", -->
-<!--  org.apache.directory.api.asn1.api;bundle-version="${org.apache.directory.api.validversion}", -->
-<!--  org.apache.directory.api.ldap.model;bundle-version="${org.apache.directory.api.validversion}", -->
-<!--  org.apache.directory.api.ldap.codec.core;bundle-version="${org.apache.directory.api.validversion}", -->
-<!--  org.apache.directory.api.dsmlv2.parser;bundle-version="${org.apache.directory.api.validversion}", -->
-<!--  org.apache.directory.api.util;bundle-version="${org.apache.directory.api.validversion}", -->
-<!--  org.apache.directory.studio.common.core, -->
-<!--  org.apache.directory.studio.connection.core, -->
-<!--  org.apache.directory.studio.ldifparser, -->
-<!--  org.dom4j.dom4j;bundle-version="${org.dom4j.version}", -->
-<!--  org.eclipse.core.runtime, -->
-<!--  org.eclipse.search, -->
-<!--  org.xpp3.xpp3;bundle-version="${org.xpp3.validversion}"</Require-Bundle> -->
-<!--             <Embed-Dependency>*;scope=compile|runtime</Embed-Dependency> -->
-<!--             <Embed-Directory>lib</Embed-Directory> -->
-<!--             <Embed-StripGroup>true</Embed-StripGroup> -->
-<!--             <Export-Package>org.apache.directory.studio.ldapbrowser.core.*</Export-Package> -->
-<!--             <Import-Package>!*</Import-Package> -->
-<!--           </instructions> -->
-<!--         </configuration> -->
-<!--         <executions> -->
-<!--           <execution> -->
-<!--             <id>generate-manifest</id> -->
-<!--             <phase>process-classes</phase> -->
-<!--             <goals> -->
-<!--               <goal>manifest</goal> -->
-<!--             </goals> -->
-<!--           </execution> -->
-<!--         </executions> -->
-<!--       </plugin> -->
-<!--     </plugins> -->
-<!--     <pluginManagement> -->
-<!--       <plugins> -->
-<!--         <plugin> -->
-<!--           <groupId>org.apache.rat</groupId> -->
-<!--           <artifactId>apache-rat-plugin</artifactId> -->
-<!--           <configuration> -->
-<!--             <excludeSubProjects>false</excludeSubProjects> -->
-<!--             <excludes> -->
-              <!-- MAVEN_DEFAULT_EXCLUDES -->
-<!--               <exclude>**/target/**/*</exclude> -->
-<!--               <exclude>**/cobertura.ser</exclude> -->
-              <!-- ECLIPSE_DEFAULT_EXCLUDES -->
-<!--               <exclude>**/.classpath</exclude> -->
-<!--               <exclude>**/.project</exclude> -->
-<!--               <exclude>**/.settings/**/*</exclude> -->
-              <!-- IDEA_DEFAULT_EXCLUDES -->
-<!--               <exclude>**/*.iml</exclude> -->
-<!--               <exclude>**/*.ipr</exclude> -->
-<!--               <exclude>**/*.iws</exclude> -->
-              <!-- MANIFEST_MF_EXCLUDES -->
-<!--               <exclude>**/MANIFEST.MF</exclude> -->
-              <!-- Missing license header in dependency reduced pom, see http://jira.codehaus.org/browse/MSHADE-48 -->
-<!--               <exclude>**/dependency-reduced-pom.xml</exclude> -->
-              <!-- GITIGNORE_EXCLUDES -->
-<!--               <exclude>**/.gitignore</exclude> -->
-              <!-- ABOUT_EXCLUDES -->
-<!--               <exclude>**/about.ini</exclude> -->
-<!--               <exclude>**/about_files/*</exclude> -->
-              <!-- LOG_FILES_EXCLUDES -->
-<!--               <exclude>**/*.log</exclude> -->
-<!--               <exclude>**/*.vm</exclude> -->
-              <!-- OTHER_EXCLUDES -->
-<!--               <exclude>src/main/resources/default_schema.ldif</exclude> -->
-<!--             </excludes> -->
-<!--           </configuration> -->
-<!--          </plugin> -->
-<!--       </plugins> -->
-<!--     </pluginManagement> -->
-<!--   </build> -->
-
-<!--   <dependencies> -->
-  	<!-- Libraries dependencies -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.poi</groupId> -->
-<!--       <artifactId>poi</artifactId> -->
-<!--       <exclusions> -->
-<!--         <exclusion> -->
-<!--           <groupId>commons-logging</groupId> -->
-<!--           <artifactId>commons-logging</artifactId> -->
-<!--         </exclusion> -->
-<!--         <exclusion> -->
-<!--           <groupId>log4j</groupId> -->
-<!--           <artifactId>log4j</artifactId> -->
-<!--         </exclusion> -->
-<!--       </exclusions> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.openoffice</groupId> -->
-<!--       <artifactId>odfdom</artifactId> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>xerces</groupId> -->
-<!--       <artifactId>xercesImpl</artifactId> -->
-<!--     </dependency> -->
-    
-    <!-- Apache Directory Studio library plugins dependencies -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.api</groupId> -->
-<!--       <artifactId>api-dsml-parser</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.api</groupId> -->
-<!--       <artifactId>api-asn1-api</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.api</groupId> -->
-<!--       <artifactId>api-ldap-codec-core</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.api</groupId> -->
-<!--       <artifactId>api-ldap-model</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.api</groupId> -->
-<!--       <artifactId>api-util</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>org.apache.commons.codec</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>org.apache.commons.collections</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>org.apache.commons.io</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>org.apache.commons.lang</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>org.dom4j.dom4j</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>org.xpp3.xpp3</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-  
-  	<!-- Apache Directory Studio plugins dependencies -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>connection.core</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>common.core</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.apache.directory.studio</groupId> -->
-<!--       <artifactId>ldifparser</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-    
-	<!-- Eclipse plugins dependencies -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse</groupId> -->
-<!--       <artifactId>osgi</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse</groupId> -->
-<!--       <artifactId>search</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse</groupId> -->
-<!--       <artifactId>text</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.core</groupId> -->
-<!--       <artifactId>jobs</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.core</groupId> -->
-<!--       <artifactId>runtime</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.equinox</groupId> -->
-<!--       <artifactId>common</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-<!--     <dependency> -->
-<!--       <groupId>org.eclipse.equinox</groupId> -->
-<!--       <artifactId>preferences</artifactId> -->
-<!--       <scope>provided</scope> -->
-<!--     </dependency> -->
-    
-  	<!-- JUnit for test only -->
-<!--     <dependency> -->
-<!--       <groupId>junit</groupId> -->
-<!--       <artifactId>junit</artifactId> -->
-<!--       <scope>test</scope> -->
-<!--     </dependency> -->
-<!--   </dependencies> -->
-
 </project>



Mime
View raw message