directory-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From elecha...@apache.org
Subject svn commit: r1643864 - in /directory/studio/branches/studio-tycho/plugins: aciitemeditor/META-INF/ apacheds.configuration.v2/META-INF/ apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/ apacheds.config...
Date Mon, 08 Dec 2014 16:54:13 GMT
Author: elecharny
Date: Mon Dec  8 16:54:12 2014
New Revision: 1643864

URL: http://svn.apache.org/r1643864
Log:
Replaced SNAPSHOT by qualifier in the MANIFEST.MF files, added some missing imports (xerces, odfdom, poi)

Modified:
    directory/studio/branches/studio-tycho/plugins/aciitemeditor/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/OverviewPage.java
    directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/ServerConfigurationEditorPage.java
    directory/studio/branches/studio-tycho/plugins/apacheds.configuration/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/common.core/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/common.ui/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/connection.core/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/connection.ui/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/ldapbrowser.ui/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v153/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v154/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v155/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/ldapservers/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/ldifeditor/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/ldifparser/META-INF/MANIFEST.MF
    directory/studio/branches/studio-tycho/plugins/valueeditors/META-INF/MANIFEST.MF

Modified: directory/studio/branches/studio-tycho/plugins/aciitemeditor/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/aciitemeditor/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/aciitemeditor/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/aciitemeditor/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,28 +1,33 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio ACI Item Editor
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.aciitemeditor;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.aciitemeditor.Activator
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.aciitemeditor
-Require-Bundle: org.eclipse.core.runtime,
- org.apache.directory.api.ldap.extras.aci;bundle-version="1.0.0.M24",
- org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- org.apache.directory.studio.connection.ui,
- org.apache.directory.studio.ldapbrowser.common,
- org.apache.directory.studio.ldapbrowser.core,
- org.apache.directory.studio.valueeditors,
- org.eclipse.core.expressions,
- org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.eclipse.jface.text,
- org.eclipse.ui,
- org.eclipse.ui.editors,
- org.eclipse.ui.workbench.texteditor
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio ACI Item Editor
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.aciitemeditor;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.aciitemeditor.Activator
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.aciitemeditor
+Require-Bundle: org.eclipse.core.runtime,
+ org.apache.directory.api.ldap.extras.aci;bundle-version="1.0.0.M24",
+ org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.ldapbrowser.common,
+ org.apache.directory.studio.ldapbrowser.core,
+ org.apache.directory.studio.valueeditors,
+ org.eclipse.core.expressions,
+ org.eclipse.core.resources,
+ org.eclipse.core.runtime,
+ org.eclipse.jface.text,
+ org.eclipse.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.workbench.texteditor
+Bundle-ClassPath: .,
+ poi-3.9.jar,
+ odfdom-0.6.16.jar,
+ xercesImpl-2.11.0.jar,
+ xml-apis-1.4.01.jar

Modified: directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,47 +1,52 @@
-manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio ApacheDS 2.0 Configuration
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.apacheds.configuration.v2;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.apacheds.configuration.v2.ApacheDS2ConfigurationPlugin
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.apacheds.configuration.v2,
- org.apache.directory.studio.apacheds.configuration.v2.actions,
- org.apache.directory.studio.apacheds.configuration.v2.dialogs,
- org.apache.directory.studio.apacheds.configuration.v2.editor,
- org.apache.directory.studio.apacheds.configuration.v2.jobs,
- org.apache.directory.studio.apacheds.configuration.v2.wizards
-Import-Package:  org.apache.directory.server.core.api,
- org.apache.directory.server.config,
- org.apache.directory.server.config.beans,
- org.apache.directory.server.core.api.entry,
- org.apache.directory.server.core.api.filtering,
- org.apache.directory.server.core.api.interceptor.context,
- org.apache.directory.server.core.api.partition,
- org.slf4j;bundle-version="1.7.7"
-Require-Bundle: org.eclipse.core.runtime,
- org.apache.commons.io;bundle-version="2.4",
- org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
- org.apache.directory.api.ldap.schema;bundle-version="1.0.0.M24",
- org.apache.directory.server.config;bundle-version="2.0.0.M17",
- org.apache.directory.server.kerberos.codec;bundle-version="2.0.0.M17",
- org.apache.directory.server.ldif.partition;bundle-version="2.0.0.M17",
- org.apache.directory.server.xdbm.partition;bundle-version="2.0.0.M17",
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- org.apache.directory.studio.connection.ui,
- org.apache.directory.studio.ldapbrowser.common,
- org.apache.directory.studio.ldapbrowser.core,
- org.eclipse.core.contenttype,
- org.eclipse.core.runtime,
- org.eclipse.core.resources,
- org.eclipse.ui,
- org.eclipse.ui.editors,
- org.eclipse.ui.forms,
- org.eclipse.ui.ide,
- net.sf.ehcache.core;bundle-version="2.4.4"
+manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio ApacheDS 2.0 Configuration
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.apacheds.configuration.v2;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.apacheds.configuration.v2.ApacheDS2ConfigurationPlugin
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.apacheds.configuration.v2,
+ org.apache.directory.studio.apacheds.configuration.v2.actions,
+ org.apache.directory.studio.apacheds.configuration.v2.dialogs,
+ org.apache.directory.studio.apacheds.configuration.v2.editor,
+ org.apache.directory.studio.apacheds.configuration.v2.jobs,
+ org.apache.directory.studio.apacheds.configuration.v2.wizards
+Import-Package:  org.apache.directory.server.core.api,
+ org.apache.directory.server.config,
+ org.apache.directory.server.config.beans,
+ org.apache.directory.server.core.api.entry,
+ org.apache.directory.server.core.api.filtering,
+ org.apache.directory.server.core.api.interceptor.context,
+ org.apache.directory.server.core.api.partition,
+ org.slf4j;bundle-version="1.7.7"
+Require-Bundle: org.eclipse.core.runtime,
+ org.apache.commons.io;bundle-version="2.4",
+ org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
+ org.apache.directory.api.ldap.schema;bundle-version="1.0.0.M24",
+ org.apache.directory.server.config;bundle-version="2.0.0.M17",
+ org.apache.directory.server.kerberos.codec;bundle-version="2.0.0.M17",
+ org.apache.directory.server.ldif.partition;bundle-version="2.0.0.M17",
+ org.apache.directory.server.xdbm.partition;bundle-version="2.0.0.M17",
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.ldapbrowser.common,
+ org.apache.directory.studio.ldapbrowser.core,
+ org.eclipse.core.contenttype,
+ org.eclipse.core.runtime,
+ org.eclipse.core.resources,
+ org.eclipse.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.forms,
+ org.eclipse.ui.ide,
+ net.sf.ehcache.core;bundle-version="2.4.4"
+Bundle-ClassPath: .,
+ poi-3.9.jar,
+ odfdom-0.6.16.jar,
+ xercesImpl-2.11.0.jar,
+ xml-apis-1.4.01.jar

Modified: directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/OverviewPage.java
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/OverviewPage.java?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/OverviewPage.java (original)
+++ directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/OverviewPage.java Mon Dec  8 16:54:12 2014
@@ -413,21 +413,13 @@ public class OverviewPage extends Server
     private void createLdapLdapsServersSection( FormToolkit toolkit, Composite parent )
     {
         // Creation of the section
-        Section section = toolkit.createSection( parent, Section.TITLE_BAR );
-        section.setText( Messages.getString( "OverviewPage.LdapLdapsServers" ) ); //$NON-NLS-1$
-        section.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false ) );
-        Composite composite = toolkit.createComposite( section );
-        toolkit.paintBordersFor( composite );
-        GridLayout gridLayout = new GridLayout( 4, false );
-        gridLayout.marginHeight = 0;
-        gridLayout.marginWidth = 0;
-        composite.setLayout( gridLayout );
-        section.setClient( composite );
+        int nbColumns = 4;
+        Composite composite = createSection( toolkit, parent, "OverviewPage.LdapLdapsServers", nbColumns, Section.TITLE_BAR );
 
         // Enable LDAP Server Checkbox
         enableLdapCheckbox = toolkit.createButton( composite,
             Messages.getString( "OverviewPage.EnableLdapServer" ), SWT.CHECK ); //$NON-NLS-1$
-        enableLdapCheckbox.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false, gridLayout.numColumns, 1 ) );
+        enableLdapCheckbox.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false, nbColumns, 1 ) );
 
         // LDAP Server Port Text
         toolkit.createLabel( composite, TABULATION );
@@ -438,7 +430,7 @@ public class OverviewPage extends Server
         // Enable LDAPS Server Checkbox
         enableLdapsCheckbox = toolkit.createButton( composite,
             Messages.getString( "OverviewPage.EnableLdapsServer" ), SWT.CHECK ); //$NON-NLS-1$
-        enableLdapsCheckbox.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false, gridLayout.numColumns, 1 ) );
+        enableLdapsCheckbox.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false, nbColumns, 1 ) );
 
         // LDAPS Server Port Text
         toolkit.createLabel( composite, TABULATION );
@@ -449,8 +441,7 @@ public class OverviewPage extends Server
         // LDAP Configuration Link
         openLdapConfigurationLink = toolkit.createHyperlink( composite,
             Messages.getString( "OverviewPage.AdvancedLdapLdapsConfiguration" ), SWT.NONE ); //$NON-NLS-1$
-        openLdapConfigurationLink.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false,
-            gridLayout.numColumns, 1 ) );
+        openLdapConfigurationLink.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false, nbColumns, 1 ) );
         openLdapConfigurationLink.addHyperlinkListener( openLdapConfigurationLinkListener );
     }
 
@@ -476,21 +467,14 @@ public class OverviewPage extends Server
     private void createKerberosChangePasswordServersSection( FormToolkit toolkit, Composite parent )
     {
         // Creation of the section
-        Section section = toolkit.createSection( parent, Section.TITLE_BAR );
-        section.setText( Messages.getString( "OverviewPage.KerberosServer" ) ); //$NON-NLS-1$
-        section.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false ) );
-        Composite composite = toolkit.createComposite( section );
-        toolkit.paintBordersFor( composite );
-        GridLayout gridLayout = new GridLayout( 4, false );
-        gridLayout.marginHeight = gridLayout.marginWidth = 0;
-        composite.setLayout( gridLayout );
-        section.setClient( composite );
+        int nbColumns = 4;
+        Composite composite = createSection( toolkit, parent, "OverviewPage.KerberosServer", nbColumns, Section.TITLE_BAR );
 
         // Enable Kerberos Server Checkbox
         enableKerberosCheckbox = toolkit.createButton( composite,
             Messages.getString( "OverviewPage.EnableKerberosServer" ), SWT.CHECK ); //$NON-NLS-1$
         enableKerberosCheckbox
-            .setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false, gridLayout.numColumns, 1 ) );
+            .setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false, nbColumns, 1 ) );
 
         // Kerberos Server Port Text
         toolkit.createLabel( composite, TABULATION );
@@ -503,7 +487,7 @@ public class OverviewPage extends Server
             Messages.getString( "OverviewPage.EnableKerberosChangePasswordServer" ), //$NON-NLS-1$
             SWT.CHECK );
         enableChangePasswordCheckbox.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false,
-            gridLayout.numColumns, 1 ) );
+            nbColumns, 1 ) );
 
         // Change Password Server Port Text
         toolkit.createLabel( composite, TABULATION );
@@ -515,13 +499,27 @@ public class OverviewPage extends Server
         openKerberosConfigurationLink = toolkit.createHyperlink( composite,
             Messages.getString( "OverviewPage.AdvancedKerberosConfiguration" ), SWT.NONE ); //$NON-NLS-1$
         openKerberosConfigurationLink.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false,
-            gridLayout.numColumns, 1 ) );
+            nbColumns, 1 ) );
         openKerberosConfigurationLink.addHyperlinkListener( openKerberosConfigurationLinkListener );
     }
 
 
     /**
-     * Creates the Partitions section.
+     * Creates the Partitions section. This is just an informative section, 
+     * where we list the existing partitions.
+     * 
+     * <pre>
+     * .--------------------------------.
+     * | Partitions                     |
+     * +--------------------------------|
+     * | +----------------------------+ |
+     * | | Partition 1                | |
+     * | | Partition 2                | |
+     * | | ...                        | |
+     * | +----------------------------+ |
+     * | <advanced partitionsS config>  |
+     * +--------------------------------+
+     * </pre>
      *
      * @param toolkit the toolkit
      * @param parent the parent composite
@@ -529,15 +527,8 @@ public class OverviewPage extends Server
     private void createPartitionsSection( FormToolkit toolkit, Composite parent )
     {
         // Creation of the section
-        Section section = toolkit.createSection( parent, Section.TITLE_BAR );
-        section.setText( Messages.getString( "OverviewPage.Partitions" ) ); //$NON-NLS-1$
-        section.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false ) );
-        Composite composite = toolkit.createComposite( section );
-        toolkit.paintBordersFor( composite );
-        GridLayout gridLayout = new GridLayout( 1, false );
-        gridLayout.marginHeight = gridLayout.marginWidth = 0;
-        composite.setLayout( gridLayout );
-        section.setClient( composite );
+        int nbColumns = 1;
+        Composite composite = createSection( toolkit, parent, "OverviewPage.Partitions", nbColumns, Section.TITLE_BAR );
 
         // Partitions Label
         partitionsLabel = toolkit.createLabel( composite, "" ); //$NON-NLS-1$
@@ -556,14 +547,24 @@ public class OverviewPage extends Server
         // Partitions Configuration Link
         openPartitionsConfigurationLink = toolkit.createHyperlink( composite,
             Messages.getString( "OverviewPage.AdvancedPartitionsConfiguration" ), SWT.NONE ); //$NON-NLS-1$
-        openPartitionsConfigurationLink.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false,
-            gridLayout.numColumns, 1 ) );
+        openPartitionsConfigurationLink.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false, nbColumns, 1 ) );
         openPartitionsConfigurationLink.addHyperlinkListener( openPartitionsConfigurationLinkListener );
     }
 
 
     /**
-     * Creates the Options section.
+     * Creates the Options section. This section expose a few critical options that are
+     * generally useful (allow anonymous, or enable control access atm).
+     * 
+     * <pre>
+     * +--------------------------------+
+     * | Options                        |
+     * +--------------------------------+
+     * | [X] Allow anonymous access     |
+     * | [X] Enable Access Control      |
+     * |                                |
+     * +--------------------------------+
+     * </pre>
      *
      * @param toolkit the toolkit
      * @param parent the parent composite
@@ -571,15 +572,8 @@ public class OverviewPage extends Server
     private void createOptionsSection( FormToolkit toolkit, Composite parent )
     {
         // Creation of the section
-        Section section = toolkit.createSection( parent, Section.TITLE_BAR );
-        section.setText( Messages.getString( "OverviewPage.Options" ) ); //$NON-NLS-1$
-        section.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false ) );
-        Composite composite = toolkit.createComposite( section );
-        toolkit.paintBordersFor( composite );
-        GridLayout gridLayout = new GridLayout( 1, false );
-        gridLayout.marginHeight = gridLayout.marginWidth = 0;
-        composite.setLayout( gridLayout );
-        section.setClient( composite );
+        int nbColumns = 1;
+        Composite composite = createSection( toolkit, parent, "OverviewPage.Options", nbColumns, Section.TITLE_BAR );
 
         // Allow Anonymous Access Checkbox
         allowAnonymousAccessCheckbox = toolkit.createButton( composite,

Modified: directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/ServerConfigurationEditorPage.java
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/ServerConfigurationEditorPage.java?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/ServerConfigurationEditorPage.java (original)
+++ directory/studio/branches/studio-tycho/plugins/apacheds.configuration.v2/src/main/java/org/apache/directory/studio/apacheds/configuration/v2/editor/ServerConfigurationEditorPage.java Mon Dec  8 16:54:12 2014
@@ -61,6 +61,7 @@ import org.eclipse.ui.forms.IManagedForm
 import org.eclipse.ui.forms.editor.FormPage;
 import org.eclipse.ui.forms.widgets.FormToolkit;
 import org.eclipse.ui.forms.widgets.ScrolledForm;
+import org.eclipse.ui.forms.widgets.Section;
 
 
 /**
@@ -797,4 +798,31 @@ public abstract class ServerConfiguratio
         gd.widthHint = 50;
         control.setLayoutData( gd );
     }
+    
+    
+    /**
+     * A shared method used to create a Section, based on a GridLayout.
+     * 
+     * @param toolkit The Form toolkit
+     * @param parent The parent 
+     * @param title The Section title
+     * @param nbColumns The number of columns for the inner grid
+     * 
+     * @return The created Composite
+     */
+    protected Composite createSection( FormToolkit toolkit, Composite parent, String title, int nbColumns, int style )
+    {
+        Section section = toolkit.createSection( parent, style );
+        section.setText( Messages.getString( title ) );
+        section.setLayoutData( new GridData( SWT.FILL, SWT.NONE, true, false ) );
+        Composite composite = toolkit.createComposite( section );
+        toolkit.paintBordersFor( composite );
+        GridLayout gridLayout = new GridLayout( nbColumns, false );
+        gridLayout.marginHeight = 0;
+        gridLayout.marginWidth = 0;
+        composite.setLayout( gridLayout );
+        section.setClient( composite );
+
+        return composite;
+    }
 }

Modified: directory/studio/branches/studio-tycho/plugins/apacheds.configuration/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/apacheds.configuration/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/apacheds.configuration/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/apacheds.configuration/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,32 +1,33 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio ApacheDS Configuration
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.apacheds.configuration;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.apacheds.configuration.ApacheDSConfigurationPlugin
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.apacheds.configuration,
- org.apache.directory.studio.apacheds.configuration.editor,
- org.apache.directory.studio.apacheds.configuration.model,
- org.apache.directory.studio.apacheds.configuration.model.v153,
- org.apache.directory.studio.apacheds.configuration.model.v154,
- org.apache.directory.studio.apacheds.configuration.model.v155,
- org.apache.directory.studio.apacheds.configuration.model.v156,
- org.apache.directory.studio.apacheds.configuration.model.v157
-Import-Package: org.apache.commons.lang,
- org.dom4j,
- org.dom4j.io
-Require-Bundle: org.eclipse.core.runtime,
- org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
- org.apache.directory.api.util;bundle-version="1.0.0.M24",
- org.apache.directory.studio.common.ui,
- org.eclipse.core.resources,
- org.eclipse.jface.text,
- org.eclipse.ui,
- org.eclipse.ui.editors,
- org.eclipse.ui.forms,
- org.eclipse.ui.ide
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio ApacheDS Configuration
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.apacheds.configuration;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.apacheds.configuration.ApacheDSConfigurationPlugin
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.apacheds.configuration,
+ org.apache.directory.studio.apacheds.configuration.editor,
+ org.apache.directory.studio.apacheds.configuration.model,
+ org.apache.directory.studio.apacheds.configuration.model.v153,
+ org.apache.directory.studio.apacheds.configuration.model.v154,
+ org.apache.directory.studio.apacheds.configuration.model.v155,
+ org.apache.directory.studio.apacheds.configuration.model.v156,
+ org.apache.directory.studio.apacheds.configuration.model.v157
+Import-Package: org.apache.commons.lang,
+ org.dom4j,
+ org.dom4j.io
+Require-Bundle: org.eclipse.core.runtime,
+ org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
+ org.apache.directory.api.util;bundle-version="1.0.0.M24",
+ org.apache.directory.studio.common.ui,
+ org.eclipse.core.resources,
+ org.eclipse.jface.text,
+ org.eclipse.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.forms,
+ org.eclipse.ui.ide
+Bundle-ClassPath: .

Modified: directory/studio/branches/studio-tycho/plugins/common.core/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/common.core/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/common.core/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/common.core/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,12 +1,13 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio Common Core
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.common.core;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.common.core.jobs
-Import-Package: org.apache.commons.lang
-Require-Bundle: org.eclipse.core.runtime
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio Common Core
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.common.core;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.common.core.jobs
+Import-Package: org.apache.commons.lang
+Require-Bundle: org.eclipse.core.runtime
+Bundle-ClassPath: .

Modified: directory/studio/branches/studio-tycho/plugins/common.ui/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/common.ui/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/common.ui/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/common.ui/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,17 +1,18 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio Common UI
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.common.ui;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.common.ui.CommonUIPlugin
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.common.ui,
- org.apache.directory.studio.common.ui.filesystem,
- org.apache.directory.studio.common.ui.widgets
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.ui,
- org.eclipse.ui.editors
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio Common UI
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.common.ui;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.common.ui.CommonUIPlugin
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.common.ui.filesystem,
+ org.apache.directory.studio.common.ui.widgets
+Require-Bundle: org.eclipse.core.runtime,
+ org.eclipse.ui,
+ org.eclipse.ui.editors
+Bundle-ClassPath: .

Modified: directory/studio/branches/studio-tycho/plugins/connection.core/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/connection.core/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/connection.core/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/connection.core/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,33 +1,34 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio Connection Core
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.connection.core;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.connection.core.ConnectionCorePlugin
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.connection.core,
- org.apache.directory.studio.connection.core.event,
- org.apache.directory.studio.connection.core.io,
- org.apache.directory.studio.connection.core.io.api,
- org.apache.directory.studio.connection.core.io.jndi,
- org.apache.directory.studio.connection.core.jobs
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.ui,
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.ldifparser,
- org.apache.directory.api.asn1.api;bundle-version="1.0.0.M24",
- org.apache.directory.api.ldap.client.api;bundle-version="1.0.0.M24",
- org.apache.directory.api.ldap.codec.core;bundle-version="1.0.0.M24",
- org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
- org.apache.directory.api.ldap.net.mina;bundle-version="1.0.0.M24",
- org.apache.directory.api.util;bundle-version="1.0.0.M24"
-Import-Package: org.apache.commons.lang,
- org.apache.commons.io,
- org.apache.commons.codec.digest,
- org.apache.http.conn.ssl,
- org.dom4j,
- org.dom4j.io
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio Connection Core
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.connection.core;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.connection.core.ConnectionCorePlugin
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.core.event,
+ org.apache.directory.studio.connection.core.io,
+ org.apache.directory.studio.connection.core.io.api,
+ org.apache.directory.studio.connection.core.io.jndi,
+ org.apache.directory.studio.connection.core.jobs
+Require-Bundle: org.eclipse.core.runtime,
+ org.eclipse.ui,
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.ldifparser,
+ org.apache.directory.api.asn1.api;bundle-version="1.0.0.M24",
+ org.apache.directory.api.ldap.client.api;bundle-version="1.0.0.M24",
+ org.apache.directory.api.ldap.codec.core;bundle-version="1.0.0.M24",
+ org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
+ org.apache.directory.api.ldap.net.mina;bundle-version="1.0.0.M24",
+ org.apache.directory.api.util;bundle-version="1.0.0.M24"
+Import-Package: org.apache.commons.lang,
+ org.apache.commons.io,
+ org.apache.commons.codec.digest,
+ org.apache.http.conn.ssl,
+ org.dom4j,
+ org.dom4j.io
+Bundle-ClassPath: .

Modified: directory/studio/branches/studio-tycho/plugins/connection.ui/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/connection.ui/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/connection.ui/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/connection.ui/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,35 +1,36 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio Connection UI
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.connection.ui;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.connection.ui.ConnectionUIPlugin
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.connection.ui,
- org.apache.directory.studio.connection.ui.actions,
- org.apache.directory.studio.connection.ui.dialogs,
- org.apache.directory.studio.connection.ui.dnd,
- org.apache.directory.studio.connection.ui.preferences,
- org.apache.directory.studio.connection.ui.properties,
- org.apache.directory.studio.connection.ui.widgets,
- org.apache.directory.studio.connection.ui.wizards,
- org.apache.directory.studio.utils
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.ui,
- org.eclipse.ui.forms,
- org.eclipse.ui.workbench.texteditor,
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24"
-Import-Package: org.apache.commons.lang,
- org.apache.commons.lang.time,
- org.apache.commons.io,
- org.apache.commons.codec.binary,
- org.apache.commons.codec.digest,
- org.bouncycastle.asn1,
- org.bouncycastle.x509.extension
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio Connection UI
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.connection.ui;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.connection.ui.ConnectionUIPlugin
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.connection.ui.actions,
+ org.apache.directory.studio.connection.ui.dialogs,
+ org.apache.directory.studio.connection.ui.dnd,
+ org.apache.directory.studio.connection.ui.preferences,
+ org.apache.directory.studio.connection.ui.properties,
+ org.apache.directory.studio.connection.ui.widgets,
+ org.apache.directory.studio.connection.ui.wizards,
+ org.apache.directory.studio.utils
+Require-Bundle: org.eclipse.core.runtime,
+ org.eclipse.ui,
+ org.eclipse.ui.forms,
+ org.eclipse.ui.workbench.texteditor,
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24"
+Import-Package: org.apache.commons.lang,
+ org.apache.commons.lang.time,
+ org.apache.commons.io,
+ org.apache.commons.codec.binary,
+ org.apache.commons.codec.digest,
+ org.bouncycastle.asn1,
+ org.bouncycastle.x509.extension
+Bundle-ClassPath: .

Modified: directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/ldapbrowser.common/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,40 +1,45 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio LDAP Browser Common
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.ldapbrowser.common;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.ldapbrowser.common.BrowserCommonActivator
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.ldapbrowser.common,
- org.apache.directory.studio.ldapbrowser.common.actions,
- org.apache.directory.studio.ldapbrowser.common.actions.proxy,
- org.apache.directory.studio.ldapbrowser.common.dialogs,
- org.apache.directory.studio.ldapbrowser.common.dialogs.preferences,
- org.apache.directory.studio.ldapbrowser.common.dnd,
- org.apache.directory.studio.ldapbrowser.common.filtereditor,
- org.apache.directory.studio.ldapbrowser.common.widgets,
- org.apache.directory.studio.ldapbrowser.common.widgets.browser,
- org.apache.directory.studio.ldapbrowser.common.widgets.entryeditor,
- org.apache.directory.studio.ldapbrowser.common.widgets.search,
- org.apache.directory.studio.ldapbrowser.common.wizards,
- org.apache.directory.studio.valueeditors
-Require-Bundle:  org.eclipse.core.runtime,
- org.eclipse.core.expressions,
- org.eclipse.jface.text,
- org.eclipse.ui,
- org.eclipse.ui.editors,
- org.eclipse.ui.workbench.texteditor,
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- org.apache.directory.studio.connection.ui,
- org.apache.directory.studio.ldapbrowser.core,
- org.apache.directory.studio.ldifparser,
- org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
- org.apache.directory.api.util;bundle-version="1.0.0.M24"
-Import-Package: org.apache.commons.lang,
- org.apache.commons.io
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio LDAP Browser Common
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.ldapbrowser.common;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.ldapbrowser.common.BrowserCommonActivator
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.ldapbrowser.common,
+ org.apache.directory.studio.ldapbrowser.common.actions,
+ org.apache.directory.studio.ldapbrowser.common.actions.proxy,
+ org.apache.directory.studio.ldapbrowser.common.dialogs,
+ org.apache.directory.studio.ldapbrowser.common.dialogs.preferences,
+ org.apache.directory.studio.ldapbrowser.common.dnd,
+ org.apache.directory.studio.ldapbrowser.common.filtereditor,
+ org.apache.directory.studio.ldapbrowser.common.widgets,
+ org.apache.directory.studio.ldapbrowser.common.widgets.browser,
+ org.apache.directory.studio.ldapbrowser.common.widgets.entryeditor,
+ org.apache.directory.studio.ldapbrowser.common.widgets.search,
+ org.apache.directory.studio.ldapbrowser.common.wizards,
+ org.apache.directory.studio.valueeditors
+Require-Bundle: org.eclipse.core.runtime,
+ org.eclipse.core.expressions,
+ org.eclipse.jface.text,
+ org.eclipse.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.workbench.texteditor,
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.ldapbrowser.core,
+ org.apache.directory.studio.ldifparser,
+ org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
+ org.apache.directory.api.util;bundle-version="1.0.0.M24"
+Import-Package: org.apache.commons.lang,
+ org.apache.commons.io
+Bundle-ClassPath: .,
+ poi-3.9.jar,
+ odfdom-0.6.16.jar,
+ xercesImpl-2.11.0.jar,
+ xml-apis-1.4.01.jar

Modified: directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/ldapbrowser.core/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,50 +1,53 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio LDAP Browser Core
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.ldapbrowser.core;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.ldapbrowser.core.BrowserCorePlugin
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.ldapbrowser.core,
- org.apache.directory.studio.ldapbrowser.core.events,
- org.apache.directory.studio.ldapbrowser.core.internal.search,
- org.apache.directory.studio.ldapbrowser.core.jobs,
- org.apache.directory.studio.ldapbrowser.core.model,
- org.apache.directory.studio.ldapbrowser.core.model.filter,
- org.apache.directory.studio.ldapbrowser.core.model.filter.parser,
- org.apache.directory.studio.ldapbrowser.core.model.impl,
- org.apache.directory.studio.ldapbrowser.core.model.schema,
- org.apache.directory.studio.ldapbrowser.core.propertypageproviders,
- org.apache.directory.studio.ldapbrowser.core.utils
-Require-Bundle:  org.eclipse.core.runtime,
- org.eclipse.search,
- org.apache.directory.api.asn1.api;bundle-version="1.0.0.M24",
- org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
- org.apache.directory.api.ldap.codec.core;bundle-version="1.0.0.M24",
- org.apache.directory.api.dsmlv2.parser;bundle-version="1.0.0.M24",
- org.apache.directory.api.util;bundle-version="1.0.0.M24",
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.connection.core,
- org.apache.directory.studio.ldifparser
-Import-Package: org.apache.commons.lang,
- org.apache.commons.io,
- org.apache.commons.collections,
- org.apache.commons.codec.digest,
- org.dom4j,
- org.dom4j.io,
- org.xmlpull.v1
-Bundle-ClassPath: .,
- lib/poi-3.9.jar,
- lib/odfdom-0.6.16.jar,
- lib/xercesImpl-2.11.0.jar,
- lib/xml-apis-1.4.01.jar
-Embed-Dependency: *;scope=compile|runtime
-Embed-Directory: lib
-Embed-StripGroup: true
-Embedded-Artifacts: lib/poi-3.9.jar;g="org.apache.poi";a="poi";v="3.9",l
- ib/odfdom-0.6.16.jar;g="org.openoffice";a="odfdom";v="0.6.16",lib/xerce
- sImpl-2.11.0.jar;g="xerces";a="xercesImpl";v="2.11.0"
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio LDAP Browser Core
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.ldapbrowser.core;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.ldapbrowser.core.BrowserCorePlugin
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.ldapbrowser.core,
+ org.apache.directory.studio.ldapbrowser.core.events,
+ org.apache.directory.studio.ldapbrowser.core.internal.search,
+ org.apache.directory.studio.ldapbrowser.core.jobs,
+ org.apache.directory.studio.ldapbrowser.core.model,
+ org.apache.directory.studio.ldapbrowser.core.model.filter,
+ org.apache.directory.studio.ldapbrowser.core.model.filter.parser,
+ org.apache.directory.studio.ldapbrowser.core.model.impl,
+ org.apache.directory.studio.ldapbrowser.core.model.schema,
+ org.apache.directory.studio.ldapbrowser.core.propertypageproviders,
+ org.apache.directory.studio.ldapbrowser.core.utils
+Require-Bundle:  org.eclipse.core.runtime,
+ org.eclipse.search,
+ org.apache.directory.api.asn1.api;bundle-version="1.0.0.M24",
+ org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
+ org.apache.directory.api.ldap.codec.core;bundle-version="1.0.0.M24",
+ org.apache.directory.api.dsmlv2.parser;bundle-version="1.0.0.M24",
+ org.apache.directory.api.util;bundle-version="1.0.0.M24",
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.ldifparser,
+ org.apache.poi;bundle-version="3.9.0",
+ org.openoffice.odfdom;bundle-version="0.6.16",
+ xerces.Impl;bundle-version="2.11.0"
+Import-Package: org.apache.commons.lang,
+ org.apache.commons.io,
+ org.apache.commons.collections,
+ org.apache.commons.codec.digest,
+ org.dom4j,
+ org.dom4j.io,
+ org.xmlpull.v1
+Embed-Dependency: *;scope=compile|runtime
+Embed-Directory: lib
+Embed-StripGroup: true
+Embedded-Artifacts: lib/poi-3.9.jar;g="org.apache.poi";a="poi";v="3.9",l
+ ib/odfdom-0.6.16.jar;g="org.openoffice";a="odfdom";v="0.6.16",lib/xerce
+ sImpl-2.11.0.jar;g="xerces";a="xercesImpl";v="2.11.0"
+Bundle-ClassPath: .,
+ poi-3.9.jar,
+ odfdom-0.6.16.jar,
+ xercesImpl-2.11.0.jar,
+ xml-apis-1.4.01.jar

Modified: directory/studio/branches/studio-tycho/plugins/ldapbrowser.ui/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapbrowser.ui/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapbrowser.ui/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/ldapbrowser.ui/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,52 +1,57 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio LDAP Browser UI
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.ldapbrowser.ui;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.ldapbrowser.ui.BrowserUIPlugin
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.entryeditors,
- org.apache.directory.studio.ldapbrowser.ui,
- org.apache.directory.studio.ldapbrowser.ui.actions,
- org.apache.directory.studio.ldapbrowser.ui.actions.proxy,
- org.apache.directory.studio.ldapbrowser.ui.dialogs,
- org.apache.directory.studio.ldapbrowser.ui.dialogs.preferences,
- org.apache.directory.studio.ldapbrowser.ui.dialogs.properties,
- org.apache.directory.studio.ldapbrowser.ui.editors.entry,
- org.apache.directory.studio.ldapbrowser.ui.editors.schemabrowser,
- org.apache.directory.studio.ldapbrowser.ui.editors.searchresult,
- org.apache.directory.studio.ldapbrowser.ui.perspective,
- org.apache.directory.studio.ldapbrowser.ui.search,
- org.apache.directory.studio.ldapbrowser.ui.views.browser,
- org.apache.directory.studio.ldapbrowser.ui.views.connection,
- org.apache.directory.studio.ldapbrowser.ui.views.modificationlogs,
- org.apache.directory.studio.ldapbrowser.ui.views.searchlogs,
- org.apache.directory.studio.ldapbrowser.ui.wizards
-Require-Bundle: org.eclipse.core.expressions,
- org.eclipse.core.filesystem,
- org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.eclipse.jface.text,
- org.eclipse.ui,
- org.eclipse.ui.editors,
- org.eclipse.ui.forms,
- org.eclipse.ui.ide,
- org.eclipse.ui.views,
- org.eclipse.ui.workbench.texteditor,
- org.eclipse.search,
- org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
- org.apache.directory.api.util;bundle-version="1.0.0.M24",
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- org.apache.directory.studio.connection.ui,
- org.apache.directory.studio.ldapbrowser.core,
- org.apache.directory.studio.ldapbrowser.common,
- org.apache.directory.studio.ldifeditor,
- org.apache.directory.studio.ldifparser
-Import-Package: org.apache.commons.lang,
- org.apache.commons.io
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio LDAP Browser UI
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.ldapbrowser.ui;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.ldapbrowser.ui.BrowserUIPlugin
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.entryeditors,
+ org.apache.directory.studio.ldapbrowser.ui,
+ org.apache.directory.studio.ldapbrowser.ui.actions,
+ org.apache.directory.studio.ldapbrowser.ui.actions.proxy,
+ org.apache.directory.studio.ldapbrowser.ui.dialogs,
+ org.apache.directory.studio.ldapbrowser.ui.dialogs.preferences,
+ org.apache.directory.studio.ldapbrowser.ui.dialogs.properties,
+ org.apache.directory.studio.ldapbrowser.ui.editors.entry,
+ org.apache.directory.studio.ldapbrowser.ui.editors.schemabrowser,
+ org.apache.directory.studio.ldapbrowser.ui.editors.searchresult,
+ org.apache.directory.studio.ldapbrowser.ui.perspective,
+ org.apache.directory.studio.ldapbrowser.ui.search,
+ org.apache.directory.studio.ldapbrowser.ui.views.browser,
+ org.apache.directory.studio.ldapbrowser.ui.views.connection,
+ org.apache.directory.studio.ldapbrowser.ui.views.modificationlogs,
+ org.apache.directory.studio.ldapbrowser.ui.views.searchlogs,
+ org.apache.directory.studio.ldapbrowser.ui.wizards
+Require-Bundle: org.eclipse.core.expressions,
+ org.eclipse.core.filesystem,
+ org.eclipse.core.resources,
+ org.eclipse.core.runtime,
+ org.eclipse.jface.text,
+ org.eclipse.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.forms,
+ org.eclipse.ui.ide,
+ org.eclipse.ui.views,
+ org.eclipse.ui.workbench.texteditor,
+ org.eclipse.search,
+ org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
+ org.apache.directory.api.util;bundle-version="1.0.0.M24",
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.ldapbrowser.core,
+ org.apache.directory.studio.ldapbrowser.common,
+ org.apache.directory.studio.ldifeditor,
+ org.apache.directory.studio.ldifparser
+Import-Package: org.apache.commons.lang,
+ org.apache.commons.io
+Bundle-ClassPath: .,
+ poi-3.9.jar,
+ odfdom-0.6.16.jar,
+ xercesImpl-2.11.0.jar,
+ xml-apis-1.4.01.jar

Modified: directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v153/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v153/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v153/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v153/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,33 +1,36 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio ApacheDS 1.5.3 LDAP Server Adapter
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.ldapservers.apacheds.v153;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.ldapservers.apacheds.v153.ApacheDS153Plugin
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.ldapservers.apacheds.v153
-Require-Bundle: org.eclipse.core.runtime,
- org.apache.mina.core;bundle-version="2.0.7",
- org.apache.commons.lang;bundle-version="2.6.0",
- org.apache.commons.collections;bundle-version="3.2.1",
- org.apache.commons.io;bundle-version="2.4",
- org.eclipse.jface.text,
- org.eclipse.ui,
- org.eclipse.debug.core,
- org.eclipse.debug.ui,
- org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.eclipse.ui.console,
- org.eclipse.ui.ide,
- org.eclipse.ui.editors,
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- org.apache.directory.studio.connection.ui,
- org.apache.directory.studio.apacheds.configuration,
- org.apache.directory.studio.ldapservers,
- dom4j
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio ApacheDS 1.5.3 LDAP Server Adapter
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.ldapservers.apacheds.v153;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.ldapservers.apacheds.v153.ApacheDS153Plugin
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.ldapservers.apacheds.v153
+Require-Bundle: org.eclipse.core.runtime,
+ org.apache.mina.core;bundle-version="2.0.7",
+ org.apache.commons.lang;bundle-version="2.6.0",
+ org.apache.commons.collections;bundle-version="3.2.1",
+ org.apache.commons.io;bundle-version="2.4",
+ org.eclipse.jface.text,
+ org.eclipse.ui,
+ org.eclipse.debug.core,
+ org.eclipse.debug.ui,
+ org.eclipse.core.resources,
+ org.eclipse.core.runtime,
+ org.eclipse.ui.console,
+ org.eclipse.ui.ide,
+ org.eclipse.ui.editors,
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.apacheds.configuration,
+ org.apache.directory.studio.ldapservers,
+ dom4j
+Bundle-ClassPath: .,
+ jdi.jar,
+ jdimodel.jar

Modified: directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v154/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v154/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v154/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v154/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,33 +1,36 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio ApacheDS 1.5.4 LDAP Server Adapter
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.ldapservers.apacheds.v154;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.ldapservers.apacheds.v154.ApacheDS154Plugin
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.ldapservers.apacheds.v154
-Require-Bundle: org.eclipse.core.runtime,
- org.apache.mina.core;bundle-version="2.0.7",
- org.apache.commons.lang;bundle-version="2.6.0",
- org.apache.commons.collections;bundle-version="3.2.1",
- org.apache.commons.io;bundle-version="2.4",
- org.eclipse.jface.text,
- org.eclipse.ui,
- org.eclipse.debug.core,
- org.eclipse.debug.ui,
- org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.eclipse.ui.console,
- org.eclipse.ui.ide,
- org.eclipse.ui.editors,
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- org.apache.directory.studio.connection.ui,
- org.apache.directory.studio.apacheds.configuration,
- org.apache.directory.studio.ldapservers,
- dom4j
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio ApacheDS 1.5.4 LDAP Server Adapter
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.ldapservers.apacheds.v154;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.ldapservers.apacheds.v154.ApacheDS154Plugin
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.ldapservers.apacheds.v154
+Require-Bundle: org.eclipse.core.runtime,
+ org.apache.mina.core;bundle-version="2.0.7",
+ org.apache.commons.lang;bundle-version="2.6.0",
+ org.apache.commons.collections;bundle-version="3.2.1",
+ org.apache.commons.io;bundle-version="2.4",
+ org.eclipse.jface.text,
+ org.eclipse.ui,
+ org.eclipse.debug.core,
+ org.eclipse.debug.ui,
+ org.eclipse.core.resources,
+ org.eclipse.core.runtime,
+ org.eclipse.ui.console,
+ org.eclipse.ui.ide,
+ org.eclipse.ui.editors,
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.apacheds.configuration,
+ org.apache.directory.studio.ldapservers,
+ dom4j
+Bundle-ClassPath: .,
+ jdi.jar,
+ jdimodel.jar

Modified: directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v155/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v155/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v155/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/ldapservers.apacheds.v155/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,33 +1,36 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio ApacheDS 1.5.5 LDAP Server Adapter
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.ldapservers.apacheds.v155;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.ldapservers.apacheds.v155.ApacheDS155Plugin
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.ldapservers.apacheds.v155
-Require-Bundle: org.eclipse.core.runtime,
- org.apache.commons.lang;bundle-version="2.6.0",
- org.apache.mina.core;bundle-version="2.0.7",
- org.apache.commons.collections;bundle-version="3.2.1",
- org.apache.commons.io;bundle-version="2.4",
- org.eclipse.jface.text,
- org.eclipse.ui,
- org.eclipse.debug.core,
- org.eclipse.debug.ui,
- org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.eclipse.ui.console,
- org.eclipse.ui.ide,
- org.eclipse.ui.editors,
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- org.apache.directory.studio.connection.ui,
- org.apache.directory.studio.apacheds.configuration,
- org.apache.directory.studio.ldapservers,
- dom4j
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio ApacheDS 1.5.5 LDAP Server Adapter
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.ldapservers.apacheds.v155;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.ldapservers.apacheds.v155.ApacheDS155Plugin
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.ldapservers.apacheds.v155
+Require-Bundle: org.eclipse.core.runtime,
+ org.apache.commons.lang;bundle-version="2.6.0",
+ org.apache.mina.core;bundle-version="2.0.7",
+ org.apache.commons.collections;bundle-version="3.2.1",
+ org.apache.commons.io;bundle-version="2.4",
+ org.eclipse.jface.text,
+ org.eclipse.ui,
+ org.eclipse.debug.core,
+ org.eclipse.debug.ui,
+ org.eclipse.core.resources,
+ org.eclipse.core.runtime,
+ org.eclipse.ui.console,
+ org.eclipse.ui.ide,
+ org.eclipse.ui.editors,
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.apacheds.configuration,
+ org.apache.directory.studio.ldapservers,
+ dom4j
+Bundle-ClassPath: .,
+ jdi.jar,
+ jdimodel.jar

Modified: directory/studio/branches/studio-tycho/plugins/ldapservers/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldapservers/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldapservers/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/ldapservers/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,34 +1,37 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio LDAP Servers
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.ldapservers;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.ldapservers.LdapServersPlugin
-Eclipse-LazyStart: true
-Import-Package: org.apache.commons.lang,
- org.apache.directory.studio.common.core.jobs
-Export-Package: org.apache.directory.studio.ldapservers,
- org.apache.directory.studio.ldapservers.model,
- org.apache.directory.studio.ldapservers.views,
- org.apache.directory.studio.ldapservers.actions
-Require-Bundle: org.eclipse.core.runtime,
- org.apache.mina.core;bundle-version="2.0.7",
- org.apache.commons.collections;bundle-version="3.2.1",
- org.apache.commons.io;bundle-version="2.4",
- org.eclipse.jdt.launching,
- org.eclipse.jface.text,
- org.eclipse.ui,
- org.eclipse.debug.core,
- org.eclipse.debug.ui,
- org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.eclipse.ui.console,
- org.eclipse.ui.ide,
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- dom4j
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio LDAP Servers
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.ldapservers;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.ldapservers.LdapServersPlugin
+Eclipse-LazyStart: true
+Import-Package: org.apache.commons.lang,
+ org.apache.directory.studio.common.core.jobs
+Export-Package: org.apache.directory.studio.ldapservers,
+ org.apache.directory.studio.ldapservers.model,
+ org.apache.directory.studio.ldapservers.views,
+ org.apache.directory.studio.ldapservers.actions
+Require-Bundle: org.eclipse.core.runtime,
+ org.apache.mina.core;bundle-version="2.0.7",
+ org.apache.commons.collections;bundle-version="3.2.1",
+ org.apache.commons.io;bundle-version="2.4",
+ org.eclipse.jdt.launching,
+ org.eclipse.jface.text,
+ org.eclipse.ui,
+ org.eclipse.debug.core,
+ org.eclipse.debug.ui,
+ org.eclipse.core.resources,
+ org.eclipse.core.runtime,
+ org.eclipse.ui.console,
+ org.eclipse.ui.ide,
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ dom4j
+Bundle-ClassPath: .,
+ jdi.jar,
+ jdimodel.jar

Modified: directory/studio/branches/studio-tycho/plugins/ldifeditor/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldifeditor/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldifeditor/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/ldifeditor/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,39 +1,44 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio LDIF Editor
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.ldifeditor;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.ldifeditor.LdifEditorActivator
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.ldifeditor,
- org.apache.directory.studio.ldifeditor.dialogs,
- org.apache.directory.studio.ldifeditor.dialogs.preferences,
- org.apache.directory.studio.ldifeditor.editor,
- org.apache.directory.studio.ldifeditor.editor.actions,
- org.apache.directory.studio.ldifeditor.editor.reconciler,
- org.apache.directory.studio.ldifeditor.editor.text,
- org.apache.directory.studio.ldifeditor.widgets,
- org.apache.directory.studio.ldifeditor.wizards
-Require-Bundle: org.eclipse.core.expressions,
- org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.eclipse.core.filesystem,
- org.eclipse.jface.text,
- org.eclipse.ui,
- org.eclipse.ui.editors,
- org.eclipse.ui.ide,
- org.eclipse.ui.views,
- org.eclipse.ui.workbench.texteditor,
- org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
- org.apache.directory.api.util;bundle-version="1.0.0.M24",
- org.apache.directory.studio.common.core,
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- org.apache.directory.studio.connection.ui,
- org.apache.directory.studio.ldapbrowser.core,
- org.apache.directory.studio.ldapbrowser.common,
- org.apache.directory.studio.ldifparser
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio LDIF Editor
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.ldifeditor;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.ldifeditor.LdifEditorActivator
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.ldifeditor,
+ org.apache.directory.studio.ldifeditor.dialogs,
+ org.apache.directory.studio.ldifeditor.dialogs.preferences,
+ org.apache.directory.studio.ldifeditor.editor,
+ org.apache.directory.studio.ldifeditor.editor.actions,
+ org.apache.directory.studio.ldifeditor.editor.reconciler,
+ org.apache.directory.studio.ldifeditor.editor.text,
+ org.apache.directory.studio.ldifeditor.widgets,
+ org.apache.directory.studio.ldifeditor.wizards
+Require-Bundle: org.eclipse.core.expressions,
+ org.eclipse.core.resources,
+ org.eclipse.core.runtime,
+ org.eclipse.core.filesystem,
+ org.eclipse.jface.text,
+ org.eclipse.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.ide,
+ org.eclipse.ui.views,
+ org.eclipse.ui.workbench.texteditor,
+ org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
+ org.apache.directory.api.util;bundle-version="1.0.0.M24",
+ org.apache.directory.studio.common.core,
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.ldapbrowser.core,
+ org.apache.directory.studio.ldapbrowser.common,
+ org.apache.directory.studio.ldifparser
+Bundle-ClassPath: .,
+ poi-3.9.jar,
+ odfdom-0.6.16.jar,
+ xercesImpl-2.11.0.jar,
+ xml-apis-1.4.01.jar

Modified: directory/studio/branches/studio-tycho/plugins/ldifparser/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/ldifparser/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/ldifparser/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/ldifparser/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,15 +1,16 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio LDIF Parser
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.ldifparser;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Export-Package: org.apache.directory.studio.ldifparser,
- org.apache.directory.studio.ldifparser.model,
- org.apache.directory.studio.ldifparser.model.container,
- org.apache.directory.studio.ldifparser.model.lines,
- org.apache.directory.studio.ldifparser.parser
-Require-Bundle: org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24"
-Import-Package: org.apache.commons.codec.binary
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio LDIF Parser
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.ldifparser;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Export-Package: org.apache.directory.studio.ldifparser,
+ org.apache.directory.studio.ldifparser.model,
+ org.apache.directory.studio.ldifparser.model.container,
+ org.apache.directory.studio.ldifparser.model.lines,
+ org.apache.directory.studio.ldifparser.parser
+Require-Bundle: org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24"
+Import-Package: org.apache.commons.codec.binary
+Bundle-ClassPath: .

Modified: directory/studio/branches/studio-tycho/plugins/valueeditors/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/directory/studio/branches/studio-tycho/plugins/valueeditors/META-INF/MANIFEST.MF?rev=1643864&r1=1643863&r2=1643864&view=diff
==============================================================================
--- directory/studio/branches/studio-tycho/plugins/valueeditors/META-INF/MANIFEST.MF (original)
+++ directory/studio/branches/studio-tycho/plugins/valueeditors/META-INF/MANIFEST.MF Mon Dec  8 16:54:12 2014
@@ -1,28 +1,33 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: Apache Directory Studio Value Editors
-Bundle-Vendor: The Apache Software Foundation
-Bundle-Version: 2.0.0.qualifier
-Bundle-SymbolicName: org.apache.directory.studio.valueeditors;singleton:=true
-Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-Localization: plugin
-Bundle-Activator: org.apache.directory.studio.valueeditors.ValueEditorsActivator
-Eclipse-LazyStart: true
-Export-Package: org.apache.directory.studio.valueeditors,
- org.apache.directory.studio.valueeditors.dn,
- org.apache.directory.studio.valueeditors.integer
-Import-Package: org.apache.commons.lang,
- org.apache.commons.codec,
- org.apache.commons.codec.binary,
- org.apache.commons.io
-Require-Bundle: org.eclipse.core.runtime,
- org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
- org.apache.directory.api.util;bundle-version="1.0.0.M24",
- org.apache.directory.studio.common.ui,
- org.apache.directory.studio.connection.core,
- org.apache.directory.studio.connection.ui,
- org.apache.directory.studio.ldapbrowser.core,
- org.apache.directory.studio.ldapbrowser.common,
- org.eclipse.core.runtime,
- org.eclipse.ui
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: Apache Directory Studio Value Editors
+Bundle-Vendor: The Apache Software Foundation
+Bundle-Version: 2.0.0.qualifier
+Bundle-SymbolicName: org.apache.directory.studio.valueeditors;singleton:=true
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-Localization: plugin
+Bundle-Activator: org.apache.directory.studio.valueeditors.ValueEditorsActivator
+Eclipse-LazyStart: true
+Export-Package: org.apache.directory.studio.valueeditors,
+ org.apache.directory.studio.valueeditors.dn,
+ org.apache.directory.studio.valueeditors.integer
+Import-Package: org.apache.commons.lang,
+ org.apache.commons.codec,
+ org.apache.commons.codec.binary,
+ org.apache.commons.io
+Require-Bundle: org.eclipse.core.runtime,
+ org.apache.directory.api.ldap.model;bundle-version="1.0.0.M24",
+ org.apache.directory.api.util;bundle-version="1.0.0.M24",
+ org.apache.directory.studio.common.ui,
+ org.apache.directory.studio.connection.core,
+ org.apache.directory.studio.connection.ui,
+ org.apache.directory.studio.ldapbrowser.core,
+ org.apache.directory.studio.ldapbrowser.common,
+ org.eclipse.core.runtime,
+ org.eclipse.ui
+Bundle-ClassPath: .,
+ poi-3.9.jar,
+ odfdom-0.6.16.jar,
+ xercesImpl-2.11.0.jar,
+ xml-apis-1.4.01.jar



Mime
View raw message