directory-api mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Nguyen" <sngu...@advantco.com>
Subject RE: [Community] LDAP client API as OSGi bundle
Date Thu, 07 Jan 2016 09:20:53 GMT
Hi Emmanuel,

Thanks for your response.
I use the latest version (1.0.0-M33) from the website.
I'm still trying to debug it. With local Camel test component, it works. But when I deploy
it on the server, it does not.
I will try to contact the server Administrator to see if I can get any DEBUG message.

Thanks & Best Regards,

Steven Nguyen
-----Original Message-----
From: Emmanuel Lécharny [mailto:elecharny@gmail.com] 
Sent: Thursday, January 7, 2016 4:11 PM
To: api@directory.apache.org
Subject: Re: [Community] LDAP client API as OSGi bundle

Le 07/01/16 09:55, Steven Nguyen a écrit :
> Hi Emmanuel,
>
> There's no log records when it is bundled in Camel component. I hope that I could retrieve
the runtime log from the server but I had no luck.
> I checked if the connection was opened successfully or not via the method connect() (e.g.
connected = conn.connect();) and its value is "false".
> I created a non-encrypted connection to LDAP server (e.g. I created LdapConnectionConfiguration
object, passed some standard parameters, then I created an LdapNetworkConnection with the
connection config and opened the connection).
> I tested my program with a simple test class and it works.

Which LDAP API version are you using ?

Somehow, if it works in a simple test, it should also work with Camel.
We use the API in Studio, which is a full OSGi env, so there is no reason it should not work
in Camel either...

Have you tried o debug it ?



Mime
View raw message