directory-api mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Abernathy <...@babernathy.net>
Subject Re: Request for slf4j import package in API bundles changes
Date Wed, 08 Apr 2015 16:01:05 GMT
Stefan,

Thank you for the reply. I'll look into it. I think the simplest
solution will be to insert the range into the import definitions. I'll
see if there's a clean way to do that.

Ben

On Tue, Apr 7, 2015, at 01:26 PM, Stefan Seelmann wrote:
> On 04/06/2015 11:26 PM, Benjamin Abernathy wrote:
> > Hello,
> > 
> > I need to deploy version 1.0.0-M30 of the API bundles into an instance
> > of ServiceMix 5.3.0. Unfortunately ServiceMix (actually Karaf I think)
> > includes slf4j as a system bundle so its headers are made available to
> > all bundles. This makes it not possible to install the LDAP API bundles
> > because the system exports version 1.7.7 and the API bundles require
> > 1.7.10. 
> > 
> > Would it be possible to open up the import version to import a wider
> > range of versions? For example, perhaps [1.7.0,1.8.0).
> 
> We use maven-bundle-plugin to generate the manifest.mf. I think I read
> that it is possible to use some expression that generates such a range.
> I have to investigate on that. If you have any useful pointers would be
> helpful.
> 
> Kind Regards,
> Stefan
> 
> 

Mime
View raw message