directory-api mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <m...@stefan-seelmann.de>
Subject Re: [ApacheDS] ver 2.0 not working on Mac OS X 10.9
Date Tue, 29 Oct 2013 21:10:22 GMT
Hi Riccardo,

as a quick workaround you can try to use the old JNDI, in the connection
settings dialog you can select the network provider. We switched to our
own LDAP API by default.

If JNDI works it would still be great to find out what the problem is,
can you please create a new connection using the Apache LDAP API, and
try both, no encryption and encryption?

Thanks,
Stefan


On 10/29/2013 12:16 PM, Riccardo wrote:
> Dear all, 
> 
> today I installed Apache Directory Studio ver 2.0.0.v20130628
> 
> Once I tried to connect I get the following error: 
> 
> Error while opening connection
>  - Error while sending some message : the session has been closed
> org.apache.directory.ldap.client.api.exception.InvalidConnectionException: Error while
sending some message : the session has been closed
> 	at org.apache.directory.ldap.client.api.LdapNetworkConnection.writeRequest(LdapNetworkConnection.java:3943)
> 	at org.apache.directory.ldap.client.api.LdapNetworkConnection.bindAsync(LdapNetworkConnection.java:1178)
> 	at org.apache.directory.ldap.client.api.LdapNetworkConnection.bind(LdapNetworkConnection.java:1076)
> 	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper$2.run(DirectoryApiConnectionWrapper.java:368)
> 	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.runAndMonitor(DirectoryApiConnectionWrapper.java:1175)
> 	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.doBind(DirectoryApiConnectionWrapper.java:460)
> 	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.bind(DirectoryApiConnectionWrapper.java:306)
> 	at org.apache.directory.studio.connection.core.jobs.OpenConnectionsRunnable.run(OpenConnectionsRunnable.java:114)
> 	at org.apache.directory.studio.connection.core.jobs.StudioConnectionJob.run(StudioConnectionJob.java:109)
> 	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
> 
> Error while sending some message : the session has been closed
> 
> Everything was working fine with the previous version I was using (1.5). 
> What I use it's an SSL encryption on port 636 + Simple Authentication Method. 
> 
> In case you need further details about my system configuration please ask. 
> 
> Thank you for your support. 
> 
> Best Regards, 
> 
> Riccardo
> 


Mime
View raw message