directory-api mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <>
Subject Re: [Shared] API Design Questionnaire #1
Date Sun, 30 Jan 2011 20:34:39 GMT
On 1/30/11 7:07 PM, Alex Karasulu wrote:
> On Sun, Jan 30, 2011 at 7:29 PM, Stefan Seelmann<>wrote:
>> On Sun, Jan 30, 2011 at 5:11 PM, Alex Karasulu<>
>> wrote:
>>> On Sun, Jan 30, 2011 at 3:17 AM, Emmanuel Lecharny<
>>> wrote:
>>>> On 1/29/11 10:38 PM, Stefan Seelmann wrote:
>>>>>   [X] - (c)
>>>>>>             interface                                 = AddRequest
>>>>>>             simple API exposed implementation         =
>> AddRequest*Impl*
>>>>>>             not so simple internal use implementation =
>>>>>> AddRequest*Decoder*
>>>>>> We're applying option 'C' right now. I'm torn but think A might suite
>> us
>>>>>> better for the long term, and for any situation. You also know what's
>> an
>>>>>> interface and what's not although the IDE automatically shows you
>>>>>> stuff
>>>>>> on the package/class browser.
>>>>> This is my opinion for a low-level API, which 1:1 maps LDAP
>>>>> terminology to the Java API. I think we should additional have a
>>>>> simplified API where the user don't need to deal with request and
>>>>> response objects at all.
>>>>> BTW: We have this discussion again and again ;-) We really need to
>>>>> decide a consistent naming.
>>>> I think we already discussed it more than once, and we all agreed on
>> this
>>>> convention.
>>>> I'm not sure we want to rehash this again every 2 years :/
>>> When there's a push to release a 1.0 of an API, we need to make the API
>>> consistent. I can do this myself but the community way is to have a
>>> discussion. If  you do not want to discuss this feel free not to
>>> participate, or say you don't care.
>> I don't see that anyone said that the API development should not be
>> community driven.
> I did not suggest anyone said that. If you read above I am saying I have no
> choice but to post and share with the community rather than do it myself.

We have to be careful in our phrasing. Or we should be careful in the 
way we understand things.

The *I* notation in shared has been added temporarily in order to ease 
the refactoring, and should be removed in trunk.

Again, injecting them in trunk was probably a wrong move, and should 
have been done in a branch. We all know that...

Ok, assuming that this was just a misunderstanding, I guess we can move on.

Emmanuel L├ęcharny

View raw message