devicemap-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Reza Naghibi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DMAP-150) iPhone operating system version is always reported at "1.0"
Date Thu, 19 Mar 2015 22:41:38 GMT

    [ https://issues.apache.org/jira/browse/DMAP-150?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14370260#comment-14370260
] 

Reza Naghibi commented on DMAP-150:
-----------------------------------

Hey Angel, this is the proper place to address this.

So there are 2 issues at play here:

First, our device data only tells us how to identify devices. Until recently this was good
enough since knowing the device usually meant we have a pretty good idea what the operating
system is. This is because devices didnt really change operating systems much. Recently, this
has been changing. To address this shortcoming, we are creating a new operating system pattern
index which we will introduce in 2.0.

Second, one of the biggest exceptions to this rule is iOS. We have very little device information,
so it makes it harder to say something specific about the operating system since the device
drives the identification. Once we get our OS pattern index in place, this issue goes away
competely!

So the best thing to do is to ignore the operating system version until we have our 2.0 data
release because its just too inaccurate to know when to trust it and when its completely off.
Its also pretty simple to parse it out yourself for now.

Thanks for trying us out!

> iPhone operating system version is always reported at "1.0"
> -----------------------------------------------------------
>
>                 Key: DMAP-150
>                 URL: https://issues.apache.org/jira/browse/DMAP-150
>             Project: DeviceMap
>          Issue Type: Question
>            Reporter: Angel Darquea
>            Assignee: Reza Naghibi
>            Priority: Minor
>
> Hello, 
> I'm using devicemap-data v1.0.2 and devicemap-client v1.1.0.
> For some reason, all iPhone user agents resolve operating system version to "1.0" and
all iPad ones to "6.0". Please see the results here: http://pastebin.com/k7CBbNwm
> Can you advice?
> Thank you and please excuse me if this is not the proper channel to submit a question.
> Thank you.
> AD



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message