deltaspike-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Marinchuk <radist-h...@yandex.ru>
Subject Re: problem in pom.xml for distributions-bom artifact version 1.8.1-SNAPSHOT
Date Thu, 22 Jun 2017 05:29:50 GMT
Hi Mark!

Warning in eclipse neon appeared after I changed deltaspike.version from 
1.7.2 to 1.8.1-SNAPSHOT. May be it some cached outdated validation info, 
but after change back to 1.7.2 warning disappears. It appears again 
after change to 1.8.0 or 1.8.1-SNAPSHOT.
The warning message is "Overriding managed version 1.2.7 for 
openwebbeans-spi" (and "...-impl").
The only reference to the owb-1.2.7 I found was in parent artifact, but 
it looks like the some internal testing artifact.

I don't understand the maven well, but as for me, this warning message 
looks strange because artifact in dependencyManagement does not have any 
direct references to the openwebbeans.
Anyway, this warning seems does not influence the build process. May be 
I will recreate the eclipse workspace to exclude the caching effect.

Thanks for your answer!
Andrew Marinchuk

21.06.2017 16:18, Mark Struberg пишет:
> Hi Andrew!
>
> Thanks for the report!
> I'm not very much into the bom as I personally don't use it.
> But it sounds pretty much wrong if we define any openwebbeans version or dependency in
any of our dependencies.
> The container version and vendor should not be in the bom at all.
>
> DeltaSpike runs with OWB-1.1.x, 1.2.x 1.7.x and should even run with the upcoming 2.0.0
.
>
> What exactly from the bom do you use?
> The versions of the deltaspike modules are the same anyway, so I usually only use
>
> <properties>
>    <deltaspike.version>1.8.0</deltaspike.version>
> </properties>
>
> + <version>${deltaspike.version}</version> in the dependencies.
>
> And the versions of the various javaee api jars (geronmo*spec) are depending on the EE
version you use, and not on the DeltaSpike version.
>
> Would love to hear your use case!
>
> txs and LieGrue,
> strub
>
>> Am 21.06.2017 um 14:42 schrieb Andrew Marinchuk <radist-hack@yandex.ru>:
>>
>> Hi!
>>
>> After switching to deltaspike verison 1.8.1-SNAPSHOT, we've obtained a warning message
in eclipse to the version in openwebbeans dependencies.
>> Some investigations shows that pom.xml for groupId org.apache.deltaspike.distribution
and artifactId distributions-bom declares version 1.2.7 for openwebbeans. Looks like typing
error, should be 1.7.2. Previous deltaspike version (1.7.2) works with openwebbeans 1.7.2
and deltaspike 1.8.1-SNAPSHOT seems too.
>>
>> Here is part of our pom.xml:
>>
>> 	<properties>
>> 		<!--deltaspike.version>1.7.2</deltaspike.version-->
>> 		<deltaspike.version>1.8.1-SNAPSHOT</deltaspike.version>
>> 		<owb.version>1.7.2</owb.version>
>> 	</properties>
>> 	<dependencyManagement>
>> 		<dependencies>
>> 			<dependency>
>> 				<groupId>org.apache.deltaspike.distribution</groupId>
>> 				<artifactId>distributions-bom</artifactId>
>> 				<version>${deltaspike.version}</version>
>> 				<type>pom</type>
>> 				<scope>import</scope>
>> 			</dependency>
>> 		</dependencies>
>> 	</dependencyManagement>
>> 	<dependencies>
>> 		<dependency>
>> 			<groupId>org.apache.geronimo.specs</groupId>
>> 			<artifactId>geronimo-atinject_1.0_spec</artifactId>
>> 			<scope>compile</scope>
>> 		</dependency>
>> 		<dependency>
>> 			<groupId>org.apache.geronimo.specs</groupId>
>> 			<artifactId>geronimo-jcdi_1.1_spec</artifactId>
>> 			<version>1.0</version>
>> 			<scope>compile</scope>
>> 		</dependency>
>> 		<dependency>
>> 			<groupId>org.apache.geronimo.specs</groupId>
>> 			<artifactId>geronimo-interceptor_1.2_spec</artifactId>
>> 			<version>1.0</version>
>> 			<scope>compile</scope>
>> 		</dependency>
>> 		<dependency>
>> 			<groupId>org.apache.geronimo.specs</groupId>
>> 			<artifactId>geronimo-annotation_1.2_spec</artifactId>
>> 			<version>1.0</version>
>> 			<scope>compile</scope>
>> 		</dependency>
>> 		<dependency>
>> 			<groupId>org.apache.openwebbeans</groupId>
>> 			<artifactId>openwebbeans-spi</artifactId>
>> 			<version>${owb.version}</version>  <!-- Warning at this line -->
>> 			<scope>compile</scope>
>> 		</dependency>
>> 		<dependency>
>> 			<groupId>org.apache.openwebbeans</groupId>
>> 			<artifactId>openwebbeans-impl</artifactId>
>> 			<version>${owb.version}</version>  <!-- Warning at this line -->
>> 			<scope>runtime</scope>
>> 		</dependency>
>> 		<dependency>
>> 			<groupId>org.apache.deltaspike.core</groupId>
>> 			<artifactId>deltaspike-core-api</artifactId>
>> 			<scope>compile</scope>
>> 		</dependency>
>> 		<dependency>
>> 			<groupId>org.apache.deltaspike.core</groupId>
>> 			<artifactId>deltaspike-core-impl</artifactId>
>> 			<scope>runtime</scope>
>> 		</dependency>
>> 		<dependency>
>> 			<groupId>org.apache.deltaspike.cdictrl</groupId>
>> 			<artifactId>deltaspike-cdictrl-api</artifactId>
>> 			<scope>compile</scope>
>> 		</dependency>
>> 		<dependency>
>> 			<groupId>org.apache.deltaspike.cdictrl</groupId>
>> 			<artifactId>deltaspike-cdictrl-owb</artifactId>
>> 			<scope>runtime</scope>
>> 			<exclusions>
>> 				<exclusion>
>> 					<groupId>org.apache.deltaspike.test</groupId>
>> 					<artifactId>test-utils</artifactId>
>> 				</exclusion>
>> 			</exclusions>
>> 		</dependency>
>> 		<dependency>
>> 			<groupId>com.google.code.findbugs</groupId>
>> 			<artifactId>jsr305</artifactId>
>> 			<version>2.0.1</version>
>> 			<scope>compile</scope>
>> 		</dependency>
>> 	</dependencies>
>>
>>
>> Best regards,
>> Andrew Marinchuk
>>


Mime
View raw message