deltaspike-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Struberg <strub...@yahoo.de.INVALID>
Subject Re: Projectstage -> JNDI
Date Thu, 06 Oct 2016 10:15:12 GMT
Servus Thomas!

The easiest way to know what happens is to debug into DeltaSpike.
I guess that the JNDI propagation does not work in Payara. Probably they config pops up in
some other tree in JNDI? That happens on some containers…
You might still simply use the -D jvm parameter to set the ProjectStage. It is for the whole
server anyway.

LieGrue,
strub 

> Am 03.10.2016 um 21:54 schrieb Thomas Kernstock <t.kernstock@e-technologies.at>:
> 
> Hi,
>  
> I tried to configure the Deltaspike ProjectStage via JNDI on Payara 4.1 like this but
it doesn’t get picked up. (payara01.jpg) To make sure my environment works, I also tried
to set the stage with a JVM Parameter, which worked fine. 
>  
> Setting the JSF ProjectStage works fine in Payara -> payara02.jpg
>  
> I also tried payara03.jpg in combination with the web.xml entry:
>  
> <resource-ref>
>     <res-ref-name>deltaspike/ProjectStage</res-ref-name>
>     <res-type>java.lang.String</res-type>
>     <mapped-name>org.apache.deltaspike.ProjectStage</mapped-name>
> </resource-ref>
>  
>  
> So the question is what is wrong with my Deltaspike configuration. Any ideas?
>  
> best regards
> Thomas


Mime
View raw message