deltaspike-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edilmar LISTAS <edili...@intersite.com.br>
Subject DeltaSpike x Payara App Server
Date Tue, 05 Jul 2016 15:34:26 GMT
My actual environment is:

- Glassfish 3.1.2.2
- CDI Weld 1.1.8
- DeltaSpike 1.6.0
- JSF Mojarra javax.faces.jar 2.1.29
- RichFaces 4.5.15
- JPA 2
- Hibernate 4.2.7
- JasperReports 6.1.0
- JDBC drivers Jaybird/Firebird and PostgreSQL

Now, I have tried to change to:

-***** Payara 4.1.1 (Glassfish 4.1.1 clone)
-***** CDI Weld 2.3.2
- DeltaSpike 1.6.0
-***** JSF Mojarra javax.faces.jar 2.2.13
- RichFaces 4.5.15
- JPA 2
- Hibernate 4.2.7
- JasperReports 6.1.0
- JDBC drivers Jaybird/Firebird and PostgreSQL

My webapp is JEE6, but Payara team said me it is fully compatible with
JEE6/JEE7.

I tried first with deltaspike-jsf-module-impl-ee6-1.6.0.jar (DS JEE6 jar 
file), but when I try to run, the first login page (with login/pass 
required="true" fields) doesn't work properly. I type the values for 
login/pass and JSF page arises an error message that fields login/pass 
are required, JSF native error, nothing is sent to server.

After to change to deltaspike-jsf-module-impl-1.6.0.jar, the webapp
arises many exceptions and doesn't run.

Then, I think the right jar is the actual 
deltaspike-jsf-module-impl-ee6-1.6.0.jar. I don't know if the problem is 
with DS or other
JSF specific configuration.



Mime
View raw message