deltaspike-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Andraschko <andraschko.tho...@gmail.com>
Subject Re: WARNING on BeanProvider shall not be used to create ...
Date Tue, 08 Dec 2015 14:54:21 GMT
hmm? thats a completely other error as in the first mail.
Make sure you have the data-impl module included.


2015-12-08 15:40 GMT+01:00 Esteve Avilés <eavilesa@gmail.com>:

> Hi Thomas,
>
> I have the repository declared as:
>
> @Repository
>
> public abstract class ServeiVendaRepository extends
> BaseRepository<ServeiVenda> {
>
>
> And BaseRespository:
>
> public abstract class BaseRepository<ENTITY> implements
> CriteriaSupport<ENTITY>, EntityRepository<ENTITY, Long>,
> EntityManagerDelegate<ENTITY> {
>
> ....
>
>
> Then I get this error:
>
>
> Caused by: java.lang.AbstractMethodError:
>
> cat.tmb.tdo.ocicommerce.domain.bo.BaseRepository.save(Ljava/lang/Object;)Ljava/lang/Object;
>
> at cat.tmb.tdo.ocicommerce.domain.bo.BaseBO.save(BaseBO.java:192)
> [domain-1.14.0-snapshot.jar:]
>
> at cat.tmb.tdo.ocicommerce.domain.bo.venda.ServeiVendaBO.save(
> ServeiVendaBO.java:381) [domain-1.14.0-snapshot.jar:]
>
>
> Thanks:
>
> On Tue, Dec 8, 2015 at 3:09 PM, Thomas Andraschko <
> andraschko.thomas@gmail.com> wrote:
>
> > Hi,
> >
> > setting a scope (e.g. ApplicationScope) on your repositories should fix
> the
> > warning.
> > Repositories are normally stateless, so using ApplicationScoped should be
> > fine.
> >
>
>
>
> --
> Esteve Avilés
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message