deltaspike-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Markus Lachat" <markuslac...@gmx.de>
Subject AW: WindowClientMode shows white Loading... Page
Date Wed, 29 Jul 2015 20:06:29 GMT
 I tried both versions of DS (1.3.0 and 1.4.2) and also changed the playground to use type-safe
navigation, the same way my application does. For my application the window handler stores
away the site on most buttons and links, but not for all. Playground is fully working now,
I don't see the loading text there anymore. Really strange I saw it before.

I am now trying to find the difference between the links and buttons on playground and my
application. I will let you know, thanks for your help so far!

-----Urspr√ľngliche Nachricht-----
Von: Thomas Andraschko [mailto:andraschko.thomas@gmail.com] 
Gesendet: Dienstag, 28. Juli 2015 16:00
An: users@deltaspike.apache.org
Betreff: Re: WindowClientMode shows white Loading... Page

FYI:
Just tried it in the playground and it works fine e.g. when you open http://localhost:8080/ds/views/windowhandling/clientwindow/test.xhtml
and click on "GET Link".

The Problem is probably the Post-Redirect-Get as only the onclick of links will overwriten.
If you use a  button it might not work.
Could you please post a sample?


2015-07-28 15:42 GMT+02:00 Thomas Andraschko <andraschko.thomas@gmail.com>:

> Hi,
>
> which version do you use?
> I refactored many things in the last release. Can you also verify this 
> e.g. with 1.3.0?
>
> 2015-07-28 15:39 GMT+02:00 Markus Lachat <MarkusLachat@gmx.de>:
>
>> Hi,
>>
>> I migrated from CODI and everything went fine so far. I am using 
>> TypeSafe Navigation and Navigation Mode is set to redirect and 
>> viewParams is also included. So the application follows mostly the 
>> Post-Redirect-Get Pattern (as far as I understood).
>>
>> However I am seeing the white intermediate page, displaying the 
>> loading... text. The documentation states a HTML5 enabled browser 
>> caches the screen, css etc. to the localstorage and the flickering 
>> effect would be gone.
>>
>> I also tested the playground app, where I see the same effect. The 
>> main application runs on Websphere and the playground testing app on TomEE.
>>
>> Any suggestions? What am I doing wrong?
>>
>> Kind regards,
>> Markus
>>
>
>


Mime
View raw message