deltaspike-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marco Aurélio Silva <marc...@progic.com.br>
Subject Problem using Repository
Date Mon, 27 Apr 2015 16:20:48 GMT
Hi all

I'm having an exception trying to inject a repository. I'm using tomcat 7
with openWebBeans , and CDI is configured and working fine, but when I try
to inject a repository from deltaspike data project, I got the follow
exception:

INFO: class: com.progic.service.TestRepository activated=true
Apr 27, 2015 1:18:07 PM org.apache.webbeans.config.BeansDeployer
configureInterceptors
WARNING: Interceptor class :
org.apache.deltaspike.jpa.impl.transaction.TransactionalInterceptor is
already defined
Apr 27, 2015 1:18:07 PM
org.apache.webbeans.servlet.WebBeansConfigurationListener contextInitialized
SEVERE: An error occurred while starting application context path :
[/managerDSUP]
Apr 27, 2015 1:18:07 PM org.apache.catalina.core.StandardContext
listenerStart
SEVERE: Exception sending context initialized event to listener instance of
class org.apache.webbeans.servlet.WebBeansConfigurationListener
org.apache.webbeans.exception.WebBeansDeploymentException:
javax.enterprise.inject.UnsatisfiedResolutionException: Api type
[com.progic.service.TestRepository] is not found with the qualifiers
Qualifiers: [@javax.enterprise.inject.Default()]
for injection into Field Injection Point, field name :  testRepository,
Bean Owner : [PointConfMB, WebBeansType:MANAGED, Name:PointConfMB, API
Types:[java.lang.Object,view.point.PointConfMB,view.Filter,java.io.Serializable],
Qualifiers:[javax.enterprise.inject.Default,javax.enterprise.inject.Any,javax.inject.Named]]
at org.apache.webbeans.config.BeansDeployer.deploy(BeansDeployer.java:293)
at
org.apache.webbeans.lifecycle.AbstractLifeCycle.bootstrapApplication(AbstractLifeCycle.java:138)
at
org.apache.webbeans.lifecycle.AbstractLifeCycle.startApplication(AbstractLifeCycle.java:104)
at
org.apache.webbeans.web.lifecycle.WebContainerLifecycle.startApplication(WebContainerLifecycle.java:90)
at
org.apache.webbeans.servlet.WebBeansConfigurationListener.contextInitialized(WebBeansConfigurationListener.java:86)
at
org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:5016)
at
org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5524)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at
org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1575)
at
org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1565)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: javax.enterprise.inject.UnsatisfiedResolutionException: Api type
[com.progic.service.TestRepository] is not found with the qualifiers
Qualifiers: [@javax.enterprise.inject.Default()]
for injection into Field Injection Point, field name :  testRepository,
Bean Owner : [PointConfMB, WebBeansType:MANAGED, Name:PointConfMB, API
Types:[java.lang.Object,view.point.PointConfMB,view.Filter,java.io.Serializable],
Qualifiers:[javax.enterprise.inject.Default,javax.enterprise.inject.Any,javax.inject.Named]]
at
org.apache.webbeans.util.InjectionExceptionUtil.throwUnsatisfiedResolutionException(InjectionExceptionUtil.java:65)
at
org.apache.webbeans.container.InjectionResolver.checkInjectionPoint(InjectionResolver.java:226)
at
org.apache.webbeans.container.BeanManagerImpl.validate(BeanManagerImpl.java:1195)
at org.apache.webbeans.util.WebBeansUtil.validate(WebBeansUtil.java:1690)
at org.apache.webbeans.config.BeansDeployer.validate(BeansDeployer.java:809)
at
org.apache.webbeans.config.BeansDeployer.validateInjectionPoints(BeansDeployer.java:720)
at org.apache.webbeans.config.BeansDeployer.deploy(BeansDeployer.java:276)
... 13 more


On my faces bean I have two services being inject, only the repository
throws an exception:

 @Inject
    private PointService pointService;
    @Inject
    private TestRepository testRepository;

My |Repository looks like this:

@Named
@ApplicationScoped
@Repository(forEntity = Point.class)
public interface TestRepository extends EntityRepository<Point, Long>
{

}


What I'm doing wrong?? Can anyone help, please?


-- 

Marco Aurélio Silva
*Líder de Desenvolvimento Web*

Tel.:+55 (48) 3024.2704 | www.progic.com.br
Rua São João Batista, nº 65 | Agronômica

Cep: 88025-230 | Florianópolis /SC | Brasil

<https://www.facebook.com/progic> Facebook <https://www.facebook.com/progic>
  <http://progic.com.br/blog/> Blog <http://progic.com.br/blog/> [image:
ElementarDS] <https://www.youtube.com/watch?v=gdsYyjYcVaE> *ElementarDS
<https://www.youtube.com/watch?v=gdsYyjYcVaE>*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message