deltaspike-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edilmar LISTAS <edili...@intersite.com.br>
Subject Re: h:commandLink target="_blank" stopped to work
Date Wed, 14 Jan 2015 18:32:37 GMT
I returned to JSF2.1.6 and Richfaces4.3.7, only with new DeltaSpike 
instead of CODI because I changed many codes from old Conversation to 
new GroupConversation. Then, the same problem appears. I think there is 
some problem in my code using GroupedConversationScoped that doesn't 
work with Chrome, arising this crazy refresh.

On 14-01-2015 15:13, Edilmar LISTAS wrote:
> This is the "head" generated:
>
> <head>
>      <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
>      <link href="/sitesat2/css/default.css" rel="stylesheet"
> type="text/css" />
>      <link href="/sitesat2/css/cssLayout.css" rel="stylesheet"
> type="text/css" />
>      <script language="JavaScript" src="/sitesat2/js/md5.js"></script>
>      <script language="JavaScript" src="/sitesat2/js/funcoes.js"></script>
>      <title>SAT - Sistema Online para Transportadoras</title><link
> type="text/css" rel="stylesheet"
> href="/sitesat2/org.richfaces.resources/javax.faces.resource/org.richfaces.staticResource/4.5.1.Final/Packed/classic/org.richfaces.css/skinning.css"
> /><script type="text/javascript"
> src="/sitesat2/javax.faces.resource/jsf.js.jsf?ln=javax.faces&amp;stage=Development"></script><script
> type="text/javascript"
> src="/sitesat2/org.richfaces.resources/javax.faces.resource/org.richfaces.staticResource/4.5.1.Final/Packed/org.richfaces/jquery.js"></script><script
> type="text/javascript"
> src="/sitesat2/org.richfaces.resources/javax.faces.resource/org.richfaces.staticResource/4.5.1.Final/Packed/packed/packed.js"></script><link
> type="text/css" rel="stylesheet"
> href="/sitesat2/org.richfaces.resources/javax.faces.resource/org.richfaces.staticResource/4.5.1.Final/Packed/classic/packed/packed.css"
> /><script type="text/javascript"
> src="/sitesat2/javax.faces.resource/windowhandler.js.jsf?ln=deltaspike"></script></head>
>
>
> On 14-01-2015 15:09, Edilmar LISTAS wrote:
>> Hi,
>>
>> I discovered that if I remove <h:head>, where it doesn't matter if
>> <h:head> is empty or not, the refresh doesn't occur. But without
>> <h:head> Richfaces doesn't render correctly the components. I have no
>> idea of this stranged behaviour of Chrome with my new enviroment.
>>
>> On 14-01-2015 14:43, Thomas Andraschko wrote:
>>> Hey,
>>>
>>> don't know what do you mean with 3) as the url referers to page 2.
>>> The change of the dswid is by design because it's a new tab -> new
>>> window
>>> id.
>>>
>>> Regards,
>>> Thomas
>>>
>>>
>>> 2015-01-14 18:35 GMT+01:00 Edilmar LISTAS <edilista@intersite.com.br>:
>>>
>>>> Hi,
>>>>
>>>> My environment is: NetBeans 8.0.1 + Glassfish 3.1.2.2 + JSF 2.1.29 +
>>>> Richfaces 4.5.1 + CDI/Weld 1.1.8 (original) + Apache DeltaSpike 1.2.1
>>>> + JPA
>>>> 2 + Hibernate 4.2.7 + RDBMS Firebird 2.5.2 + JasperReports 5.5.… last
>>>> week
>>>> I change from my old enviroment:
>>>> - old JSF 2.1.6 to new JSF 2.1.29
>>>> - old RF 4.3.7 to new RF 4.5.1
>>>> - old CODI 1.0.6 (ConversationScoped) to new DeltaSpike 1.2.1
>>>> (GroupedConversationScoped)
>>>>
>>>> I have commandLinks with target="_blank" that worked fine in old
>>>> environment with many new versions of Firefox and Chrome.
>>>>
>>>> Now, it doesn't work in new enviroment only in Chrome, Firefox
>>>> continues
>>>> to work fine.
>>>>
>>>> When I am in a JSF page and clicks in a commandLink with
>>>> target="_blank"
>>>> in Chrome, it opens a new tab with the new page I need but it does a
>>>> "strange refresh" and goes back to the same page from the first tab.
>>>> Do you
>>>> have any idea about this strange problem?
>>>>
>>>> I noticed this behaviour of link generated:
>>>> 1) user in page1 clicks the link http://192.168.200.202:8080/
>>>> sitesat2/filClienteFil.jsf?dswid=7384 that should be opened in a new
>>>> _blank tab.
>>>> 2) page2 is opened in a new _blank tab with link
>>>> http://192.168.200.202:8080/sitesat2/cadCliente.jsf?dswid=7384
>>>> 3) page2 is "refreshed" to page1 with link http://192.168.200.202:8080/
>>>> sitesat2/cadCliente.jsf?dswid=6114 => THE STRANGE IS.. dswid changed,
>>>> like it would be in another conversation.
>>>>
>>>
>>
>>
>
>


Mime
View raw message