deltaspike-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hampus Wingren (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DELTASPIKE-359) Websphere 8.0.x javaassist proxy does not reflect instance value
Date Mon, 06 May 2013 20:16:17 GMT

    [ https://issues.apache.org/jira/browse/DELTASPIKE-359?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13650062#comment-13650062
] 

Hampus Wingren commented on DELTASPIKE-359:
-------------------------------------------

Yes, I've tried both META-INF and WEB-INF. He loads the ViewConfigExtension and everything
looks ok but something strange happens in the ViewConfigExtension (and it doesn't seem like
a logical error in DS). The ViewConfigExtension.transformMetaData is called and the ViewConfigResolver
is loaded but then, one line later it still returns null on getViewConfigResolver. It feels
like somekind of proxying error in javaassist. 
WAS 8.5 and the Liberty profile works but I'm stuck with 8.0.0.5 (tried 8.0.0.6 but no luck)

Regards
Hampus
                
> Websphere 8.0.x javaassist proxy does not reflect instance value
> ----------------------------------------------------------------
>
>                 Key: DELTASPIKE-359
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-359
>             Project: DeltaSpike
>          Issue Type: Bug
>          Components: JSF-Module
>    Affects Versions: 0.4-incubating
>         Environment: Websphere 8.0.x, Windows 7
>            Reporter: Hampus Wingren
>
> I have a strange issue in the ViewConfigResolverProducer where the ViewConfigResolver
is always null. When I debug what's happening I can see that the underlying ViewConfigExtension
creates a ViewConfigResolver and stores it in an instance variable which is later is returned
through getViewConfigResolver. However, the returned value is always null. I've tested this
in the Liberty profile where it works so it seems to be isolated to Websphere 8.0.x line.
Have you seen anything like this before?
> Regards,
> Hampus

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message