deltaspike-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Struberg <strub...@yahoo.de>
Subject Re: Integration testing not possible with current version of WLS12c
Date Sat, 01 Dec 2012 18:48:12 GMT
Sad to hear Rudy, seems like WLS12c is most likely broken for any non-trivial CDI Extension
:/

Hoping for a soonish new release of WLS12 as well!


LieGrue,
strub



----- Original Message -----
> From: Rudy De Busscher <rdebusscher@gmail.com>
> To: deltaspike-dev@incubator.apache.org
> Cc: 
> Sent: Saturday, December 1, 2012 7:30 PM
> Subject: Integration testing not possible with current version of WLS12c
> 
> All,
> 
> I had some time today to have a look at the problems with the integration
> tests on WLS12c server. (DELTASPIKE-261)
> 
> I created a web application that performs the same test as described in
> org.apache.deltaspike.test.security.impl.authorization.securitybinding.SecurityBindingTest#simpleInterceptorTest
> 
> At the end, it seams that DeltaSpike has the same issue as CODI when it
> comes to CDI extensions in WLS12c.  A possible solution is to unjar the
> deltaspike jar files into the classes directory as described here for CODI
> (2)
> 
> I tried to change the shrinkwrap war creation to simulate the unjarring of
> the artifacts but I wasn't successful.  But in any case, I think we 
> can't
> use WLS12c any longer as one of the containers that we use for integration
> testing of DeltaSpike.
> 
> As Joseph Snyder mentioned in a mail back in march, we can only hope for a
> new release of the app server by the end of the year.
> 
> Regards
> Rudy
> 
> (1) : https://issues.apache.org/jira/browse/DELTASPIKE-261
> (2) :
> http://jsfcorner.blogspot.com/2012/01/codi-on-oracle-weblogic-server-12c.html
> 

Mime
View raw message