deltaspike-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Struberg (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (DELTASPIKE-213) move atinject-api, jcdi-api and interceptors-api dependencies to the container configuration
Date Thu, 05 Jul 2012 22:43:34 GMT

     [ https://issues.apache.org/jira/browse/DELTASPIKE-213?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mark Struberg resolved DELTASPIKE-213.
--------------------------------------

    Resolution: Fixed
    
> move atinject-api, jcdi-api and interceptors-api dependencies to the container configuration
> --------------------------------------------------------------------------------------------
>
>                 Key: DELTASPIKE-213
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-213
>             Project: DeltaSpike
>          Issue Type: Bug
>          Components: build_infra
>    Affects Versions: 0.2-incubating
>            Reporter: Mark Struberg
>            Assignee: Mark Struberg
>             Fix For: 0.3-incubating
>
>
> We currently have the atinject-api, jcdi-api and interceptors-api dependencies from Apache
Geronimo defined in the root pom. This is being used for all containers, regardless if they
use them or would need another dependency (e.g. the jboss-jcdi-api).
> Since the API changes in CDI-1.1, we need to move those dependencies to the container
configurations.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message