deltaspike-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Struberg (JIRA)" <>
Subject [jira] [Commented] (DELTASPIKE-201) move NarrowingBeanBuilder to API utils and rename it
Date Fri, 15 Jun 2012 13:04:42 GMT


Mark Struberg commented on DELTASPIKE-201:

renamed to WrappingBeanBuilder and moved to deltaspike-core-api util.bean  package.

Tests are still missing ...
> move NarrowingBeanBuilder to API utils and rename it
> ----------------------------------------------------
>                 Key: DELTASPIKE-201
>                 URL:
>             Project: DeltaSpike
>          Issue Type: New Feature
>          Components: Core
>    Affects Versions: 0.3-incubating
>            Reporter: Mark Struberg
>            Assignee: Mark Struberg
>             Fix For: 0.3-incubating
> NarrowingBeanBuilder is currently in the deltaspike-impl message package. But this class
is really usable especially for Extension developers as well. Thus we shall move it to deltaspike-api
util package.
> NarrowingBeanBuilder cannot only change the implementation Types but also the Qualifiers
and other attributes. After a discussion with Pete and Gerhard we came up with the name
> WrappingBeanBuilder
> This is still just a suggestion, but it is a bit closer to the real feature set now.
If anyone has an idea for a better name, then pleas shout out loud ;)

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message