deltaspike-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Allen <dan.j.al...@gmail.com>
Subject Re: [DISCUSS] [DELTASPIKE-28] ServiceProvider
Date Fri, 30 Dec 2011 00:11:52 GMT
On Wed, Dec 28, 2011 at 06:53, Mark Struberg <struberg@yahoo.de> wrote:

> oki, seems the majority is for dropping Java5 support. I've upgraded the
> parent pom to language target level 1.6 already.
>

+1


>
> Please note that this doesn't mean that we drop JavaEE-5 support! I still
> like to support CDI containers running on EE-5 if possible.
>

I have always felt like it's much better to look forward, not backward.
Here's how I've always made this case.

Migrating programming models is a pretty big deal. It requires changing
quite a bit of code, probably even rewriting an application. Upgrading Java
SE is much, much, much less complex. People (companies, projects, etc) who
refuse to upgrade the JVM version are just dragging their feet. (If they
aren't changing anything, that's a different story. It's people that want
to upgrade a programming model but not the JVM version that I'm calling
into question).

So I'm glad we are setting the SE 6 baseline :)

-Dan

-- 
Dan Allen
Principal Software Engineer, Red Hat | Author of Seam in Action
Registered Linux User #231597

http://google.com/profiles/dan.j.allen
http://mojavelinux.com
http://mojavelinux.com/seaminaction

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message