deltaspike-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Struberg <strub...@yahoo.de>
Subject basic decisions - package and class naming
Date Mon, 12 Dec 2011 11:24:02 GMT
Hi folks!

Back to work after being sick for a week. I think it's time to start hacking on DeltaSpike!

But before we do so, I'd like to clarify a few basic things

a.) package names

I'd suggest 

> org.apache.deltaspike.core.* 

for our core stuff

> org.apache.deltaspike.jpa.* 

for JPA


> org.apache.deltaspike.jsf.jsf12.* 

for JSF-1.2

> org.apache.deltaspike.jsf.jsf20.* 

for JSF-2.0, etc



In general most of our project parts will contain the following 3 sub- parts

*) api - the parts meant to be imported in customer projects with Maven <scope>compile

*) impl - does the actual work, not intended to be used in customer projects diretly. Thus
Maven <scope>runtime only.

*) spi - parts meant to be used for extending the default functionality. Up for discussion,
not sure if we really need it! This might also be done directly in impl, users can still 


Matze mentioned that he doesn't like to have 'api' in the package name. What do you like to
use instead to distinguish between those? Having an own package name probably makes it easier
to use the maven-shade-plugin. Any opinions?


Are there any Class naming conventions/rules you like to introduce? Pros, cons?


LieGrue,
strub


Mime
View raw message