deltaspike-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: DeltaSpike Weld 2.2.0 #2
Date Wed, 16 Apr 2014 02:09:34 GMT
See <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/2/changes>

Changes:

[tandraschko] DELTASPIKE-569 Improve DeltaSpikeResourceHandler handling

[tommy] DELTASPIKE-569 Improve DeltaSpikeResourceHandler handling

[tommy] Revert "DELTASPIKE-569 Improve DeltaSpikeResourceHandler handling"

[tandraschko] DELTASPIKE-569 Improve DeltaSpikeResourceHandler handling

[tandraschko] DELTASPIKE-574 Versioning for DeltaSpike JSF resources

------------------------------------------
Started by timer
Building remotely on ubuntu5 (Ubuntu ubuntu) in workspace <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/>
Cloning the remote Git repository
Cloning repository https://git-wip-us.apache.org/repos/asf/deltaspike.git
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/deltaspike.git
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/deltaspike.git
Checking out Revision 0a4bc446b5d8a75b67a211a883004c88187ed630 (origin/master)
Parsing POMs
maven3-agent.jar already up to date
maven3-interceptor.jar already up to date
maven3-interceptor-commons.jar already up to date
[deltaspike] $ /home/hudson/tools/java/latest1.7/bin/java -cp /home/jenkins/jenkins-slave/maven3-agent.jar:/home/hudson/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar
org.jvnet.hudson.maven3.agent.Maven3Main /home/hudson/tools/maven/apache-maven-3.0.4 /home/jenkins/jenkins-slave/slave.jar
/home/jenkins/jenkins-slave/maven3-interceptor.jar /home/jenkins/jenkins-slave/maven3-interceptor-commons.jar
38398
<===[JENKINS REMOTING CAPACITY]===>channel started
   log4j:WARN No appenders could be found for logger (org.apache.commons.beanutils.converters.BooleanConverter).
log4j:WARN Please initialize the log4j system properly.
Executing Maven:  -B -f <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/pom.xml>
-Dmaven.repo.local=/home/jenkins/jenkins-slave/maven-repositories/1 clean install -PWeld -Dweld.version=2.2.0
[INFO] Scanning for projects...
Downloading: https://repository.apache.org/content/repositories/releases/org/jboss/weld/weld-core-bom/2.2.0/weld-core-bom-2.2.0.pom
Downloading: https://repository.apache.org/content/repositories/snapshots/org/jboss/weld/weld-core-bom/2.2.0/weld-core-bom-2.2.0.pom
Downloading: http://repo.maven.apache.org/maven2/org/jboss/weld/weld-core-bom/2.2.0/weld-core-bom-2.2.0.pom
Downloading: https://repository.apache.org/content/repositories/releases/org/jboss/weld/weld-core-bom/2.2.0/weld-core-bom-2.2.0.pom
Downloading: https://repository.apache.org/content/repositories/snapshots/org/jboss/weld/weld-core-bom/2.2.0/weld-core-bom-2.2.0.pom
Downloading: http://repo.maven.apache.org/maven2/org/jboss/weld/weld-core-bom/2.2.0/weld-core-bom-2.2.0.pom
Downloading: https://repository.apache.org/content/repositories/releases/org/jboss/weld/weld-core-bom/2.2.0/weld-core-bom-2.2.0.pom
Downloading: https://repository.apache.org/content/repositories/snapshots/org/jboss/weld/weld-core-bom/2.2.0/weld-core-bom-2.2.0.pom
Downloading: http://repo.maven.apache.org/maven2/org/jboss/weld/weld-core-bom/2.2.0/weld-core-bom-2.2.0.pom
[ERROR] The build could not read 3 projects -> [Help 1]
[ERROR]   
[ERROR]   The project org.apache.deltaspike:parent-code:0.7-SNAPSHOT (<https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml)>
has 7 errors
[ERROR]     Non-resolvable import POM: Could not find artifact org.jboss.weld:weld-core-bom:pom:2.2.0
in Apache Repository (https://repository.apache.org/content/repositories/releases) @ line
245, column 33 -> [Help 2]
[ERROR]     'dependencies.dependency.version' for javax.enterprise:cdi-api:jar is missing.
@ line 255, column 29
[ERROR]     'dependencies.dependency.version' for org.jboss.weld:weld-api:jar is missing.
@ line 260, column 29
[ERROR]     'dependencies.dependency.version' for org.jboss.weld:weld-core:jar is missing.
@ line 265, column 29
[ERROR]     'dependencies.dependency.version' for org.jboss.spec.javax.ejb:jboss-ejb-api_3.1_spec:jar
is missing. @ line 281, column 29
[ERROR]     'dependencies.dependency.version' for javax.validation:validation-api:jar is missing.
@ line 286, column 29
[ERROR]     'dependencies.dependency.version' for javax.persistence:persistence-api:jar is
missing. @ line 291, column 29
[ERROR]   
[ERROR]   The project org.apache.deltaspike.core:core-project:0.7-SNAPSHOT (<https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/core/pom.xml)>
has 7 errors
[ERROR]     Non-resolvable import POM: Could not find artifact org.jboss.weld:weld-core-bom:pom:2.2.0
in Apache Repository (https://repository.apache.org/content/repositories/releases) @ org.apache.deltaspike:parent-code:0.7-SNAPSHOT,
<https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 245, column 33 -> [Help 2]
[ERROR]     'dependencies.dependency.version' for javax.enterprise:cdi-api:jar is missing.
@ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 255, column 29
[ERROR]     'dependencies.dependency.version' for org.jboss.weld:weld-api:jar is missing.
@ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 260, column 29
[ERROR]     'dependencies.dependency.version' for org.jboss.weld:weld-core:jar is missing.
@ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 265, column 29
[ERROR]     'dependencies.dependency.version' for org.jboss.spec.javax.ejb:jboss-ejb-api_3.1_spec:jar
is missing. @ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 281, column 29
[ERROR]     'dependencies.dependency.version' for javax.validation:validation-api:jar is missing.
@ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 286, column 29
[ERROR]     'dependencies.dependency.version' for javax.persistence:persistence-api:jar is
missing. @ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 291, column 29
[ERROR]   
[ERROR]   The project org.apache.deltaspike.modules:modules-project:0.7-SNAPSHOT (<https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/modules/pom.xml)>
has 7 errors
[ERROR]     Non-resolvable import POM: Could not find artifact org.jboss.weld:weld-core-bom:pom:2.2.0
in Apache Repository (https://repository.apache.org/content/repositories/releases) @ org.apache.deltaspike:parent-code:0.7-SNAPSHOT,
<https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 245, column 33 -> [Help 2]
[ERROR]     'dependencies.dependency.version' for javax.enterprise:cdi-api:jar is missing.
@ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 255, column 29
[ERROR]     'dependencies.dependency.version' for org.jboss.weld:weld-api:jar is missing.
@ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 260, column 29
[ERROR]     'dependencies.dependency.version' for org.jboss.weld:weld-core:jar is missing.
@ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 265, column 29
[ERROR]     'dependencies.dependency.version' for org.jboss.spec.javax.ejb:jboss-ejb-api_3.1_spec:jar
is missing. @ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 281, column 29
[ERROR]     'dependencies.dependency.version' for javax.validation:validation-api:jar is missing.
@ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 286, column 29
[ERROR]     'dependencies.dependency.version' for javax.persistence:persistence-api:jar is
missing. @ org.apache.deltaspike:parent-code:0.7-SNAPSHOT, <https://builds.apache.org/job/DeltaSpike%20Weld%202.2.0/ws/deltaspike/parent/code/pom.xml,>
line 291, column 29
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
channel stopped

Mime
View raw message