deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Koper, Dies" <di...@fast.au.fujitsu.com>
Subject RE: travis build error
Date Sat, 06 Apr 2013 21:43:51 GMT
Hi Michal,

The 2.0.0 build seems to be down again/still. Fortunately the other two
passed fine; maybe it's an intermittent issue.

ruby -v: ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-linux]
[ rake drivers:openstack ]
Loaded suite 
Started
................
No output has been received in the last 10 minutes, this potentially
indicates a stalled build or something wrong with the build itself.
The build has been terminated

Regards,
Dies Koper


> -----Original Message-----
> From: Michal Fojtik [mailto:mfojtik@redhat.com]
> Sent: Saturday, 6 April 2013 5:53 AM
> To: dev@deltacloud.apache.org
> Subject: Re: travis build error
> 
> On 04/05/2013 03:45 AM, Koper, Dies wrote:
> 
> Thanks for reporting this Dies. We already fixed this issue. It was
> caused by new version of 'fog' which require newer excon.
> 
> However this newer excon is not compatible with VCR ;-) (rubygems ftw
;-).
> 
> I monkey-patched excon to be backward compatible and reported it to
> upstream (they come with similar fix in few minutes).
> 
> -- Michal
> 
> > Hi Michal,
> >
> > I noticed the build failed after my push but I don't think my patch
> had
> > anything to do with it:
> >
> > [11:45] -travis-ci:#deltacloud- [travis-ci] mifo/deltacloud#381
> (master
> > - 2a53220 : Dies Koper): The build has errored.
> > [11:45] -travis-ci:#deltacloud- [travis-ci] Change view :
> >
> https://github.com/mifo/deltacloud/compare/237a455606f8...2a53220f00
> 7e
> > [11:45] -travis-ci:#deltacloud- [travis-ci] Build details :
> > http://travis-ci.org/mifo/deltacloud/builds/6067911
> >
> > $ cd server
> > $ bundle install
> > Fetching gem metadata from http://rubygems.org/.......
> > Fetching gem metadata from http://rubygems.org/..
> > Resolving dependencies...
> > Bundler could not find compatible versions for gem "excon":
> >    In Gemfile:
> >      deltacloud-core (>= 0) ruby depends on
> >        excon (< 0.17.0, >= 0.14.2) ruby
> >      deltacloud-core (>= 0) ruby depends on
> >        excon (0.20.1)
> > The command "bundle install" failed and exited with 6 during
install.
> >
> > (same for all ruby versions)
> >
> > Regards,
> > Dies Koper
> >
> 
> 
> --
> 
> Michal Fojtik <mfojtik@redhat.com>
> Deltacloud API, CloudForms



Mime
View raw message