deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ronelle Landy <rla...@redhat.com>
Subject Re: should cimi tests be passing?
Date Thu, 04 Apr 2013 00:04:40 GMT
> From: "Dies Koper" <diesk@fast.au.fujitsu.com>
> To: dev@deltacloud.apache.org
> Sent: Wednesday, April 3, 2013 6:58:36 PM
> Subject: RE: should cimi tests be passing?
> 
> I should have added the full trace from rake:
> 
> D:/Programs/Ruby193/lib/ruby/gems/1.9.1/gems/rest-client-1.6.7/lib/restc
> lient/abstract_response.rb:48:in `return!': 500 Internal Server
>  Error (RestClient::InternalServerError)
>         from
> D:/Programs/Ruby193/lib/ruby/gems/1.9.1/gems/rest-client-1.6.7/lib/restc
> lient/request.rb:230:in `process_result'
>         from
> D:/Programs/Ruby193/lib/ruby/gems/1.9.1/gems/rest-client-1.6.7/lib/restc
> lient/request.rb:178:in `block in transmit'
>         from D:/Programs/Ruby193/lib/ruby/1.9.1/net/http.rb:745:in
> `start'
>         from
> D:/Programs/Ruby193/lib/ruby/gems/1.9.1/gems/rest-client-1.6.7/lib/restc
> lient/request.rb:172:in `transmit'
>         from
> D:/Programs/Ruby193/lib/ruby/gems/1.9.1/gems/rest-client-1.6.7/lib/restc
> lient/request.rb:64:in `execute'
>         from
> D:/Programs/Ruby193/lib/ruby/gems/1.9.1/gems/rest-client-1.6.7/lib/restc
> lient/request.rb:33:in `execute'
>         from
> D:/Programs/Ruby193/lib/ruby/gems/1.9.1/gems/rest-client-1.6.7/lib/restc
> lient.rb:72:in `post'
>         from
> d:/sources/OSS/cloud/deltacloud/tests/cimi/test_helper.rb:166:in `post'
>         from
> d:/sources/OSS/cloud/deltacloud/tests/cimi/part4_test.rb:78:in
> `<class:AddVolumeToMachine>'
>         from
> d:/sources/OSS/cloud/deltacloud/tests/cimi/part4_test.rb:21:in `<top
> (required)>'
> 
> I was only assuming the uninitialized constant error was related to this
> failure; I suppose they could be unrelated.
> 
> Regards,
> Dies Koper
> 
> 
> 
> > -----Original Message-----
> > From: Koper, Dies [mailto:diesk@fast.au.fujitsu.com]
> > Sent: Thursday, 4 April 2013 9:55 AM
> > To: dev@deltacloud.apache.org
> > Subject: should cimi tests be passing?
> > 
> > Hi Ronelle,
> > 
> > Are the cimi tests currently passing for you?
> > 
> > When I run rake test:cimi in deltacloud\tests with the mock driver, I
> > get a failure in part4, with the following error on the server:
> > 
> > E, [2013-04-04T09:36:17.402963 #1296] ERROR -- 500: [NameError]
> > uninitialized constant CIMI::Service::VolumeConfigurationCreate
> > 
> > Regards,
> > Dies Koper
> > 
> > 

Hi Dies,
Thanks for the report - I see the failure ... logging the change 

Mime
View raw message