deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ronelle Landy <rla...@redhat.com>
Subject Re: Need your help for running Deltacloud server on Windows machine
Date Thu, 18 Apr 2013 14:04:56 GMT

> From: "Madhuri" <m.disale@zensar.in>
> To: dev@deltacloud.apache.org
> Sent: Thursday, April 18, 2013 1:46:37 AM
> Subject: Need your help for running Deltacloud server on Windows machine
> 
> Hi team,
> 
> I have installed deltacloud server on my windows machine.
> DevKit Package : DevKit-tdm-32-4.5.2-20111229-1559-sfx.exe
> Ruby Installer: rubyinstaller-1.9.2-p392.exe
> 
> While running command : gem install deltacloud-core there was an error:
> ERROR:  While executing gem ... (Gem::DependencyError)
>     Unable to resolve dependencies: deltacloud-core requires excon (< 0.17.0,
>     >=
>  0.14.2); fog requires excon (~> 0.20)
> 
> To resolve this error I have installed excon-0.15.0 and excon-0.20.0
> 
> After that installation command runs smoothly. But while running deltacloud
> server with 'deltacloudd -i ec2' command , it is showing me an error:
> 
> D:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:774:in `block
> in a
> ctivate_dependencies': can't satisfy 'excon (< 0.17.0, >= 0.14.2)', already
> acti
> vated 'excon-0.20.0' (Gem::LoadError)
>         from
>         D:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:766:i
> n `each'
>         from
>         D:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:766:i
> n `activate_dependencies'
>         from
>         D:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:750:i
> n `activate'
>         from D:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems.rb:1232:in `gem'
>         from D:/Ruby193/bin/deltacloudd:22:in `<main>'
> Now I am stucked. kindly help.
> Regards,
> Madhuri Disale
> 
Hi Madhuri Disale,

I assume you are working with deltacloud-core-1.1.2.gem. Subsequent to the initial release
of deltacloud-core-1.1.2, (the gem currently available), there was a dependency upgrade made
to one of the gems on which Deltacloud depends.

We have fixed the dependency issue in the next release of the Deltacloud gem - that was just
posted on list for testing and approval: http://people.apache.org/~mfojtik/deltacloud/1.1.3rc1/.
Please try out this version of the deltacloud-core gem to see if it resolves the error you
reported.

Thanks,
Ronelle 

Mime
View raw message