deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marios Andreou (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DTACLOUD-508) Fresh detacloud install doesnt create database file
Date Fri, 08 Mar 2013 15:18:13 GMT

    [ https://issues.apache.org/jira/browse/DTACLOUD-508?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13597203#comment-13597203
] 

Marios Andreou commented on DTACLOUD-508:
-----------------------------------------

more debug info from Carlos:

    ubuntu@dc:~$ rvm gemset list
     
    gemsets for ruby-1.9.3-p392 (found in /home/ubuntu/.rvm/gems/ruby-1.9.3-p392)
    => (default)
       global
     
    ubuntu@dc:~$ rvm gemset create dc
    gemset created dc       => /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc
    ubuntu@dc:~$ cd deltacloud/
    ==============================================================================
    = NOTICE                                                                     =
    ==============================================================================
    = RVM has encountered a new or modified .rvmrc file in the current directory =
    = This is a shell script and therefore may contain any shell commands.       =
    =                                                                            =
    = Examine the contents of this file carefully to be sure the contents are    =
    = safe before trusting it! ( Choose v[iew] below to view the contents )      =
    ==============================================================================
    Do you wish to trust this .rvmrc file? (/home/ubuntu/deltacloud/.rvmrc)
    y[es], n[o], v[iew], c[ancel]> yes
    ubuntu@dc:~/deltacloud$ gem install deltacloud-core --no-ri --no-rdoc
    Fetching: tilt-1.3.5.gem (100%)
    Fetching: haml-4.0.0.gem (100%)
     
    HEADS UP! Haml 4.0 has many improvements, but also has changes that may break
    your application:
     
    * Support for Ruby 1.8.6 dropped
    * Support for Rails 2 dropped
    * Sass filter now always outputs <style> tags
    * Data attributes are now hyphenated, not underscored
    * html2haml utility moved to the html2haml gem
    * Textile and Maruku filters moved to the haml-contrib gem
     
    For more info see:
     
    http://rubydoc.info/github/haml/haml/file/CHANGELOG.md
     
    Fetching: rack-1.5.2.gem (100%)
    Fetching: rack-protection-1.4.0.gem (100%)
    Fetching: sinatra-1.3.5.gem (100%)
    Fetching: sinatra-rabbit-1.1.6.gem (100%)
    Fetching: rack-accept-0.4.5.gem (100%)
    Fetching: json_pure-1.7.7.gem (100%)
    Fetching: net-ssh-2.6.6.gem (100%)
    Fetching: nokogiri-1.5.6.gem (100%)
    Building native extensions.  This could take a while...
    Fetching: sequel-3.42.0.gem (100%)
    Fetching: sqlite3-1.3.7.gem (100%)
    Building native extensions.  This could take a while...
    Fetching: eventmachine-1.0.3.gem (100%)
    Building native extensions.  This could take a while...
    Fetching: daemons-1.1.9.gem (100%)
    Fetching: thin-1.5.0.gem (100%)
    Building native extensions.  This could take a while...
    Fetching: mime-types-1.21.gem (100%)
    Fetching: rest-client-1.6.7.gem (100%)
    Fetching: rbovirt-0.0.18.gem (100%)
    Fetching: uuidtools-2.1.3.gem (100%)
    Fetching: http_connection-1.4.4.gem (100%)
    Fetching: xml-simple-1.1.2.gem (100%)
    Fetching: aws-2.8.0.gem (100%)
    Fetching: ruby-hmac-0.4.0.gem (100%)
    Fetching: waz-storage-1.3.3.gem (100%)
    Fetching: json-1.7.7.gem (100%)
    Building native extensions.  This could take a while...
    Fetching: cloudservers-0.4.2.gem (100%)
    Fetching: cloudfiles-1.5.0.1.gem (100%)
    Fetching: builder-3.2.0.gem (100%)
    Fetching: excon-0.19.5.gem (100%)
    Fetching: formatador-0.2.4.gem (100%)
    Fetching: multi_json-1.6.1.gem (100%)
    Fetching: net-scp-1.1.0.gem (100%)
    Fetching: fog-1.10.0.gem (100%)
    Fetching: openstack-1.0.9.gem (100%)
    Fetching: nori-2.0.4.gem (100%)
    Fetching: httpi-2.0.2.gem (100%)
    Fetching: wasabi-3.0.0.gem (100%)
    Fetching: gyoku-1.0.0.gem (100%)
    Fetching: akami-1.2.0.gem (100%)
    Fetching: savon-2.1.0.gem (100%)
    Fetching: trollop-2.0.gem (100%)
    Fetching: rbvmomi-1.6.0.gem (100%)
    Fetching: deltacloud-core-1.1.1.gem (100%)
    Successfully installed tilt-1.3.5
    Successfully installed haml-4.0.0
    Successfully installed rack-1.5.2
    Successfully installed rack-protection-1.4.0
    Successfully installed sinatra-1.3.5
    Successfully installed sinatra-rabbit-1.1.6
    Successfully installed rack-accept-0.4.5
    Successfully installed json_pure-1.7.7
    Successfully installed net-ssh-2.6.6
    Successfully installed nokogiri-1.5.6
    Successfully installed sequel-3.42.0
    Successfully installed sqlite3-1.3.7
    Successfully installed eventmachine-1.0.3
    Successfully installed daemons-1.1.9
    Successfully installed thin-1.5.0
    Successfully installed mime-types-1.21
    Successfully installed rest-client-1.6.7
    Successfully installed rbovirt-0.0.18
    Successfully installed uuidtools-2.1.3
    Successfully installed http_connection-1.4.4
    Successfully installed xml-simple-1.1.2
    Successfully installed aws-2.8.0
    Successfully installed ruby-hmac-0.4.0
    Successfully installed waz-storage-1.3.3
    Successfully installed json-1.7.7
    Successfully installed cloudservers-0.4.2
    Successfully installed cloudfiles-1.5.0.1
    Successfully installed builder-3.2.0
    Successfully installed excon-0.19.5
    Successfully installed formatador-0.2.4
    Successfully installed multi_json-1.6.1
    Successfully installed net-scp-1.1.0
    Successfully installed fog-1.10.0
    Successfully installed openstack-1.0.9
    Successfully installed nori-2.0.4
    Successfully installed httpi-2.0.2
    Successfully installed wasabi-3.0.0
    Successfully installed gyoku-1.0.0
    Successfully installed akami-1.2.0
    Successfully installed savon-2.1.0
    Successfully installed trollop-2.0
    Successfully installed rbvmomi-1.6.0
    Successfully installed deltacloud-core-1.1.1
    43 gems installed
    ubuntu@dc:~/deltacloud$ deltacloudd -f cimi -i openstack -v -P "http://cloud.atnog.av.it.pt:5000/v2.0/"
-r 0.0.0.0
    Starting Deltacloud API :: openstack :: http://cloud.atnog.av.it.pt:5000/v2.0/ :: http://0.0.0.0:3001/cimi/cloudEntryPoint
     
    /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/adapters/sqlite.rb:108:in
`initialize': SQLite3::CantOpenException: unable to open database file (Sequel::DatabaseConnectionError)
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/adapters/sqlite.rb:108:in
`new'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/adapters/sqlite.rb:108:in
`connect'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/connection_pool.rb:94:in
`make_new'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/connection_pool/threaded.rb:164:in
`make_new'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/connection_pool/threaded.rb:137:in
`available'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/connection_pool/threaded.rb:127:in
`block in acquire'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/connection_pool/threaded.rb:195:in
`block in sync'
            from <internal:prelude>:10:in `synchronize'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/connection_pool/threaded.rb:195:in
`sync'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/connection_pool/threaded.rb:126:in
`acquire'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/connection_pool/threaded.rb:94:in
`hold'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/database/connecting.rb:236:in
`synchronize'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/adapters/sqlite.rb:141:in
`execute_ddl'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/database/schema_methods.rb:546:in
`create_table_from_generator'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/database/schema_methods.rb:169:in
`create_table'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/sequel-3.42.0/lib/sequel/database/schema_methods.rb:195:in
`create_table?'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/db.rb:44:in
`initialize_database'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/cimi/models.rb:42:in
`<top (required)>'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/cimi/collections/base.rb:16:in
`require_relative'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/cimi/collections/base.rb:16:in
`<top (required)>'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/cimi/collections.rb:17:in
`require_relative'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/cimi/collections.rb:17:in
`<top (required)>'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/cimi/server.rb:24:in
`require_relative'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/cimi/server.rb:24:in
`<top (required)>'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/deltacloud_rack.rb:42:in
`require_relative'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/deltacloud_rack.rb:42:in
`require_frontend!'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/lib/deltacloud_rack.rb:129:in
`require!'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/config.ru:62:in
`block (2 levels) in <main>'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/config.ru:56:in
`each'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/config.ru:56:in
`block in <main>'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/rack-1.5.2/lib/rack/builder.rb:55:in
`instance_eval'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/rack-1.5.2/lib/rack/builder.rb:55:in
`initialize'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/config.ru:1:in
`new'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/config.ru:1:in
`<main>'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/thin-1.5.0/lib/rack/adapter/loader.rb:33:in
`eval'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/thin-1.5.0/lib/rack/adapter/loader.rb:33:in
`load'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/thin-1.5.0/lib/thin/controllers/controller.rb:181:in
`load_rackup_config'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/thin-1.5.0/lib/thin/controllers/controller.rb:71:in
`start'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/thin-1.5.0/lib/thin/runner.rb:187:in
`run_command'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/thin-1.5.0/lib/thin/runner.rb:152:in
`run!'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/gems/deltacloud-core-1.1.1/bin/deltacloudd:248:in
`<top (required)>'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/bin/deltacloudd:19:in `load'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/bin/deltacloudd:19:in `<main>'
            from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/bin/ruby_noexec_wrapper:14:in `eval'
           from /home/ubuntu/.rvm/gems/ruby-1.9.3-p392@dc/bin/ruby_noexec_wrapper:14:in `<main>'

                
> Fresh detacloud install doesnt create database file
> ---------------------------------------------------
>
>                 Key: DTACLOUD-508
>                 URL: https://issues.apache.org/jira/browse/DTACLOUD-508
>             Project: DeltaCloud
>          Issue Type: Bug
>          Components: CIMI/Frontend, Server
>            Reporter: Carlos Goncalves
>
> Fresh install of Deltacloud v1.1.1 via rubygem o a clean gemset and running deltacloudd
with CIMI frontend errors due to non existent database file. No earlier Deltacloud installed
on this machine.
> Deltacloud doesn't create file /var/tmp/deltacloud-$USER/db.sqlite.
> SQLite3::CantOpenException: unable to open database file (Sequel::DatabaseConnectionError)
> Errors like that^ will be probably related to this issue.
> Checking out Deltacloud from Git and running deltacloud-db-upgrade followed by deltacloudd
will do. Still, even with the database file created, can't run v1.1.1.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message