deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Koper, Dies" <di...@fast.au.fujitsu.com>
Subject RE: [PATCH] FGCP: use jruby-openssl >=0.8.7 which has proper pkcs12 support
Date Thu, 21 Mar 2013 23:41:06 GMT
Hi Ronelle,

I can wait.
If you have a working jruby environment, could you run the fgcp unit tests to confirm they
now pass?
Just need to install jruby-openssl 0.8.7 and undo commit e884d128c334f1fc6aee62a615cbd7024d2f4437:

server/Rakefile:
+    #
+    # FIXME: Skip FGCP tests under jRuby as jRuby openssl lacks
+    #        the OpenSSL::PKCS12::PKCS12Error class
+    #
+    next if RUBY_PLATFORM == 'java' and driver == :fgcp
^^^ remove or comment out this line

Regards,
Dies Koper


> -----Original Message-----
> From: Ronelle Landy [mailto:rlandy@redhat.com]
> Sent: Friday, 22 March 2013 1:32 AM
> To: dev@deltacloud.apache.org
> Subject: Re: [PATCH] FGCP: use jruby-openssl >=0.8.7 which has proper
> pkcs12 support
> 
> 
> > From: "Dies Koper" <diesk@fast.au.fujitsu.com>
> > To: dev@deltacloud.apache.org
> > Sent: Wednesday, March 20, 2013 11:35:58 PM
> > Subject: RE: [PATCH] FGCP: use jruby-openssl >=0.8.7 which has proper
> pkcs12 support
> >
> > Hi Ronelle,
> >
> > Thanks, bundle install now worked.
> > Running the tests however failed with:
> >
> > d:\sources\OSS\cloud\deltacloud\server>rake test:drivers:mock
> > Could not find tilt-1.3.6 in any of the sources
> > org/jruby/RubyArray.java:2393:in `map!'
> > D:/sources/OSS/cloud/deltacloud/server/Rakefile:26:in `(root)'
> 
> Hi Dies,
> 
> hmmm .. was afraid you would see that, hence my previous comment "Running
> rake might object to the versions of above gems".
> If you can hang on a bit for the fix, great. If not, can give you some
> other install options (which involve downgrading versions :( ).
> 
> Thanks,
> Ronelle
> 
> >
> > Regards,
> > Dies Koper
> >
> >
> > > -----Original Message-----
> > > From: Ronelle Landy [mailto:rlandy@redhat.com]
> > > Sent: Thursday, 21 March 2013 2:01 PM
> > > To: dev@deltacloud.apache.org
> > > Subject: Re: [PATCH] FGCP: use jruby-openssl >=0.8.7 which has
> > > proper
> > > pkcs12 support
> > >
> > >
> > >
> > > > Hi Michal,
> > > >
> > > > The PKCS12 patch for jruby that I had been contributing to has
> > > > been
> > > > merged and jruby-openssl-0.8.7.gem has been released!
> > > >
> > > > I tried running DC on jruby on my local environment but couldn't
> > > > get
> > > the
> > > > gems installed:
> > > >
> > > > d:\sources\OSS\cloud\deltacloud\server>jruby -S bundle install
> > > > Fetching gem metadata from http://rubygems.org/.......
> > > > Fetching gem metadata from http://rubygems.org/..
> > > > Resolving dependencies...
> > > > Bundler could not find compatible versions for gem "sinatra":
> > > >  In Gemfile:
> > > >    deltacloud-core (>= 0) ruby depends on
> > > >      sinatra (<= 1.3.5) ruby
> > > >
> > > >    deltacloud-core (>= 0) ruby depends on
> > > >      sinatra (1.4.1)
> > > >
> > > Hi Dies,
> > >
> > > The gemfile issue you reported is as a result of a temporary
> > > change.
> > > If you want to use bundler to install dependencies, you can use the
> > > following workaround:
> > >
> > > - edit deltacloud/server/deltacloud-core.gemspec and comment out
> > > the
> > > lines that specify the 'tilt' and 'sinatra' gem versions (easy to
> > > find
> > ...
> > > Look for FixMe comment)
> > >
> > > - run bundle from deltacloud/sever
> > >
> > > - once bundle completes,
> > > gem install tilt -v 1.3.3
> > > gem install sinatra -v 1.3.5
> > > gem uninstall tilt -v 1.3.6 (or version later than 1.3.3)
> > > gem uninstall sinatra -v 1.4.1
> > >
> > > Now you should be able to start Deltacloud. Running rake might
> > > object
> > > to the versions of above gems - not 100% sure that you'll hit an
> > > error
> > > after the steps above.
> > >
> > > > Can you try it out in your environment and confirm the fgcp unit
> > tests
> > > > now pass on jruby?
> > > >
> > > > Regards,
> > > > Dies Koper
> > > >
> > > >
> > > >> -----Original Message-----
> > > >> From: diesk@fast.au.fujitsu.com
> > > >> [mailto:diesk@fast.au.fujitsu.com]
> > > >> Sent: Thursday, 21 March 2013 11:27 AM
> > > >> To: dev@deltacloud.apache.org
> > > >> Subject: [PATCH] FGCP: use jruby-openssl >=0.8.7 which has
> > > >> proper
> > > > pkcs12
> > > >> support
> > > >>
> > > >> From: Dies Koper <diesk@fast.au.fujitsu.com>
> > > >>
> > > >> ---
> > > >> server/Gemfile | 2 +-
> > > >> 1 file changed, 1 insertion(+), 1 deletion(-)
> > > >>
> > > >> diff --git a/server/Gemfile b/server/Gemfile
> > > >> index 7ac1b25..0860db3 100644
> > > >> --- a/server/Gemfile
> > > >> +++ b/server/Gemfile
> > > >> @@ -3,7 +3,7 @@ source "http://rubygems.org"
> > > >> gemspec
> > > >>
> > > >> platforms :jruby do
> > > >> -  gem 'jruby-openssl'
> > > >> +  gem 'jruby-openssl', '> 0.8.6' # has PKCS12 impl that fgcp
> > requires
> > > >>   gem 'puma'
> > > >> end
> > > >>
> > > >> --
> > > >> 1.8.0.msysgit.0
> > > >>
> > > >>
> > > >
> > > >
> >
> >
> >

Mime
View raw message