deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mfoj...@redhat.com
Subject [PATCH core 2/2] Core: Lock sinatra and tilt to versions known to work
Date Tue, 12 Mar 2013 09:54:53 GMT
From: Michal Fojtik <mfojtik@redhat.com>


Signed-off-by: Michal fojtik <mfojtik@redhat.com>
---
 server/Gemfile                 | 2 --
 server/deltacloud-core.gemspec | 9 +++++++--
 2 files changed, 7 insertions(+), 4 deletions(-)

diff --git a/server/Gemfile b/server/Gemfile
index 5f3c98d..7ac1b25 100644
--- a/server/Gemfile
+++ b/server/Gemfile
@@ -2,8 +2,6 @@ source "http://rubygems.org"
 
 gemspec
 
-gem 'tilt', '=1.3.3'
-
 platforms :jruby do
   gem 'jruby-openssl'
   gem 'puma'
diff --git a/server/deltacloud-core.gemspec b/server/deltacloud-core.gemspec
index 4f80dea..ce035c5 100644
--- a/server/deltacloud-core.gemspec
+++ b/server/deltacloud-core.gemspec
@@ -69,7 +69,6 @@ Gem::Specification.new do |s|
   s.has_rdoc = 'false'
   s.add_dependency('rake', '>= 0.8.7')
   s.add_dependency('haml', '>= 2.2.17')
-  s.add_dependency('sinatra', '>= 1.3.0')
   s.add_dependency('sinatra-rabbit', '>= 1.1.6')
   s.add_dependency('rack', '>= 1.0.0')
   s.add_dependency('rack-accept')
@@ -77,9 +76,15 @@ Gem::Specification.new do |s|
   s.add_dependency('net-ssh', '>= 2.0.0')
   s.add_dependency('nokogiri', '>= 1.4.3')
   s.add_dependency('require_relative') if RUBY_VERSION < '1.9'
-
   s.add_dependency('sequel', '<= 3.42.0')
 
+  # FIXME: These dependencies are locked due to bugs that
+  #        we will not address in this release.
+  #
+  s.add_dependency('tilt', '<=1.3.3')
+  s.add_dependency('sinatra', '<=1.3.5')
+
+
   if RUBY_PLATFORM == 'java'
     s.add_dependency('jdbc-sqlite3')
   else
-- 
1.8.1.4


Mime
View raw message