deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ronelle Landy (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DTACLOUD-477) Openstack provider: Realms not correct reported from GET /api/instance/Instance_id
Date Thu, 14 Feb 2013 17:28:13 GMT
Ronelle Landy created DTACLOUD-477:
--------------------------------------

             Summary: Openstack provider: Realms not correct reported from GET /api/instance/Instance_id
                 Key: DTACLOUD-477
                 URL: https://issues.apache.org/jira/browse/DTACLOUD-477
             Project: DeltaCloud
          Issue Type: Bug
          Components: Native/Frontend
         Environment: Deltacloud 1.1.1 - gem under test
Openstack provider
            Reporter: Ronelle Landy


Create an instance passing a realm_id - note that this realm is the same as the one where
the image resides:

>>  curl -X POST -F "image_id=67663" -F "realm_id=az-2.region-a.geo-1" --user "un:pw"
"http://amd-pike-06.lab.bos.redhat.com:3001/api/instances?format=json"

{"instance":{"id":"1099283","href":"http://amd-pike-06.lab.bos.redhat.com:3001/api/instances/1099283","name":"server2013-02-14
12:17:20 -0500","state":"PENDING","owner":"....","image":{"href":"http://amd-pike-06.lab.bos.redhat.com:3001/api/images/67663","id":"67663","rel":"image"},
"realm":{"href":"http://amd-pike-06.lab.bos.redhat.com:3001/api/realms/az-2.region-a.geo-1","id":"az-2.region-a.geo-1","rel":"realm"},"
actions":[],"hardware_profile":{"id":"100","href":"http://amd-pike-06.lab.bos.redhat.com:3001/api/hardware_profiles/100","rel":"hardware_profile","properties":{}},"public_addresses":[],"private_addresses":[],"create_time":"2013-02-14T17:17:28Z","storage_volumes":[],"authentication_type":"key","authentication":{"user":"root","password":"uQiHTRW5ircK5Mzz"}}}

All good above.

Now GET the instance ... not that the realm is reported as:

<realm href='http://amd-pike-06.lab.bos.redhat.com:3001/api/realms/n/a' id='n/a'></realm>

>>  curl -X GET --user "un:pw" "http://amd-pike-06.lab.bos.redhat.com:3001/api/instances/1099283?format=xml"<?xml
version='1.0' encoding='utf-8' ?>
<instance href='http://amd-pike-06.lab.bos.redhat.com:3001/api/instances/1099283' id='1099283'>
  <name>server2013-02-14 12:17:20 -0500</name>
  <owner_id>...</owner_id>
  <image href='http://amd-pike-06.lab.bos.redhat.com:3001/api/images/67663' id='67663'></image>
  <realm href='http://amd-pike-06.lab.bos.redhat.com:3001/api/realms/n/a' id='n/a'></realm>
  <state>RUNNING</state>
  <hardware_profile href='http://amd-pike-06.lab.bos.redhat.com:3001/api/hardware_profiles/100'
id='100'>
  </hardware_profile>
  <actions>
    <link href='http://amd-pike-06.lab.bos.redhat.com:3001/api/instances/1099283/reboot'
method='post' rel='reboot' />
    <link href='http://amd-pike-06.lab.bos.redhat.com:3001/api/instances/1099283/stop'
method='post' rel='stop' />
    <link href='http://amd-pike-06.lab.bos.redhat.com:3001/api/images;instance_id=1099283'
method='post' rel='create_image' />
  </actions>
  <launch_time>2013-02-14T17:17:28Z</launch_time>
  <public_addresses><address type='ipv4'>15.185.178.1</address></public_addresses>
  <private_addresses><address type='ipv4'>10.7.103.19</address></private_addresses>
  <storage_volumes></storage_volumes>
  <authentication type='key'>
    <login>
      <username>root</username>
      <password><![CDATA[]]></password>
    </login>
  </authentication>
</instance>
[root@cloud-qe-3 tests]# 

This fails  deltacloud/test/instances_test.rb.


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message