deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enrique Fernandez Casado (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DTACLOUD-459) run_command always returns 406 when specifying JSON as a response type
Date Fri, 08 Feb 2013 14:09:12 GMT

     [ https://issues.apache.org/jira/browse/DTACLOUD-459?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Enrique Fernandez Casado updated DTACLOUD-459:
----------------------------------------------

    Attachment: 0001-Adds-JSON-as-a-supported-rtype-run_command-DTACLOUD-.patch

I've followed the same structure as in views/instances/run.xml.haml
                
> run_command always returns 406 when specifying JSON as a response type
> ----------------------------------------------------------------------
>
>                 Key: DTACLOUD-459
>                 URL: https://issues.apache.org/jira/browse/DTACLOUD-459
>             Project: DeltaCloud
>          Issue Type: Bug
>          Components: Server
>         Environment: Latest version on GitHub.
>            Reporter: Enrique Fernandez Casado
>         Attachments: 0001-Adds-JSON-as-a-supported-rtype-run_command-DTACLOUD-.patch
>
>
> Deltacloud server always returns 406 error when specifying JSON as response type for
a run_command request (same request works if you set XML as response type). It does not seem
to be prepared for serving JSON responses.
> https://github.com/apache/deltacloud/blob/master/server/lib/deltacloud/collections/instances.rb#L115

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message