deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ronelle Landy (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (DTACLOUD-401) CIMI: "can't find image in given datacenter" - Deltacloud server point at Vsphere provider
Date Wed, 02 Jan 2013 15:08:12 GMT

     [ https://issues.apache.org/jira/browse/DTACLOUD-401?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ronelle Landy closed DTACLOUD-401.
----------------------------------

    Resolution: Fixed

Fixed in Deltacloud commit version 329a2e6a463326d43110e4504e158e05435ea2ae - http://tracker.deltacloud.org/patch/a3f09c18
... 

[rlandy@localhost ~]$ curl -v POST -H "Content-Type: application/xml" -d '<MachineCreate
xmlns="http://schemas.dmtf.org/cimi/1"><name>cimi_machine_is</name><machineTemplate><initialState>STARTED</initialState><machineConfig
href="http://qe-blade-02.idm.lab.bos.redhat.com:3001/cimi/machine_configurations/default"/><machineImage
href="http://qe-blade-02.idm.lab.bos.redhat.com:3001/cimi/machine_images/AutoImageImport-DoNotDelete"/></machineTemplate></MachineCreate>'
 --user 'un:pw' "http://qe-blade-02.idm.lab.bos.redhat.com:3001/cimi/machines?format=xml"
* Could not resolve host: POST; Name or service not known
* Closing connection #0
curl: (6) Could not resolve host: POST; Name or service not known
* About to connect() to qe-blade-02.idm.lab.bos.redhat.com port 3001 (#0)
*   Trying 10.16.76.33... connected
* Connected to qe-blade-02.idm.lab.bos.redhat.com (10.16.76.33) port 3001 (#0)
* Server auth using Basic with user 'Administrator'
> POST /cimi/machines?format=xml HTTP/1.1
> Authorization: Basic QWRtaW5pc3RyYXRvcjpSM2RoYXQh
> User-Agent: curl/7.21.7 (x86_64-redhat-linux-gnu) libcurl/7.21.7 NSS/3.13.1.0 zlib/1.2.5
libidn/1.22 libssh2/1.2.7
> Host: qe-blade-02.idm.lab.bos.redhat.com:3001
> Accept: */*
> Content-Type: application/xml
> Content-Length: 392
> 
< HTTP/1.1 201 Created
< ETag: 0d54cc00aa2289ffb45e72a1e2cd26c3
< Content-Length: 829
< CIMI-Specification-Version: 1.0.1
< Content-Type: application/xml
< Location: http://qe-blade-02.idm.lab.bos.redhat.com:3001/cimi/machines_machine_is
< Date: Wed, 02 Jan 2013 14:47:53 GMT
< Cache-Control: max-age=0, private, must-revalidate
< Connection: keep-alive
< Server: thin 1.5.0 codename Knife
< 
<Machine xmlns="http://schemas.dmtf.org/cimi/1" resourceURI="http://schemas.dmtf.org/cimi/1/Machine">
  <id>http://qe-blade-02.idm.lab.bos.redhat.com:3001/cimi/machines_machine_is</id>
  <name>cimi_machine_is</name>
  <description>No description set for Machine cimi_machine_is</description>
  <created>2013-01-02T09:47:53-05:00</created>
  <property key="credential">http://qe-blade-02.idm.lab.bos.redhat.com:3001/cimi/credentials</property>
  <property key="machine_image">http://qe-blade-02.idm.lab.bos.redhat.com:3001/cimi/machine_images</property>
  <state>CREATING</state>
  <cpu>1</cpu>
  <memory>524288</memory>
  <disks href="http://qe-blade-02.idm.lab.bos.redhat.com:3001/cimi/machines_machine_is/disks"
/>
  <volumes href="http://qe-blade-02.idm.lab.bos.redhat.com:3001/cimi/machines_machine_is/volumes"
/>
</Machine>
* Connection #0 to host qe-blade-02.idm.lab.bos.redhat.com left intact
* Closing connection #0
[rlandy@localhost ~]$ 

                
> CIMI: "can't find image in given datacenter" - Deltacloud server point at Vsphere provider

> -------------------------------------------------------------------------------------------
>
>                 Key: DTACLOUD-401
>                 URL: https://issues.apache.org/jira/browse/DTACLOUD-401
>             Project: DeltaCloud
>          Issue Type: Bug
>          Components: CIMI/Frontend
>         Environment: Deltacloud commit version: 15c1e8b702460b43fc445cbbc13657d9affd2977
> Vsphere 5.x
>            Reporter: Ronelle Landy
>            Assignee: Michal Fojtik
>
> The error below seems legitimate ... ie: that Deltacloud is just reporting the backend
error - except that the image referred to is definitely available in the Vsphere provider.
(It's the default image used most in testing - as is returned by the GET request below:)
> **********
>  curl -X GET --user 'un:pw' http://qe-blade-13.idm.lab.bos.redhat.com:3001/cimi/machine_images?format=xml
>  <id>http://qe-blade-13.idm.lab.bos.redhat.com:3001/cimi/machine_images</id>
>   <count>20</count>
>   <MachineImage>
>     <id>http://qe-blade-13.idm.lab.bos.redhat.com:3001/cimi/machine_images/AutoImageImport-DoNotDelete</id>
>     <name>AutoImageImport-DoNotDelete</name>
>     <description>Other Linux (64-bit)</description>
>     <created>2012-12-13T17:53:40-05:00</created>
>     <state>AVAILABLE</state>
>     <type>IMAGE</type>
>     <imageLocation>vsphere://AutoImageImport-DoNotDelete</imageLocation>
>   </MachineImage>
> **********
> Do I *need* to specify the datastore? (There is only one in this case).
> ERROR -- 500: [Deltacloud::Exceptions::BackendError] ERROR: Could not find the image
in given datacenter
> /home/dcloud/workspace/deltacloud/server/lib/deltacloud/drivers/vsphere/vsphere_driver.rb:218:in
`block in create_instance'
> /home/dcloud/workspace/deltacloud/server/lib/deltacloud/drivers/exceptions.rb:212:in
`call'
> /home/dcloud/workspace/deltacloud/server/lib/deltacloud/drivers/exceptions.rb:212:in
`safely'
> /home/dcloud/workspace/deltacloud/server/lib/deltacloud/drivers/vsphere/vsphere_driver.rb:213:in
`create_instance'
> /home/dcloud/workspace/deltacloud/server/lib/cimi/models/machine.rb:91:in `create_from_xml'
> /home/dcloud/workspace/deltacloud/server/lib/cimi/collections/machines.rb:52:in `block
(3 levels) in <class:Machines>'
> /usr/local/share/gems/gems/sinatra-rabbit-1.1.3/lib/sinatra/rabbit/base.rb:396:in `instance_eval'
> /usr/local/share/gems/gems/sinatra-rabbit-1.1.3/lib/sinatra/rabbit/base.rb:396:in `block
in control'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:1265:in `call'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:1265:in `block in compile!'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:835:in `[]'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:835:in `block (3 levels)
in route!'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:851:in `route_eval'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:835:in `block (2 levels)
in route!'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:872:in `block in process_route'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:870:in `catch'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:870:in `process_route'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:834:in `block in route!'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:833:in `each'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:833:in `route!'
> /usr/local/share/gems/gems/sinatra-1.3.3/lib/sinatra/base.rb:936:in `dispatch!'
> 10.11.11.227 - - [13/Dec/2012 17:48:20] "POST /cimi/machines HTTP/1.1" 500 1930 0.7406
> Any thoughts on what's amiss here?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message