deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Fojtik <mfoj...@redhat.com>
Subject Re: A few CIMI fixes
Date Mon, 03 Dec 2012 14:49:33 GMT
On 12/03, marios@redhat.com wrote:
> ACK & pushed:
> 
> On 03/12/12 09:54, lutter@redhat.com wrote:
> > These patches address a few things I ran across running the CIMI
> > tests. Patch 2/3 makes cep_test avoid accessing the
> > forwarding_group_templates collection, since that makes the server eat up
> > all available memory (very unpleasant) - I am not sure what the actual
> > issue is, but it seems to happen before we get into the control block of
> > the CIMI collection; i.e., I am looking angrily at our middleware and/or
> > rabbit ;)
> 
> Michal is chasing this - it seems to be very specific to F16 1.8.7 ruby

As marios wrote, this issues seems to be *very* F16 ruby (1.8.7-p371)
specific. I'm not able to reproduce it on F18 (rbenv 1.8.7) or OSX (same).

Exceptions seems to be random:

This is the same request (I just hit Ctrl+R in browser):

stack level too deep
/usr/lib/ruby/gems/1.8/gems/dm-core-1.2.0/lib/dm-core/model.rb:696:in
`repository_name'

stack level too deep
/home/mfojtik/deltacloud/server/lib/deltacloud_rack.rb:55:in
`default_frontend'
/home/mfojtik/deltacloud/server/lib/deltacloud/helpers/driver_helper.rb:32:in
`driver_name

stack level too deep
/home/mfojtik/deltacloud/server/lib/deltacloud/helpers/driver_helper.rb:32:in
`driver_name'
/home/mfojtik/deltacloud/server/lib/deltacloud/helpers/driver_helper.rb:28:in
`driver_symbol'

There are couple more, I really dunno how to track this issue. I tried to
disable everything that touch DataMapper but still the same problem.

I tried to use Tracer (it usually reveals infinite loops/recursions), but
no luck either :/

So I desperately installed rbenv on that F16 box and then I installed
ruby 1.8.7 (CONFIGURE_OPTS="--without-dl" - this is broken on new glibc).
The I installed bundler and bootstraped deltacloud.... When I switched
to this version **everything** works!

  -- Michal

> 
> marios
> 
> > 
> > David
> > 
> 

-- 
Michal Fojtik <mfojtik@redhat.com>
Deltacloud API, CloudForms

Mime
View raw message