deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rla...@redhat.com
Subject [PATCH] Site: Add note about require_relative gem install for Deltacloud 1.0.5
Date Tue, 20 Nov 2012 20:01:59 GMT
From: Ronelle Landy <rlandy@redhat.com>

---
 site/content/install-deltacloud.md |    8 ++++++++
 1 files changed, 8 insertions(+), 0 deletions(-)

diff --git a/site/content/install-deltacloud.md b/site/content/install-deltacloud.md
index 1a73afc..88c6cee 100644
--- a/site/content/install-deltacloud.md
+++ b/site/content/install-deltacloud.md
@@ -140,6 +140,14 @@ the Wiki</a>. Note that they require using homebrew.
 
 <p><strong>And thats it!</strong> The gem install command will automatically
fetch and install all other gems that the Deltacloud server needs. As an alternative you can
get the latest releases of Deltacloud from the <a href="http://www.apache.org/dist/deltacloud/">Apache
website</a>.</p>
 
+<p><span class="label">Note:</span> When installing and running Deltacloud
on platforms with Ruby versions 1.8.x, the 'require_relative' gem needs to be installed. This
gem should be automatically installed with the deltacloud-core gem however, if this does not
occur, the follow error will be thrown when starting Deltacloud: </p>
+
+<pre>/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require':
no such file to load -- require_relative (LoadError)</pre>
+
+<p>The fix is to explicitly install the 'require_relative' gem: </p>
+
+<pre>$ sudo gem install require_relative</pre>
+
 <a class="btn btn-inverse btn-large" style="float: right" href="/run-deltacloud-server.html">Run
Deltacloud</a>
 
 <br/>
-- 
1.7.7.6


Mime
View raw message