deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Fojtik ...@mifo.sk>
Subject Re: Deltacloud API development bootstrap
Date Thu, 15 Nov 2012 14:49:56 GMT
On Nov 15, 2012, at 3:41 PM, Justin Clift <jclift@redhat.com> wrote:

Hi Justin,

First thanks for trying this out. I think the rbenv issue is because the PATH
variable is not being set correctly. I pushed a fix to workaround it, if somebody
has better idea how to solve it please feel free to do a pull request or drop reply
to this email :-)

The 'puts' there is a typo (my brain is damaged by Ruby ;-). Fixed now.

I haven't tried this yet on OSX, because I don't have access to Mac right now.
If someone want to fix it I happy with that, otherwise you will need to wait until
my Air return from repairs :-)

  -- Michal


> On 15/11/2012, at 3:31 PM, Justin Clift wrote:
>> On 11/11/2012, at 12:45 PM, Michal fojtik wrote:
>>> Hi guys,
>>> 
>>> I put together small bash script to bootstrap development environment for developing
Deltacloud API.
>>> 
>>> Currently this script supports: Fedora, CentOS, RHEL6, openSuse, Debian and Ubuntu.
>>> 
>>> To run the script you can do:
>>> 
>>> curl https://raw.github.com/mifo/deltacloud-dev-tools/master/bootstrap.sh | bash
>>> 
>>> Following things will be installed:
>>> 
>>> * rbenv
>>> * ruby 1.9
>>> * all system dependencies (gcc, libxml, libxslt, etc...)
>>> * deltacloud
>>> 
>>> This script is not perfect yet, I want to add support for OSX for example and
improve dependency checking for other distros, so if someone have time to check if this script
works on his distro, all issues or pull requests are welcome :-)
>> 
>> Just tried it on a "minimal" CentOS 6.3 x64 install.
>> 
>> It doesn't seem to be installing rbenv:
>> 
>> * Installing rbenv
>> bash: line 118: rbenv: command not found
>> bash: line 119: puts: command not found
>> bash: line 120: rbenv: command not found
>> bash: line 121: rbenv: command not found
>> bash: line 122: gem: command not found
>> * Downloading Deltacloud API source code into /root/code/core
>> bash: line 135: git: command not found
>> * Installing Deltacloud dependencies
>> bash: line 139: cd: /root/code/core/server: No such file or directory
>> bash: line 140: rbenv: command not found
>> bash: line 141: bundle: command not found
>> * Complete! Happy hacking!
>> 
>> There's no "rbenv" anywhere on the system after
>> this, and there doesn't seem to be a log file
>> to indicate what went wrong. (?)
> 
> 
> Similar problem on OSX 10.7.5 too:
> 
>  root# curl https://raw.github.com/mifo/deltacloud-dev-tools/master/bootstrap.sh | bash
>    % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
>                                   Dload  Upload   Total   Spent    Left  Speed
>  100  5484  100  5484    0     0   5401      0  0:00:01  0:00:01 --:--:-- 10327
>  * Bootstraping Deltacloud API environment for development...
> 
>  * Checking runtime dependencies...
>  * Installing rbenv
>  bash: line 118: rbenv: command not found
>  bash: line 119: puts: command not found
>  bash: line 120: rbenv: command not found
>  bash: line 121: rbenv: command not found
>  Successfully installed bundler-1.2.2
>  1 gem installed
>  Installing ri documentation for bundler-1.2.2...
>  Installing RDoc documentation for bundler-1.2.2...
>  * Downloading Deltacloud API source code into /var/root/code/core
>  bash: line 135: git: command not found
>  * Installing Deltacloud dependencies
>  bash: line 139: cd: /var/root/code/core/server: No such file or directory
>  bash: line 140: rbenv: command not found
>  Could not locate Gemfile
>  * Complete! Happy hacking!
> 
>  root#
> 
> Hopefully that helps. :)
> 
> + Justin
> 
> --
> Aeolus Cloud Evangelist
> http://www.aeolusproject.org
> 


Mime
View raw message