deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Koper, Dies" <di...@fast.au.fujitsu.com>
Subject RE: fgcp not accessible anymore on /api
Date Mon, 08 Oct 2012 07:27:01 GMT
Thanks!

Regards,
Dies Koper


> -----Original Message-----
> From: marios@redhat.com [mailto:mandreou@redhat.com]
> Sent: Monday, 8 October 2012 6:20 PM
> To: dev@deltacloud.apache.org
> Cc: Koper, Dies
> Subject: Re: fgcp not accessible anymore on /api
> 
> Hi Dies:
> 
> On 08/10/12 03:55, Koper, Dies wrote:
> > With the DC frontend using fgcp, the server is giving me error
messages
> > on http://localhost:3001/api. If I go to the operations directly,
like
> > http://localhost:3001/api/instances, they work fine.
> >
> 
> yes, sorry about that. It's due to a change in the way the 'supported
> collections' for each driver are now determined (explanation below if
> you are interested) **. I just pushed the fix for that now in commit
> f8542cf493e82a579dc75c810c1a7220d2926456.
> 
> marios
> 
> 
> ** How supported collections are determined: basically, if a driver
> defines the 'def buckets' method, then the buckets collection is
> exposed. You can override this behaviour when necessary, like for
> Openstack for example where you may/not want to expose the 'buckets'
> collection depending on whether the provider has deployed swift or
not.
> The 'supported_collections' method is moved to the base driver now so
it
> can be overridden if/when needed and takes a credentials parameter
> (hence the error 'wrong number of arguments 1 for 0).
> 
> The fix was therefore to remove the supported_collections method from
> fgcp driver as it isn't necessary/used unless you need to explicitly
> override the supported collections, beyond those for which you have
> defined methods (like 'def instances', def images etc etc).
> 
> >>> Listening on localhost:3001, CTRL+C to stop
> > E, [2012-10-06T22:25:11.315047 #6272] ERROR -- : [500]
> > ArgumentError:wrong number of arguments (1 for 0)
> >
> >
d:/sources/OSS/cloud/deltacloud/server/lib/deltacloud/server.rb:52:in
> > `supported_collections'
> >
d:/sources/OSS/cloud/deltacloud/server/lib/deltacloud/server.rb:52:in
> > `GET /'
> >
D:/programs/Ruby187/lib/ruby/gems/1.8/gems/sinatra-1.3.3/lib/sinatra/bas
> > e.rb:1264:in `call'
> >
> > There was some talk on the mailing list about making changes to
/api.
> > Did you break something?
> >
> > Regards,
> > Dies Koper
> >
> 



Mime
View raw message