deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Fojtik <mfoj...@redhat.com>
Subject Re: Initial support for CIMI minitest (rev 2)
Date Wed, 01 Aug 2012 12:55:10 GMT
Hi,

Seems like a missing 'require "rubygems"' for me.

Do you want me to add this into all files or we are good with:

export RUBYOPT="rubygems" ?

 -- Michal

Michal Fojtik
http://deltacloud.org
mfojtik@redhat.com



On Aug 1, 2012, at 12:35 AM, David Lutterkort <lutter@redhat.com> wrote:

> On Tue, 2012-07-31 at 14:33 +0200, mfojtik@redhat.com wrote:
>> This patch will add support for CIMI collection testing.
> 
> More ruby 1.8 pain:
> 
>> ruby tests/cimi/spec/cimi/model/machine_spec.rb
>         tests/cimi/spec/cimi/model/machine_spec.rb:17:in `require': no such file to load
-- minitest/autorun (LoadError)
>                from tests/cimi/spec/cimi/model/machine_spec.rb:17
> 
> and
> 
>> ruby -rubygems tests/cimi/spec/cimi/model/machine_spec.rb 
>        tests/cimi/spec/cimi/model/machine_spec.rb:17: undefined method `require_relative'
for main:Object (NoMethodError)
> 
> and
> 
>> bundle eexec ruby tests/cimi/spec/cimi/model/machine_spec.rb
>         tests/cimi/spec/cimi/model/machine_spec.rb:17: undefined method `require_relative'
for main:Object (NoMethodError)
> 
> as well as
> 
>> rake test:cimi:models
>        ./tests/cimi/spec/spec_helper.rb:17:in `require': no such file to load -- minitest/autorun
(LoadError)
>                from ./tests/cimi/spec/spec_helper.rb:17
>        rake aborted!
>        Command failed with status (1): [/usr/bin/ruby -I"lib" -r./tests/cimi/spec/...]
> 
>        Tasks: TOP => test:cimi:models
>        (See full trace by running task with --trace)
> 
> But the code looks great ;)
> 
> David
> 
> 


Mime
View raw message