deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ronelle Landy <rla...@redhat.com>
Subject Re: [PATCH core] Core: Make 'require_relative' required only for MRI 1.8
Date Tue, 14 Aug 2012 13:31:59 GMT
QE ACK on this one

> From: mfojtik@redhat.com
> To: dev@deltacloud.apache.org
> Sent: Monday, August 13, 2012 1:03:07 PM
> Subject: [PATCH core] Core: Make 'require_relative' required only for MRI 1.8
> 
> From: Michal Fojtik <mfojtik@redhat.com>
> 
> * Because 1.9 is already shipped with 'require_relative' method
>   we don't need to require this gem.
> 
> Signed-off-by: Michal fojtik <mfojtik@redhat.com>
> ---
>  server/deltacloud-core.gemspec
>                                        |    2 +-
>  server/lib/cimi/models.rb
>                                             |    2 +-
>  server/lib/deltacloud/api.rb
>                                          |    2 +-
>  server/lib/deltacloud/core_ext.rb
>                                     |    2 +-
>  server/lib/deltacloud_rack.rb
>                                         |    2 +-
>  server/tests/cimi/collections/cloud_entry_point_test.rb
>               |    2 +-
>  server/tests/cimi/collections/machine_images_test.rb
>                  |    2 +-
>  server/tests/cimi/collections/machines_test.rb
>                        |    2 +-
>  server/tests/cimi/spec/cimi/model/machine_admin_spec.rb
>               |    2 +-
>  server/tests/cimi/spec/cimi/model/machine_configuration_spec.rb
>       |    2 +-
>  server/tests/cimi/spec/cimi/model/machine_image_spec.rb
>               |    2 +-
>  server/tests/cimi/spec/cimi/model/machine_spec.rb
>                     |    2 +-
>  server/tests/cimi/spec/cimi/model/machine_template_spec.rb
>            |    2 +-
>  server/tests/cimi/spec/cimi/model/schema_spec.rb
>                      |    2 +-
>  server/tests/cimi/spec/cimi/model/volume_configuration_spec.rb
>        |    2 +-
>  server/tests/cimi/spec/cimi/model/volume_image_spec.rb
>                |    2 +-
>  server/tests/cimi/spec/cimi/model/volume_spec.rb
>                      |    2 +-
>  server/tests/cimi/spec/cimi/model/volume_template_spec.rb
>             |    2 +-
>  server/tests/cimi/spec/spec_helper.rb
>                                 |    2 +-
>  server/tests/deltacloud/base_collection_test.rb
>                       |    2 +-
>  server/tests/deltacloud/collections/buckets_collection_test.rb
>        |    2 +-
>  server/tests/deltacloud/collections/drivers_collection_test.rb
>        |    2 +-
>  .../deltacloud/collections/hardware_profiles_collection_test.rb
>       |    2 +-
>  server/tests/deltacloud/collections/images_collection_test.rb
>         |    2 +-
>  .../tests/deltacloud/collections/instance_states_collection_test.rb
>   |    2 +-
>  server/tests/deltacloud/collections/instances_collection_test.rb
>      |    2 +-
>  server/tests/deltacloud/collections/keys_collection_test.rb
>           |    2 +-
>  server/tests/deltacloud/collections_test.rb
>                           |    2 +-
>  server/tests/deltacloud/deltacloud_helper_test.rb
>                     |    2 +-
>  server/tests/deltacloud/drivers_test.rb
>                               |    2 +-
>  server/tests/deltacloud/rack_test.rb
>                                  |    2 +-
>  server/tests/deltacloud/server_test.rb
>                                |    2 +-
>  server/tests/ec2/common.rb
>                                            |    2 +-
>  server/tests/ec2/query_parser_test.rb
>                                 |    2 +-
>  server/tests/ec2/server_test.rb
>                                       |    2 +-
>  server/tests/helpers/core_ext/array_test.rb
>                           |    2 +-
>  server/tests/helpers/core_ext/hash_test.rb
>                            |    2 +-
>  server/tests/helpers/core_ext/integer_test.rb
>                         |    2 +-
>  server/tests/helpers/core_ext/string_test.rb
>                          |    2 +-
>  server/tests/test_helper.rb
>                                           |    2 +-
>  40 files changed, 40 insertions(+), 40 deletions(-)
> 
> diff --git a/server/deltacloud-core.gemspec
> b/server/deltacloud-core.gemspec
> index a225d18..71f7998 100644
> --- a/server/deltacloud-core.gemspec
> +++ b/server/deltacloud-core.gemspec
> @@ -77,7 +77,7 @@ Gem::Specification.new do |s|
>    s.add_dependency('net-ssh', '>= 2.0.0')
>    s.add_dependency('thin', '>= 1.2.5') unless RUBY_PLATFORM ==
>    'java'
>    s.add_dependency('nokogiri', '>= 1.4.3')
> -  s.add_dependency('require_relative')
> +  s.add_dependency('require_relative') if RUBY_VERSION < '1.9'
>  
>  # dependencies for various cloud providers:
>  # RHEV-M
> diff --git a/server/lib/cimi/models.rb b/server/lib/cimi/models.rb
> index d88d4b8..2eaf345 100644
> --- a/server/lib/cimi/models.rb
> +++ b/server/lib/cimi/models.rb
> @@ -17,7 +17,7 @@ module CIMI
>    module Model; end
>  end
>  
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative './models/schema'
>  require_relative './models/base'
> diff --git a/server/lib/deltacloud/api.rb
> b/server/lib/deltacloud/api.rb
> index ed3d4e4..21a720f 100644
> --- a/server/lib/deltacloud/api.rb
> +++ b/server/lib/deltacloud/api.rb
> @@ -16,7 +16,7 @@
>  require 'rubygems'
>  require 'ostruct'
>  
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative 'core_ext'
>  require_relative 'models'
> diff --git a/server/lib/deltacloud/core_ext.rb
> b/server/lib/deltacloud/core_ext.rb
> index 7db0c16..76359f1 100644
> --- a/server/lib/deltacloud/core_ext.rb
> +++ b/server/lib/deltacloud/core_ext.rb
> @@ -14,7 +14,7 @@
>  # under the License.
>  #
>  
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative './core_ext/array'
>  require_relative './core_ext/hash'
> diff --git a/server/lib/deltacloud_rack.rb
> b/server/lib/deltacloud_rack.rb
> index 54474c3..7b01524 100644
> --- a/server/lib/deltacloud_rack.rb
> +++ b/server/lib/deltacloud_rack.rb
> @@ -13,7 +13,7 @@
>  # License for the specific language governing permissions and
>  limitations
>  # under the License.
>  
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative './deltacloud/core_ext'
>  require_relative './sinatra/rack_logger'
> diff --git a/server/tests/cimi/collections/cloud_entry_point_test.rb
> b/server/tests/cimi/collections/cloud_entry_point_test.rb
> index 95b09c1..3f60d0d 100644
> --- a/server/tests/cimi/collections/cloud_entry_point_test.rb
> +++ b/server/tests/cimi/collections/cloud_entry_point_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require 'minitest/autorun'
>  require_relative './common.rb'
> diff --git a/server/tests/cimi/collections/machine_images_test.rb
> b/server/tests/cimi/collections/machine_images_test.rb
> index c5367a3..38fa0c4 100644
> --- a/server/tests/cimi/collections/machine_images_test.rb
> +++ b/server/tests/cimi/collections/machine_images_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  require 'minitest/autorun'
>  require_relative './common.rb'
>  
> diff --git a/server/tests/cimi/collections/machines_test.rb
> b/server/tests/cimi/collections/machines_test.rb
> index 328b712..77b319f 100644
> --- a/server/tests/cimi/collections/machines_test.rb
> +++ b/server/tests/cimi/collections/machines_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  require 'minitest/autorun'
>  require_relative './common.rb'
>  
> diff --git a/server/tests/cimi/spec/cimi/model/machine_admin_spec.rb
> b/server/tests/cimi/spec/cimi/model/machine_admin_spec.rb
> index 3fc272c..e2a5d5c 100644
> --- a/server/tests/cimi/spec/cimi/model/machine_admin_spec.rb
> +++ b/server/tests/cimi/spec/cimi/model/machine_admin_spec.rb
> @@ -15,7 +15,7 @@
>  #
>  
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  if require 'minitest/autorun'
>    require_relative '../../spec_helper.rb'
> diff --git
> a/server/tests/cimi/spec/cimi/model/machine_configuration_spec.rb
> b/server/tests/cimi/spec/cimi/model/machine_configuration_spec.rb
> index f990871..f6011e9 100644
> --- a/server/tests/cimi/spec/cimi/model/machine_configuration_spec.rb
> +++ b/server/tests/cimi/spec/cimi/model/machine_configuration_spec.rb
> @@ -14,7 +14,7 @@
>  # under the License.
>  #
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  require_relative '../../spec_helper.rb' if require
>  'minitest/autorun'
>  
>  describe "MachineConfiguration model" do
> diff --git a/server/tests/cimi/spec/cimi/model/machine_image_spec.rb
> b/server/tests/cimi/spec/cimi/model/machine_image_spec.rb
> index dd5ddbe..204f27f 100644
> --- a/server/tests/cimi/spec/cimi/model/machine_image_spec.rb
> +++ b/server/tests/cimi/spec/cimi/model/machine_image_spec.rb
> @@ -14,7 +14,7 @@
>  # under the License.
>  #
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../spec_helper.rb' if require
>  'minitest/autorun'
>  
> diff --git a/server/tests/cimi/spec/cimi/model/machine_spec.rb
> b/server/tests/cimi/spec/cimi/model/machine_spec.rb
> index ad9f11e..d2001e2 100644
> --- a/server/tests/cimi/spec/cimi/model/machine_spec.rb
> +++ b/server/tests/cimi/spec/cimi/model/machine_spec.rb
> @@ -14,7 +14,7 @@
>  # under the License.
>  #
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../spec_helper.rb' if require
>  'minitest/autorun'
>  
> diff --git
> a/server/tests/cimi/spec/cimi/model/machine_template_spec.rb
> b/server/tests/cimi/spec/cimi/model/machine_template_spec.rb
> index 97bdce9..cc2aef6 100644
> --- a/server/tests/cimi/spec/cimi/model/machine_template_spec.rb
> +++ b/server/tests/cimi/spec/cimi/model/machine_template_spec.rb
> @@ -14,7 +14,7 @@
>  # under the License.
>  #
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../spec_helper.rb' if require
>  'minitest/autorun'
>  
> diff --git a/server/tests/cimi/spec/cimi/model/schema_spec.rb
> b/server/tests/cimi/spec/cimi/model/schema_spec.rb
> index 8b6de48..0a9dd9c 100644
> --- a/server/tests/cimi/spec/cimi/model/schema_spec.rb
> +++ b/server/tests/cimi/spec/cimi/model/schema_spec.rb
> @@ -14,7 +14,7 @@
>  # under the License.
>  #
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../spec_helper.rb' if require
>  'minitest/autorun'
>  
> diff --git
> a/server/tests/cimi/spec/cimi/model/volume_configuration_spec.rb
> b/server/tests/cimi/spec/cimi/model/volume_configuration_spec.rb
> index 0f26edc..1bbdfe9 100644
> --- a/server/tests/cimi/spec/cimi/model/volume_configuration_spec.rb
> +++ b/server/tests/cimi/spec/cimi/model/volume_configuration_spec.rb
> @@ -15,7 +15,7 @@
>  # under the License.
>  #
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../spec_helper.rb' if require
>  'minitest/autorun'
>  
> diff --git a/server/tests/cimi/spec/cimi/model/volume_image_spec.rb
> b/server/tests/cimi/spec/cimi/model/volume_image_spec.rb
> index 10509da..197b2db 100644
> --- a/server/tests/cimi/spec/cimi/model/volume_image_spec.rb
> +++ b/server/tests/cimi/spec/cimi/model/volume_image_spec.rb
> @@ -14,7 +14,7 @@
>  # under the License.
>  #
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../spec_helper.rb' if require
>  'minitest/autorun'
>  
> diff --git a/server/tests/cimi/spec/cimi/model/volume_spec.rb
> b/server/tests/cimi/spec/cimi/model/volume_spec.rb
> index c3bad88..7e6449a 100644
> --- a/server/tests/cimi/spec/cimi/model/volume_spec.rb
> +++ b/server/tests/cimi/spec/cimi/model/volume_spec.rb
> @@ -14,7 +14,7 @@
>  # under the License.
>  #
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../spec_helper.rb' if require
>  'minitest/autorun'
>  
> diff --git
> a/server/tests/cimi/spec/cimi/model/volume_template_spec.rb
> b/server/tests/cimi/spec/cimi/model/volume_template_spec.rb
> index 4bf969c..bfddcd4 100644
> --- a/server/tests/cimi/spec/cimi/model/volume_template_spec.rb
> +++ b/server/tests/cimi/spec/cimi/model/volume_template_spec.rb
> @@ -14,7 +14,7 @@
>  # under the License.
>  #
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../spec_helper.rb' if require
>  'minitest/autorun'
>  
> diff --git a/server/tests/cimi/spec/spec_helper.rb
> b/server/tests/cimi/spec/spec_helper.rb
> index 3e23fc0..aeffc28 100644
> --- a/server/tests/cimi/spec/spec_helper.rb
> +++ b/server/tests/cimi/spec/spec_helper.rb
> @@ -18,7 +18,7 @@ require 'rubygems'
>  require 'minitest/autorun'
>  require 'minitest/spec'
>  require 'xmlsimple'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../../lib/deltacloud/core_ext.rb'
>  require_relative '../../../lib/cimi/models.rb'
> diff --git a/server/tests/deltacloud/base_collection_test.rb
> b/server/tests/deltacloud/base_collection_test.rb
> index 4978f16..65e2363 100644
> --- a/server/tests/deltacloud/base_collection_test.rb
> +++ b/server/tests/deltacloud/base_collection_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative 'common.rb'
>  
> diff --git
> a/server/tests/deltacloud/collections/buckets_collection_test.rb
> b/server/tests/deltacloud/collections/buckets_collection_test.rb
> index d1c40af..d33b412 100644
> --- a/server/tests/deltacloud/collections/buckets_collection_test.rb
> +++ b/server/tests/deltacloud/collections/buckets_collection_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative File.join('..', 'common.rb')
>  
> diff --git
> a/server/tests/deltacloud/collections/drivers_collection_test.rb
> b/server/tests/deltacloud/collections/drivers_collection_test.rb
> index 922248b..296eba8 100644
> --- a/server/tests/deltacloud/collections/drivers_collection_test.rb
> +++ b/server/tests/deltacloud/collections/drivers_collection_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative File.join('..', 'common.rb')
>  
> diff --git
> a/server/tests/deltacloud/collections/hardware_profiles_collection_test.rb
> b/server/tests/deltacloud/collections/hardware_profiles_collection_test.rb
> index b307bdd..2f6cf59 100644
> ---
> a/server/tests/deltacloud/collections/hardware_profiles_collection_test.rb
> +++
> b/server/tests/deltacloud/collections/hardware_profiles_collection_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative File.join('..', 'common.rb')
>  
> diff --git
> a/server/tests/deltacloud/collections/images_collection_test.rb
> b/server/tests/deltacloud/collections/images_collection_test.rb
> index cff0d33..ad4f4c0 100644
> --- a/server/tests/deltacloud/collections/images_collection_test.rb
> +++ b/server/tests/deltacloud/collections/images_collection_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative File.join('..', 'common.rb')
>  
> diff --git
> a/server/tests/deltacloud/collections/instance_states_collection_test.rb
> b/server/tests/deltacloud/collections/instance_states_collection_test.rb
> index dd8a507..768a19f 100644
> ---
> a/server/tests/deltacloud/collections/instance_states_collection_test.rb
> +++
> b/server/tests/deltacloud/collections/instance_states_collection_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative File.join('..', 'common.rb')
>  
> diff --git
> a/server/tests/deltacloud/collections/instances_collection_test.rb
> b/server/tests/deltacloud/collections/instances_collection_test.rb
> index bc2c880..668af4d 100644
> ---
> a/server/tests/deltacloud/collections/instances_collection_test.rb
> +++
> b/server/tests/deltacloud/collections/instances_collection_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative File.join('..', 'common.rb')
>  
> diff --git
> a/server/tests/deltacloud/collections/keys_collection_test.rb
> b/server/tests/deltacloud/collections/keys_collection_test.rb
> index 10371d3..29b9653 100644
> --- a/server/tests/deltacloud/collections/keys_collection_test.rb
> +++ b/server/tests/deltacloud/collections/keys_collection_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative File.join('..', 'common.rb')
>  
> diff --git a/server/tests/deltacloud/collections_test.rb
> b/server/tests/deltacloud/collections_test.rb
> index ec05682..d3e41e9 100644
> --- a/server/tests/deltacloud/collections_test.rb
> +++ b/server/tests/deltacloud/collections_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative 'common.rb'
>  
> diff --git a/server/tests/deltacloud/deltacloud_helper_test.rb
> b/server/tests/deltacloud/deltacloud_helper_test.rb
> index a01bb7b..b7de3e6 100644
> --- a/server/tests/deltacloud/deltacloud_helper_test.rb
> +++ b/server/tests/deltacloud/deltacloud_helper_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative 'common.rb'
>  
> diff --git a/server/tests/deltacloud/drivers_test.rb
> b/server/tests/deltacloud/drivers_test.rb
> index 3143563..8142fe1 100644
> --- a/server/tests/deltacloud/drivers_test.rb
> +++ b/server/tests/deltacloud/drivers_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative 'common.rb'
>  
> diff --git a/server/tests/deltacloud/rack_test.rb
> b/server/tests/deltacloud/rack_test.rb
> index b5b1c77..e8c11b3 100644
> --- a/server/tests/deltacloud/rack_test.rb
> +++ b/server/tests/deltacloud/rack_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative 'common.rb'
>  
> diff --git a/server/tests/deltacloud/server_test.rb
> b/server/tests/deltacloud/server_test.rb
> index 9789ccb..4a18a37 100644
> --- a/server/tests/deltacloud/server_test.rb
> +++ b/server/tests/deltacloud/server_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative 'common.rb'
>  
> diff --git a/server/tests/ec2/common.rb b/server/tests/ec2/common.rb
> index 3527523..fabe5b7 100644
> --- a/server/tests/ec2/common.rb
> +++ b/server/tests/ec2/common.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  require 'minitest/autorun'
>  
>  require_relative File.join('..', '..', 'lib', 'deltacloud_rack.rb')
> diff --git a/server/tests/ec2/query_parser_test.rb
> b/server/tests/ec2/query_parser_test.rb
> index 81db3f6..e34e1f9 100644
> --- a/server/tests/ec2/query_parser_test.rb
> +++ b/server/tests/ec2/query_parser_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  require_relative './common.rb'
>  
>  require_relative File.join('..', '..', 'lib', 'deltacloud',
>  'api.rb')
> diff --git a/server/tests/ec2/server_test.rb
> b/server/tests/ec2/server_test.rb
> index e851e6b..feca68e 100644
> --- a/server/tests/ec2/server_test.rb
> +++ b/server/tests/ec2/server_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative './common.rb'
>  
> diff --git a/server/tests/helpers/core_ext/array_test.rb
> b/server/tests/helpers/core_ext/array_test.rb
> index 6f75e2a..71d07da 100644
> --- a/server/tests/helpers/core_ext/array_test.rb
> +++ b/server/tests/helpers/core_ext/array_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  require_relative '../../test_helper.rb'
>  
>  require_relative File.join('..', '..', '..', 'lib', 'deltacloud',
>  'core_ext.rb')
> diff --git a/server/tests/helpers/core_ext/hash_test.rb
> b/server/tests/helpers/core_ext/hash_test.rb
> index 9793e45..dcee42c 100644
> --- a/server/tests/helpers/core_ext/hash_test.rb
> +++ b/server/tests/helpers/core_ext/hash_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../test_helper.rb'
>  require_relative File.join('..', '..', '..', 'lib', 'deltacloud',
>  'core_ext.rb')
> diff --git a/server/tests/helpers/core_ext/integer_test.rb
> b/server/tests/helpers/core_ext/integer_test.rb
> index 2882db1..9f7a9a9 100644
> --- a/server/tests/helpers/core_ext/integer_test.rb
> +++ b/server/tests/helpers/core_ext/integer_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../test_helper.rb'
>  require_relative File.join('..', '..', '..', 'lib', 'deltacloud',
>  'core_ext.rb')
> diff --git a/server/tests/helpers/core_ext/string_test.rb
> b/server/tests/helpers/core_ext/string_test.rb
> index 6481d70..c25a1f3 100644
> --- a/server/tests/helpers/core_ext/string_test.rb
> +++ b/server/tests/helpers/core_ext/string_test.rb
> @@ -1,5 +1,5 @@
>  require 'rubygems'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  require_relative '../../test_helper.rb'
>  require_relative File.join('..', '..', '..', 'lib', 'deltacloud',
>  'core_ext.rb')
> diff --git a/server/tests/test_helper.rb
> b/server/tests/test_helper.rb
> index e7a7dea..41d8758 100644
> --- a/server/tests/test_helper.rb
> +++ b/server/tests/test_helper.rb
> @@ -4,7 +4,7 @@ require 'minitest/autorun'
>  require 'rack/test'
>  require 'nokogiri'
>  require 'pp'
> -require 'require_relative'
> +require 'require_relative' if RUBY_VERSION < '1.9'
>  
>  ENV['RACK_ENV'] = 'test'
>  
> --
> 1.7.10.2
> 
> 

Mime
View raw message