deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michal Fojtik (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DTACLOUD-291) LoadError when running rake with bundler on Fedora 17
Date Thu, 02 Aug 2012 12:02:02 GMT

    [ https://issues.apache.org/jira/browse/DTACLOUD-291?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13427256#comment-13427256
] 

Michal Fojtik commented on DTACLOUD-291:
----------------------------------------

Btw. just to track down this issue, I got similar problem with OpenShift:

remote: ~/git/deltacloud.git ~/git/deltacloud.git
remote: ~/git/deltacloud.git
remote: Running .openshift/action_hooks/pre_build
remote: Bundling RubyGems based on Gemfile/Gemfile.lock to repo/vendor/bundle with 'bundle
install --deployment'
remote: There was a LoadError while evaluating deltacloud-core.gemspec:
remote:   no such file to load -- rake from
remote:   /var/lib/stickshift/a852134dca944ed0855e517752cb769a/app-root/runtime/repo/deltacloud-core.gemspec:17
remote: Precompiling with 'bundle exec rake assets:precompile'
remote: There was a LoadError while evaluating deltacloud-core.gemspec:
remote:   no such file to load -- rake from
remote:   /var/lib/stickshift/a852134dca944ed0855e517752cb769a/app-root/runtime/repo/deltacloud-core.gemspec:17

After removing require "rake" from gemspec:

remote: ~/git/deltacloud.git ~/git/deltacloud.git
remote: ~/git/deltacloud.git
remote: Running .openshift/action_hooks/pre_build
remote: Restoring previously bundled RubyGems (note: you can commit .openshift/markers/force_clean_build
at the root of your repo to force a clean bundle)
remote: Bundling RubyGems based on Gemfile/Gemfile.lock to repo/vendor/bundle with 'bundle
install --deployment'
remote: /var/lib/stickshift/a852134dca944ed0855e517752cb769a/app-root/runtime/repo/deltacloud-core.gemspec:33:
uninitialized constant FileList (NameError)
remote: 	from /usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb:425:in `initialize'
remote: 	from /var/lib/stickshift/a852134dca944ed0855e517752cb769a/app-root/runtime/repo/deltacloud-core.gemspec:17:in
`new'
remote: 	from /var/lib/stickshift/a852134dca944ed0855e517752cb769a/app-root/runtime/repo/deltacloud-core.gemspec:17


(PS: slowly starting to hate bundler ;-)
                
> LoadError when running rake with bundler on Fedora 17
> -----------------------------------------------------
>
>                 Key: DTACLOUD-291
>                 URL: https://issues.apache.org/jira/browse/DTACLOUD-291
>             Project: DeltaCloud
>          Issue Type: Bug
>          Components: Native/Frontend
>         Environment: deltacloud commit version: 1ed49681482d64fb1578fc6ab6989e32d7cc8cc2
> Fedora 17
> ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]
>            Reporter: Ronelle Landy
>            Assignee: David Lutterkort
>
> On Fedora 17, running any rake task with 'bundle' included in the Rakefile causes a LoadError
as shown below ...
>     [root@nec-em6 server]# rake mock:features:reset
>     rake aborted!
>     There was a LoadError while evaluating deltacloud-core.gemspec:
>       cannot load such file -- rake from
>       /home/dcloud/workspace/deltacloud/server/deltacloud-core.gemspec:17:in `<main>'
>      
>     Does it try to require a relative path? That doesn't work in Ruby 1.9. 
> Commenting out the following in the Rakefile fixes the problem:
>     begin
>     require "bundler"
>     Bundler.setup
>     rescue LoadError
>     $stderr.puts "Please install bundler with 'gem install bundler'"
>     exit(1)
>     end

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message