deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francesco Vollero <razor...@gmail.com>
Subject Re: [jira] [Updated] (DTACLOUD-241) floppyinject silently fails on RHEVM
Date Tue, 19 Jun 2012 10:19:07 GMT
Did you try to run first : mount floppy ?
Because if the data arrived to oVirt shouldn't be a deltacloud problem.

Cheers,
Francesco Vollero


Il giorno 19/giu/2012, alle ore 09:53, "Jan Provaznik (JIRA)" <jira@apache.org> ha scritto:

> 
>     [ https://issues.apache.org/jira/browse/DTACLOUD-241?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
> 
> Jan Provaznik updated DTACLOUD-241:
> -----------------------------------
> 
>    Description: 
> When sending this dc-api request:
> Processing /api/instances (for 127.0.0.1 at Tue Jun 19 02:56:35 -0400 2012) [POST] [RHEVM]
> Parameters: {"image_id"=>"66a522d5-eb4e-4402-9f8f-d56da46f1337", "name"=>"jprovazn1-RHELRHEVMInstance",
"realm_id"=>"a9347fb8-5976-11e1-a53e-5254005809b7", "hwp_memory"=>"512", "keyname"=>"",
"hwp_id"=>"SERVER", "hwp_cpu"=>"1", "hwp_storage"=>"6", "user_data"=>"TVh4b2RIUndjem92TDJSbFlXUmtiMjVyWlhrdWRYTmxjbk41Y3k1eVpXUm9Z\nWFF1WTI5dGZHVTRNRFEyTUdVMExXSTVaR0l0TVRGbE1TMDRZV0ZpTFdVNE16\na3pOV015TVdZeVkzeE5XazVVY1VaSGIwWkxkVkJNVW5SdlQwaFlRVU56Y0U1\naFVrNDNTa3hET0hkME0wZGtNSFJHZGpCT2QzWjROMnM9\n"}
> Provider: https://10.16.120.230:8443/api;9754dc7f-489e-49dd-99d0-2c2ea7657b56
> Authentication: Basic
> Server: thin 1.2.11 codename Bat-Shit Crazy
> Accept: application/xml
> 
> 
> Completed in 0.000000 | 0.000000 | 201 | application/xml | http://localhost:3002/api/instances
> 
> Then the instance is started but floppy is not mounted in /media/deltacloud-user-data.txt,
/dev/fd0 doesn't exist:
> [root@10-16-120-207 ~]# ls -l /media
> total 0
> [root@10-16-120-207 ~]# ls /dev/fd0
> ls: cannot access /dev/fd0: No such file or directory
> [root@10-16-120-207 ~]# 
> 
> Nothing related to floppy is in logs, on RHEVM server I can see that floppyinject data
arrived (this is from different request then above dc-api request, so user-data string might
be different):
> 
> 2012-06-19 03:46:57,017 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand]
(http-0.0.0.0-8443-3) org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand kvmEnable=true,nicModel=pv,keyboardLayout=en-us,nice=0,pitReinjection=false,displayNetwork=rhevm,timeOffset=0,transparentHugePages=true,drives=[Ljava.util.Map;@6147386e,vmId=2bacd7a7-b01d-4b69-840e-6c16421bee5e,acpiEnable=true,custom={floppyinject=deltacloud-user-data.txt:TVh4b2RIUndjem92TDJSbFlXUmtiMjVyWlhrdWRYTmxjbk41Y3k1eVpXUm9ZWFF1WTI5dGZHUmpZV1V3WmpNMkxXSTVaVEl0TVRGbE1TMDRZV0ZpTFdVNE16a3pOV015TVdZeVkzeDJWSE5HZUdWRlkyMUxXRXBQWlZCdU56WjNNM2h6UXpoSVl6bG9XV1V4ZFRSUVRtWmhXWGhSTTNKTVoySk5WRVJ4},spiceSslCipherSuite=DEFAULT,memSize=512,boot=dc,smp=1,emulatedMachine=rhel6.2.0,vmType=kvm,display=qxl,spiceSecureChannels=smain,sinputs,smpCoresPerSocket=1,spiceMonitors=1,macAddr=00:1a:4a:10:78:2f,bridge=rhevm,vmName=jprovazn4-RHELRHEVMInstance,cpuType=Nehalem
> 
> Also it doesn't matter what user data I pass, same result when I pass 'xxxxx' string.
> 
> Any idea why it doesn't work?
> 
>  was:
> When sending this dc-api request:
> Processing /api/instances (for 127.0.0.1 at Tue Jun 19 02:56:35 -0400 2012) [POST] [RHEVM]
> Parameters: {"image_id"=>"66a522d5-eb4e-4402-9f8f-d56da46f1337", "name"=>"jprovazn1-RHELRHEVMInstance",
"realm_id"=>"a9347fb8-5976-11e1-a53e-5254005809b7", "hwp_memory"=>"512", "keyname"=>"",
"hwp_id"=>"SERVER", "hwp_cpu"=>"1", "hwp_storage"=>"6", "user_data"=>"TVh4b2RIUndjem92TDJSbFlXUmtiMjVyWlhrdWRYTmxjbk41Y3k1eVpXUm9Z\nWFF1WTI5dGZHVTRNRFEyTUdVMExXSTVaR0l0TVRGbE1TMDRZV0ZpTFdVNE16\na3pOV015TVdZeVkzeE5XazVVY1VaSGIwWkxkVkJNVW5SdlQwaFlRVU56Y0U1\naFVrNDNTa3hET0hkME0wZGtNSFJHZGpCT2QzWjROMnM9\n"}
> Provider: https://10.16.120.230:8443/api;9754dc7f-489e-49dd-99d0-2c2ea7657b56
> Authentication: Basic
> Server: thin 1.2.11 codename Bat-Shit Crazy
> Accept: application/xml
> 
> 
> Completed in 0.000000 | 0.000000 | 201 | application/xml | http://localhost:3002/api/instances
> 
> Then the instance is started but floppy is not mounted in /media/deltacloud-user-data.txt,
/dev/fd0 doesn't exist:
> [root@10-16-120-207 ~]# ls -l /media
> total 0
> [root@10-16-120-207 ~]# ls /dev/fd0
> ls: cannot access /dev/fd0: No such file or directory
> [root@10-16-120-207 ~]# 
> 
> Nothing related to floppy is in logs, on RHEVM server I can see that floppyinject data
arrived (this is from different request then above dc-api request, so user-data string might
be different):
> 
> 2012-06-19 03:46:57,017 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand]
(http-0.0.0.0-8443-3) org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand kvmEnable=true,nicModel=pv,keyboardLayout=en-us,nice=0,pitReinjection=false,displayNetwork=rhevm,timeOffset=0,transparentHugePages=true,drives=[Ljava.util.Map;@6147386e,vmId=2bacd7a7-b01d-4b69-840e-6c16421bee5e,acpiEnable=true,custom={floppyinject=deltacloud-user-data.txt:TVh4b2RIUndjem92TDJSbFlXUmtiMjVyWlhrdWRYTmxjbk41Y3k1eVpXUm9ZWFF1WTI5dGZHUmpZV1V3WmpNMkxXSTVaVEl0TVRGbE1TMDRZV0ZpTFdVNE16a3pOV015TVdZeVkzeDJWSE5HZUdWRlkyMUxXRXBQWlZCdU56WjNNM2h6UXpoSVl6bG9XV1V4ZFRSUVRtWmhXWGhSTTNKTVoySk5WRVJ4},spiceSslCipherSuite=DEFAULT,memSize=512,boot=dc,smp=1,emulatedMachine=rhel6.2.0,vmType=kvm,display=qxl,spiceSecureChannels=smain,sinputs,smpCoresPerSocket=1,spiceMonitors=1,macAddr=00:1a:4a:10:78:2f,bridge=rhevm,vmName=jprovazn4-RHELRHEVMInstance,cpuType=Nehalem
> 
> Any idea why it doesn't work?
> 
> 
>> floppyinject silently fails on RHEVM
>> ------------------------------------
>> 
>>                Key: DTACLOUD-241
>>                URL: https://issues.apache.org/jira/browse/DTACLOUD-241
>>            Project: DeltaCloud
>>         Issue Type: Bug
>>        Environment: deltacloud-core-0.5.0-10.el6_2.noarch
>> deltacloud-core-rhevm-0.5.0-10.el6_2.noarch
>>           Reporter: Jan Provaznik
>> 
>> When sending this dc-api request:
>> Processing /api/instances (for 127.0.0.1 at Tue Jun 19 02:56:35 -0400 2012) [POST]
[RHEVM]
>> Parameters: {"image_id"=>"66a522d5-eb4e-4402-9f8f-d56da46f1337", "name"=>"jprovazn1-RHELRHEVMInstance",
"realm_id"=>"a9347fb8-5976-11e1-a53e-5254005809b7", "hwp_memory"=>"512", "keyname"=>"",
"hwp_id"=>"SERVER", "hwp_cpu"=>"1", "hwp_storage"=>"6", "user_data"=>"TVh4b2RIUndjem92TDJSbFlXUmtiMjVyWlhrdWRYTmxjbk41Y3k1eVpXUm9Z\nWFF1WTI5dGZHVTRNRFEyTUdVMExXSTVaR0l0TVRGbE1TMDRZV0ZpTFdVNE16\na3pOV015TVdZeVkzeE5XazVVY1VaSGIwWkxkVkJNVW5SdlQwaFlRVU56Y0U1\naFVrNDNTa3hET0hkME0wZGtNSFJHZGpCT2QzWjROMnM9\n"}
>> Provider: https://10.16.120.230:8443/api;9754dc7f-489e-49dd-99d0-2c2ea7657b56
>> Authentication: Basic
>> Server: thin 1.2.11 codename Bat-Shit Crazy
>> Accept: application/xml
>> Completed in 0.000000 | 0.000000 | 201 | application/xml | http://localhost:3002/api/instances
>> Then the instance is started but floppy is not mounted in /media/deltacloud-user-data.txt,
/dev/fd0 doesn't exist:
>> [root@10-16-120-207 ~]# ls -l /media
>> total 0
>> [root@10-16-120-207 ~]# ls /dev/fd0
>> ls: cannot access /dev/fd0: No such file or directory
>> [root@10-16-120-207 ~]# 
>> Nothing related to floppy is in logs, on RHEVM server I can see that floppyinject
data arrived (this is from different request then above dc-api request, so user-data string
might be different):
>> 2012-06-19 03:46:57,017 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand]
(http-0.0.0.0-8443-3) org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand kvmEnable=true,nicModel=pv,keyboardLayout=en-us,nice=0,pitReinjection=false,displayNetwork=rhevm,timeOffset=0,transparentHugePages=true,drives=[Ljava.util.Map;@6147386e,vmId=2bacd7a7-b01d-4b69-840e-6c16421bee5e,acpiEnable=true,custom={floppyinject=deltacloud-user-data.txt:TVh4b2RIUndjem92TDJSbFlXUmtiMjVyWlhrdWRYTmxjbk41Y3k1eVpXUm9ZWFF1WTI5dGZHUmpZV1V3WmpNMkxXSTVaVEl0TVRGbE1TMDRZV0ZpTFdVNE16a3pOV015TVdZeVkzeDJWSE5HZUdWRlkyMUxXRXBQWlZCdU56WjNNM2h6UXpoSVl6bG9XV1V4ZFRSUVRtWmhXWGhSTTNKTVoySk5WRVJ4},spiceSslCipherSuite=DEFAULT,memSize=512,boot=dc,smp=1,emulatedMachine=rhel6.2.0,vmType=kvm,display=qxl,spiceSecureChannels=smain,sinputs,smpCoresPerSocket=1,spiceMonitors=1,macAddr=00:1a:4a:10:78:2f,bridge=rhevm,vmName=jprovazn4-RHELRHEVMInstance,cpuType=Nehalem
>> Also it doesn't matter what user data I pass, same result when I pass 'xxxxx' string.
>> Any idea why it doesn't work?
> 
> --
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
> For more information on JIRA, see: http://www.atlassian.com/software/jira
> 
> 

Mime
View raw message