deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ramesh A (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DTACLOUD-230) Clicking on "Create new address" button in the web-ui results in 404 error
Date Tue, 12 Jun 2012 08:39:42 GMT

    [ https://issues.apache.org/jira/browse/DTACLOUD-230?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13293451#comment-13293451
] 

Ramesh A commented on DTACLOUD-230:
-----------------------------------

Hi Marios,

Patch seems to work fine for create new address button.  However when we try to click on the
associate button in the next page, dc shows "Sinatra doesn’t know this ditty."  Also, 404
exception is thrown in the terminal.  "127.0.0.1 - - [12/Jun/2012 14:10:50] "GET /api/__sinatra__/404.png
HTTP/1.1" 404 463 0.0309"

Thanks,
Ramesh A
                
> Clicking on "Create new address" button in the web-ui results in 404 error
> --------------------------------------------------------------------------
>
>                 Key: DTACLOUD-230
>                 URL: https://issues.apache.org/jira/browse/DTACLOUD-230
>             Project: DeltaCloud
>          Issue Type: Bug
>          Components: Client (Ruby), Server
>         Environment: OS- RHEL 6.2, Fedora 16
> [root@server ~]# rpm -qa| grep deltacloud
> deltacloud-core-ec2-0.6.0-2.el6.noarch
> deltacloud-core-0.6.0-2.el6.noarch
> deltacloud-core-all-0.6.0-2.el6.noarch
> deltacloud-core-rhevm-0.6.0-2.el6.noarch
> deltacloud-core-doc-0.6.0-2.el6.noarch
> deltacloud-core-vsphere-0.6.0-2.el6.noarch
> Also, found in commit - c71c8cceee27fb356651fd3100dc2ac6fd83accd
>            Reporter: Ramesh A
>            Assignee: Ramesh A
>         Attachments: 0001-Fix-for-DTACLOUD-230-new-Address-via-HTML-UI.patch
>
>
> Clicking on "Create new address" button in the web-ui results in 404 error
> Reproduction Steps:
> ===============
> 1. In the Web-ui click on the Addresses
> 2. Click on the "Create new address" button in the Addresses module
> Results:
> ======
> Nothing happens in the Web-ui, but throws 404 error in the Log.
> Log Snippet
> ==========
> 10.11.11.173 - - [11/Jun/2012 13:44:48] "GET /api/addresses?format=xml HTTP/1.1" 200
65 0.1637
> 10.11.11.173 - - [11/Jun/2012 13:45:01] "POST /api/create_address HTTP/1.1" 404 487 0.0408

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message