deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Fojtik <mfoj...@redhat.com>
Subject Re: [PATCH] Updated .gemspec to require fog >= 1.4.0
Date Wed, 27 Jun 2012 11:22:20 GMT
ACK.

Michal Fojtik
http://deltacloud.org
mfojtik@redhat.com



On Jun 27, 2012, at 10:51 AM, marios@redhat.com wrote:

> From: marios <marios@redhat.com>
> 
> Resolves issue with deltacloud install on rhel
> (gem versions conflict for excon)
> Also, require excon > 0.14.2 because of
> https://github.com/geemus/excon/pull/128
> 
> resolves JIRA DTACLOUD_242
> https://issues.apache.org/jira/browse/DTACLOUD-242
> 
> Signed-off-by: marios <marios@redhat.com>
> ---
> server/deltacloud-core.gemspec |    4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/server/deltacloud-core.gemspec b/server/deltacloud-core.gemspec
> index c69aed5..cd466ec 100644
> --- a/server/deltacloud-core.gemspec
> +++ b/server/deltacloud-core.gemspec
> @@ -91,8 +91,8 @@ Gem::Specification.new do |s|
>   s.add_dependency('cloudfiles')
> 
> # Terremark Vcloud Express
> -  s.add_dependency('fog')
> -  s.add_dependency('excon')
> +  s.add_dependency('fog', '>= 1.4.0')
> +  s.add_dependency('excon', '>= 0.14.2' )
> 
> # Rhevm and Condor Cloud
>   s.add_dependency('rest-client')
> -- 
> 1.7.6.5
> 


Mime
View raw message