deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ronelle Landy (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DTACLOUD-207) GET /api/images/:id - XML and JSON output do not show 'destroy/delete' as an action for images
Date Thu, 03 May 2012 20:12:48 GMT

     [ https://issues.apache.org/jira/browse/DTACLOUD-207?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ronelle Landy updated DTACLOUD-207:
-----------------------------------

    Assignee: Marios Andreou  (was: David Lutterkort)
    
>  GET /api/images/:id - XML and JSON output do not show 'destroy/delete' as an action
for images
> -----------------------------------------------------------------------------------------------
>
>                 Key: DTACLOUD-207
>                 URL: https://issues.apache.org/jira/browse/DTACLOUD-207
>             Project: DeltaCloud
>          Issue Type: Bug
>          Components: Server
>         Environment: Deltacloud git commit version: c13da7b50bbbbdc529b42207f58dbe5099006ad1
> RHEL 6.2, Fedora 16
> Openstack V2.0 ( not Openstack specific)
>            Reporter: Ronelle Landy
>            Assignee: Marios Andreou
>
> Destroying images: the XML  and JSON output do not show 'destroy/delete' as an action
for images. User are able to delete/destroy an image using the Deltacloud GUI.
> >> curl -X GET --user "<un>:<pw>" "http://qe-blade-14.idm.lab.bos.redhat.com:3008/api/images/8215?format=xml"
> <?xml version='1.0' encoding='utf-8' ?>
> <image href='http://qe-blade-14.idm.lab.bos.redhat.com:3008/api/images/8215' id='8215'>
>   <name>myImage</name>
>   <owner_id>XXXX</owner_id>
>   <description>myImage</description>
>   <architecture>x86_64</architecture>
>   <state>ACTIVE</state>
>   <hardware_profiles>
>     <hardware_profile href='http://qe-blade-14.idm.lab.bos.redhat.com:3008/api/hardware_profiles/100'
id='100' rel='hardware_profile'></hardware_profile>
>     <hardware_profile href='http://qe-blade-14.idm.lab.bos.redhat.com:3008/api/hardware_profiles/101'
id='101' rel='hardware_profile'></hardware_profile>
>     <hardware_profile href='http://qe-blade-14.idm.lab.bos.redhat.com:3008/api/hardware_profiles/105'
id='105' rel='hardware_profile'></hardware_profile>
>     <hardware_profile href='http://qe-blade-14.idm.lab.bos.redhat.com:3008/api/hardware_profiles/103'
id='103' rel='hardware_profile'></hardware_profile>
>     <hardware_profile href='http://qe-blade-14.idm.lab.bos.redhat.com:3008/api/hardware_profiles/102'
id='102' rel='hardware_profile'></hardware_profile>
>     <hardware_profile href='http://qe-blade-14.idm.lab.bos.redhat.com:3008/api/hardware_profiles/104'
id='104' rel='hardware_profile'></hardware_profile>
>   </hardware_profiles>
>   <actions>
>     <link href='http://qe-blade-14.idm.lab.bos.redhat.com:3008/api/instances;image_id=8215'
method='post' rel='create_instance' />
>   </actions>
> </image>
> ************************
> Note from Marios:
> jira please - this is not an openstack specific issue - looking at the haml template,
seems like we ommit the destroy action from /images/show.xml.haml

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message