deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mfoj...@redhat.com
Subject [PATCH core 45/51] Core: Replaced 'require' with 'require_relative' to keep loading of core extensions working under MRI 1.9
Date Mon, 21 May 2012 10:07:26 GMT
From: Michal Fojtik <mfojtik@redhat.com>


Signed-off-by: Michal fojtik <mfojtik@redhat.com>
---
 server/lib/deltacloud/core_ext.rb |   10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/server/lib/deltacloud/core_ext.rb b/server/lib/deltacloud/core_ext.rb
index b54df66..edaaa00 100644
--- a/server/lib/deltacloud/core_ext.rb
+++ b/server/lib/deltacloud/core_ext.rb
@@ -14,8 +14,8 @@
 # under the License.
 #
 
-require 'deltacloud/core_ext/array'
-require 'deltacloud/core_ext/hash'
-require 'deltacloud/core_ext/integer'
-require 'deltacloud/core_ext/proc'
-require 'deltacloud/core_ext/string'
+require_relative './core_ext/array'
+require_relative './core_ext/hash'
+require_relative './core_ext/integer'
+require_relative './core_ext/proc'
+require_relative './core_ext/string'
-- 
1.7.10.1


Mime
View raw message