deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michal Fojtik (Resolved) (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (DTACLOUD-97) Unable to launch server on F14 x86_64 with latest deltacloud commit
Date Tue, 21 Feb 2012 12:07:34 GMT

     [ https://issues.apache.org/jira/browse/DTACLOUD-97?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michal Fojtik resolved DTACLOUD-97.
-----------------------------------

    Resolution: Won't Fix
    
> Unable to launch server on F14 x86_64 with latest deltacloud commit 
> --------------------------------------------------------------------
>
>                 Key: DTACLOUD-97
>                 URL: https://issues.apache.org/jira/browse/DTACLOUD-97
>             Project: DeltaCloud
>          Issue Type: Bug
>          Components: Client (Ruby)
>         Environment: OS - F14 x86_64
> Deltacloud API 0.4.1
> Sinatra versions - 1.2.1
> commit 2f02a4ba0ec19a41fa1753c89bc9ddbcaa202243
>            Reporter: Ramesh A
>            Assignee: David Lutterkort
>            Priority: Blocker
>
> Unable to launch the deltacloud server for any cloud provider.  Following error message
is seen in the console when trying to start the Deltacloud server.
> This setup works fine for F15 with Sinatra version 1.3.1
> Tested for EC2, RHEVM, VSPHERE.
> Stack Trace:
> ==========
> [root@dhcp201-161 server]# ./bin/deltacloudd -i ec2 -r dhcp201-161.englab.pnq.redhat.com
-p 3003
> Starting Deltacloud API :: ec2 :: http://dhcp201-161.englab.pnq.redhat.com:3003/api
> 15:27:54 - Server Launched
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.5/lib/ses/../awsbase/utils.rb:105: warning: already
initialized constant HEX
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.5/lib/ses/../awsbase/utils.rb:107: warning: already
initialized constant TO_REMEMBER
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.5/lib/ses/../awsbase/utils.rb:108: warning: already
initialized constant ASCII
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.5/lib/ses/../awsbase/errors.rb:128: warning: already
initialized constant DEFAULT_CLOSE_ON_4XX_PROBABILITY
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.5/lib/ses/../awsbase/parsers.rb:47: warning: already
initialized constant DEFAULT_XML_LIBRARY
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.5/lib/ses/../awsbase/awsbase.rb:66: warning: already
initialized constant AMAZON_PROBLEMS
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.5/lib/ses/../awsbase/awsbase.rb:86: warning: already
initialized constant DEFAULT_SIGNATURE_VERSION
> (__DELEGATE__):2:in `settings': stack level too deep (SystemStackError)
> 	from (__DELEGATE__):2:in `send'
> 	from (__DELEGATE__):2:in `settings'
> 	from (__DELEGATE__):2:in `send'
> 	from (__DELEGATE__):2:in `settings'
> 	from (__DELEGATE__):2:in `send'
> 	from (__DELEGATE__):2:in `settings'
> 	from (__DELEGATE__):2:in `send'
> 	from (__DELEGATE__):2:in `settings'
> 	 ... 1573 levels...
> 	from /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/builder.rb:46:in `instance_eval'
> 	from /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/builder.rb:46:in `initialize'
> 	from ./bin/../config.ru:1:in `new'
> 	from ./bin/../config.ru:1

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message