deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "marios@redhat.com" <mandr...@redhat.com>
Subject Re: GETTING STARTED WITH DELTACLOUD
Date Fri, 04 Nov 2011 17:14:06 GMT
Hi Tom,

I just spent some time looking at this:

On 01/11/11 20:22, Tom Wlodek wrote:
> and I did step by step the instructions. First the prerequisites:

> End of prerequisites. so far so good. But when I do
> 
> gem install deltacloud-core
> ERROR:  Error installing deltacloud-core:
>     fog requires net-ssh (~>  2.1.4, runtime)
> 

I tried to recreate this but was not able to (though I can see what the
problem is with the net-ssh version.. more below). Can you tell us what
OS/version you are using (I tried to recreate with a vanilla fedora 15
intallation).

Ok, the deltacloud gem pulls in the fog gem. It seems fog introduced the
dependency ~> 2.1.4 since fog version 0.10.0. When you install
deltacloud-core, the .gemspec should ensure you get version 2.1.4 of
net-ssh as required by fog. One way you may have ended up with version
2.2.1 (which is in fact the latest), is if you already had it (e.g. due
to some unrelated installation/dependency).
> but when I do
> 
>  gem list
> 
> I get
> ...
> 
> net-ssh (2.2.1)
> 
> so I have net-ssh installed.
> 
> Any ideas?

Just fyi, you could have removed the net-ssh 2.2.1 and explicitly
installed the version that was required:

gem uninstall net-ssh

gem install net-ssh -v 2.1.4

If you had then run gem install deltacloud-core it should have run fine.
But this is besides the point, we want the install to be as painless as
possible so any info you can provide about your setup will help me to
investigate further,

thanks for reporting the issue, marios


> 
> Tom W
> 
> |
> 
> 


Mime
View raw message