deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ramesh A (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DTACLOUD-90) Error/warning message observed for different versions of Sinatra for Deltacloud API
Date Mon, 10 Oct 2011 14:47:32 GMT

     [ https://issues.apache.org/jira/browse/DTACLOUD-90?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ramesh A updated DTACLOUD-90:
-----------------------------

    Summary: Error/warning message observed for different versions of Sinatra for Deltacloud
API  (was: Error/warning message observed for different versions of Sinatra Deltacloud)
    
> Error/warning message observed for different versions of Sinatra for Deltacloud API
> -----------------------------------------------------------------------------------
>
>                 Key: DTACLOUD-90
>                 URL: https://issues.apache.org/jira/browse/DTACLOUD-90
>             Project: DeltaCloud
>          Issue Type: Bug
>          Components: Client (Ruby)
>         Environment: OS- F15 x86_64
> Dcloud API 0.4.1 
> Sinatra versions - 1.3.1, 1.2.1
>            Reporter: Ramesh A
>            Assignee: David Lutterkort
>
> Error/warning message is observed for different version of Sinatra
> Screnario-1:
> =========
> Sinatra version 1.3.1 
> Dcloud API 0.4.1
> OS - F15 x86_64
> Result:
> ======
> When trying to access any module links, following warning message is observed,
>   [WARN: /usr/lib/ruby/gems/1.8/gems/sinatra-1.3.1/lib/sinatra/base.rb:732:in `options']:
"Sinatra::Base#options is deprecated and will be removed, use #settings instead."
> Stack trace:
> =========
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.6/lib/ses/../awsbase/awsbase.rb:66: warning: already
initialized constant AMAZON_PROBLEMS
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.6/lib/ses/../awsbase/awsbase.rb:86: warning: already
initialized constant DEFAULT_SIGNATURE_VERSION
> >> Thin web server (v1.2.11 codename Bat-Shit Crazy)
> >> Debugging ON
> >> Maximum connections set to 1024
> >> Listening on cavenger.lab.eng.pnq.redhat.com:3003, CTRL+C to stop
> [WARN: /usr/lib/ruby/gems/1.8/gems/sinatra-1.3.1/lib/sinatra/base.rb:732:in `options']:
"Sinatra::Base#options is deprecated and will be removed, use #settings instead."
> [WARN: /usr/lib/ruby/gems/1.8/gems/sinatra-1.3.1/lib/sinatra/base.rb:732:in `options']:
"Sinatra::Base#options is deprecated and will be removed, use #settings instead."
> 10.11.9.240 - - [10/Oct/2011 19:05:29] "GET /api HTTP/1.1" 200 3460 0.0428
> 10.11.9.240 - - [10/Oct/2011 19:05:30] "GET /stylesheets/jquery.mobile-1.0b1.min.css
HTTP/1.1" 200 42005 0.0596
> 10.11.9.240 - - [10/Oct/2011 19:05:30] "GET /stylesheets/new.css HTTP/1.1" 200 1362 0.0018
> Scenario - 2:
> ==========
> Sinatra version 1.2.1 
> Dcloud API 0.4.1
> OS - F15 x86_64
> Result:
> ======
> Error message is observed while starting the Dcloud server.  Please find the below mentioned
stack
> Stack Trace:
> ==========
> [root@cavenger server]# ./bin/deltacloudd -i ec2 -r cavenger.lab.eng.pnq.redhat.com -p
3003
> Starting Deltacloud API :: ec2 :: http://cavenger.lab.eng.pnq.redhat.com:3003/api
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.6/lib/ses/../awsbase/utils.rb:105: warning: already
initialized constant HEX
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.6/lib/ses/../awsbase/utils.rb:107: warning: already
initialized constant TO_REMEMBER
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.6/lib/ses/../awsbase/utils.rb:108: warning: already
initialized constant ASCII
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.6/lib/ses/../awsbase/errors.rb:128: warning: already
initialized constant DEFAULT_CLOSE_ON_4XX_PROBABILITY
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.6/lib/ses/../awsbase/parsers.rb:47: warning: already
initialized constant DEFAULT_XML_LIBRARY
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.6/lib/ses/../awsbase/awsbase.rb:66: warning: already
initialized constant AMAZON_PROBLEMS
> /usr/lib/ruby/gems/1.8/gems/aws-2.5.6/lib/ses/../awsbase/awsbase.rb:86: warning: already
initialized constant DEFAULT_SIGNATURE_VERSION
> ./bin/../lib/sinatra/rabbit.rb:106:in `options': wrong number of arguments (1 for 0)
(ArgumentError)
> 	from ./bin/../lib/sinatra/rabbit.rb:106:in `generate_options'
> 	from ./bin/../lib/sinatra/rabbit.rb:70:in `initialize'
> 	from ./bin/../lib/sinatra/rabbit.rb:294:in `new'
> 	from ./bin/../lib/sinatra/rabbit.rb:294:in `operation'
> 	from ./bin/../server.rb:122
> 	from ./bin/../lib/sinatra/rabbit.rb:210:in `instance_eval'
> 	from ./bin/../lib/sinatra/rabbit.rb:210:in `initialize'
> 	from ./bin/../lib/sinatra/rabbit.rb:392:in `new'
> 	from ./bin/../lib/sinatra/rabbit.rb:392:in `collection'
> 	from (__DELEGATE__):2:in `send'
> 	from (__DELEGATE__):2:in `collection'
> 	from ./bin/../server.rb:115
> 	from ./bin/../config.ru:23:in `load'
> 	from ./bin/../config.ru:23
> 	from /usr/lib/ruby/gems/1.8/gems/rack-1.3.4/lib/rack/builder.rb:51:in `instance_eval'
> 	from /usr/lib/ruby/gems/1.8/gems/rack-1.3.4/lib/rack/builder.rb:51:in `initialize'
> 	from ./bin/../config.ru:1:in `new'
> 	from ./bin/../config.ru:1
> Note:
> ====
> This is not observed in the Sinatra version 1.0.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message