deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Fojtik <>
Subject Re: syslog in DeltaCloud 0.4.0
Date Thu, 08 Sep 2011 09:02:45 GMT

On Sep 7, 2011, at 11:09 PM, Tong Li wrote:

> Tried DC RC 4 with ruby 1.9.1 and latest dependencies and found quite few problems.
> The RC4 was downloaded here and seemed it was posted on 8/24. 
> 1. This should be just a bug.
> views/instances/show.html.haml has errors, it should have never worked.
> both line 31 and 34 has code like this.
> %p{ :'data-role' => 'fieldcontain'}',')
> the map.join should not have worked.

It works:

irb(main):001:0> [1,2,3,4].map.join(',')
=> "1,2,3,4"

However you raised a valid point, because the map there is completely meaningless in this
context and should be removed.

> it needs to be changed to 
> %p{ :'data-role' => 'fieldcontain'}=@instance.public_addresses.join(',')
> 2. incorrectly use "lib" in the require path, this causes big problem for others to use
DC gem. There are two places
> base_driver/base_driver.rb
> sinatra/rack_syslog.rb
> both files have some thing like this
> require 'lib/xxxxx'
> They should be changed to 
> require 'xxxxx'
> 3. In base_driver/features.rb, it still uses ordinalize method from an integer, which
has been removed in newer active_support package,

AFAIK we should be 'active_support' free. If we're using this method it must be defined locally
or be part
of integer class in 1.8.7.

> 4. i18n is a dependency , but was not stated in the spec. 

This is a 'active_support' dependency which again, should be not required anymore. If it is,
it's a bug.
Btw. what driver you're using? EC2?

> 5. nokogiri requires some other dependency which is not available on 64 bits platform,
forgot the name of it, when I tried to gem install, it did a local build, then blows up because
it was trying to use 32 libraries on windows.
> 6. syslog is not available on windows platform, both item 5 and 6 really hurts. I had
to setup an Ubuntu 11.04 machine to do my development.

Sorry for this dependency, I did not realized that it should be a problem on Windows. I think
we should subclass
syslog class and add fallback to windows registry instead. However for development I though
syslog is turned off
by default.

> 7. new RC4 is extremely slow. I run 0.4.0 and 0.3.0 on the same machine, 0.4.0 took a
lot longer from user point view. not sure if it has anything to do with the newer UI or because
of the thin server which is now required. Any reason why switch it from WEBrick?

Thin server was required from the start. If deltacloud doesn't have this gem installed it
fall back to Webrick.
Could you be more descriptive what is slow? From 0.3.0 we have special HTTP header 'X-Runtime'
in response headers,
that hold information about how long did it take to generate a response. 
If those times differs a lot from 0.3.0 it looks like a bug.

> is there any way these problems can be fixed? or they have been fixed in newer builds?
If I can access the source, I do not mind to fix them. I think that problems described in
1 to 4 should really be fixed ASAP.

I'll look on them ASAP. Probably best way how to report bugs is our JIRA (
where you can then track status of the bug.

 -- Michal

> David Lutterkort ---09/06/2011 07:17:45 PM---On Tue, 2011-09-06 at 15:40 -0400, Tong
Li wrote: > finally had time to try this rc4, however, syslo
> From:	David Lutterkort <>
> To:
> Date:	09/06/2011 07:17 PM
> Subject:	Re: syslog in DeltaCloud 0.4.0
> On Tue, 2011-09-06 at 15:40 -0400, Tong Li wrote:
> > finally had time to try this rc4, however, syslog is now needed by few
> > files in DC.  unfortunately syslog is not available on windows platform, so
> > somehow this release becomes platform specific. is this really intended? am
> > I missing something?
> No, the intent is not to make it platform specific - we need to figure
> out how to replace syslog on Windows. Should probably fall back to
> writing to stdout. Or do you know of a more elegant fallback ?
> David

Michal Fojtik,
Deltacloud API:

View raw message